Solved

unable to grant permission for network access

Posted on 2004-08-24
15
232 Views
Last Modified: 2013-12-04
I have two Win Xp computers on a network, using a Linksys router as a hub and ICS.  The ICS works fine.  Computer A (sharing its connection) can access Computer B.  Computer B can see the other Computer A in the workgroup, can ping it and see it using net view, but cannot access it.  I have tried it with simple sharing turned on and off.  I have tried to change the "Access this computer from the network" in User Rights Assignment on Computer A, I can locate Computer B in the list of locations, but when I try to Apply it, it says "Failed to Save Local Policy Database"

Is there something else I should be changing?  Why will it not save the local policy database?
0
Comment
Question by:pjfromny
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
15 Comments
 
LVL 8

Expert Comment

by:RevelationCS
ID: 11895631
do you have firewalls running on either one of the pcs? also, have you tried to connect to the computers by using the administrative shares (usually \\computername\driveletter$) to see if you can access it that way.
0
 

Author Comment

by:pjfromny
ID: 11901228
There's an internet firewall (Windows) on the ICS computer, but I've disconnected it from the internet, tkarn off the firewall, and still get the same results wrrt network.

I'm not sure how to use the administrative shares; where do I get to that?

I can use ping and net view and make contact with computer A from B using those options.  Just can't double click the computer icon under workgroup computers and access anything.  The error message says that Computer A is not accessible.
0
 
LVL 8

Expert Comment

by:RevelationCS
ID: 11902746
well, since you are doing more of a peer to peer type network, you are going to be more prone to issues such as this (I have seen it in the past with other networks set up peer to peer)... what type of connection do you have to the internet and if you are using broadband, why are you using ICS? To use the administrative shares, open up the run menu and type \\computername\drive$ (ie \\ComputerA\c$). It might prompt you for a User ID and password, if so, enter it in. Also, you might be having issues based on userids and permissions between the two pcs as to why those shares are not showing. This would explain why you are able to ping/etc but not access it via Network Neighborhood... Check the permissions on your shares and make sure the same IDs are set up on both PCs (same UIDs and PWDs) and see if that works for you.
0
Webinar: Aligning, Automating, Winning

Join Dan Russo, Senior Manager of Operations Intelligence, for an in-depth discussion on how Dealertrack, leading provider of integrated digital solutions for the automotive industry, transformed their DevOps processes to increase collaboration and move with greater velocity.

 

Author Comment

by:pjfromny
ID: 11903331
The internet connection is dial-up.  Its my only option.  I don't have broadband.  I realize that its an unusual setup.  I'm useing a linksys router as a hub (have set the IP addresses).  I am following the recommendation of linksys for this set-up: to use the router as a hub and use ICS for the internet.

When I check the permissions on the shares of Computer A, "NETWORK" is a group listed as having permission.  But if I try to add any other users or groups, the other computer (B) is not available as a location, only the local computer is available.

When I use the administrative shares from B, it tells me "multiple connections to a server or shared resource by the same user are not allowed."  So there's some connection there apparently, but when I use the icons in workgroup, it tells me access is denied.

This setup worked several weeks ago.  I crashed the hard drive of Computer A and had to reinstall everything.  So, I believe that there is some setting that I had worked out before that was changed when I had to reinstall everything.  I've checked everything I can think of, however.
0
 
LVL 8

Expert Comment

by:RevelationCS
ID: 11904897
the permissions would have to be set up on the local pc as you do not have a domain to pull permissions from. As stated above, set up the same users/pwds on both pcs then make sure they are added to the appropriate permissions to grant access...

which version of XP do you have? I would take a look at what shares might be open by doing a "net use" from a command prompt....
0
 

Author Comment

by:pjfromny
ID: 11905476
XP Pro

I have added the same users to both computers.

When I do net use from computer B (the one which is unable to access the other) I get the following.  Dimension is the name of the computer I am trying to access (A).


C:\Documents and Settings\Garrie>net use

New connections will be remembered.

 Status       Local     Remote                    Network


-------------------------------------------------------------------------------

OK                     \\Dimension\IPC$          Microsoft Windows Network

The command completed successfully
0
 
LVL 8

Expert Comment

by:RevelationCS
ID: 11905559
also, have you tried taking a look at the following K-base article?

http://support.microsoft.com/default.aspx?scid=kb;en-us;304040
0
 
LVL 8

Expert Comment

by:RevelationCS
ID: 11905578
looking further at that doc, have you upgraded to SP2 for XP yet? if so, your firewall is most likely the issue....

"For remote users to access files from the network (Levels 4 and 5), the Internet Connection Firewall (ICF) must be disabled on the network interface that the remote users connect through."
0
 

Author Comment

by:pjfromny
ID: 11906264
Have looked at doc before; didn't find anything that was of any help.

Have not upgraded to SP2
0
 
LVL 8

Expert Comment

by:RevelationCS
ID: 11906402
is your firewall on?
0
 

Author Comment

by:pjfromny
ID: 11906614
At the moment, firewall is on ICS, not on LAN.  I do not want to connect to the internet without it (just cleaned up a mess).  However, I have disconnected the phone line from the computer, removed the firewall, rebooted the computers, and still no network.

0
 
LVL 8

Expert Comment

by:RevelationCS
ID: 11917701
also, have you tried to connect to the server by using \\serveripaddress\servershare? (ie \\192.168.1.200\c$)
0
 

Author Comment

by:pjfromny
ID: 11918003
yes,

If I use \\Dimension (which is the computer's name) from Run, I get the same error message as when I click on the icon, which is:

Dimension is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Access is denied.

If I type in the name of a share, eg. \\Dimension\C$, it says:

Multiple connections to a server or a shared resource, using more tha one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.
0
 

Author Comment

by:pjfromny
ID: 11918808
if I enter the IP address with a share, it returns a password box.  If I type in the name of the computer/username it returns the same password box.  There is not a password on that account, and I don't know how to set one.  I try the Administrator's password but get the same result.

On the server, if I go into Computer management, and look at shared folders, and then sessions, the user and computer name to whom I am trying to get access is listed (twice actually).  There are no open files and it is marked yes as a Guest account.

Does this get us anywhere?
0
 
LVL 8

Accepted Solution

by:
RevelationCS earned 500 total points
ID: 11919003
you need to have a valid user account with a password to access a share over the network which is why I told you to set up the same user ids and passwords on BOTH of the boxes...

ie:
account used on PC1
Username: mmouse
password: disney

same needs to be set up on PC2

I do not believe guest will work for file sharing with the new versions of windows...
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is a guide to the following problem (not exclusive but here) on Windows: Users need our support and we supporters often use global administrative accounts to do this. Using these accounts safely is a real challenge. Any admin who takes se…
Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question