[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 243
  • Last Modified:

Two exchange servers working in 1 domain on 1 site

Our exchange server had reached it's storage capacity. (16gb - it's only a Standard Edition 2000 Exchange Server)

So, we installed a second exchange server which was an Enterprise Edition 2000 Exchange Server.

I moved some of the users mailboxes over and it all 'looked' ok. Users could open outlook and read there emails.

However, they could send emails to anybody, but they could not receive emails from anywhere either internal or external.

I can see all the emails that are supposed to be delivered to the new server (or these users) on the original exchange server in the SMTP - Queues and a queue called 'serverB.domain.co.uk (Remote Deilvery)'

Is there something easy that needs to be done to get the email routing from the queue on Server A to the new Exchange serverB?
0
NewDealSkates
Asked:
NewDealSkates
  • 5
  • 4
  • 2
  • +1
1 Solution
 
SembeeCommented:
They should route between themselves quite happily.

The most common reasons why this doesn't happen:

1. DNS Resolution. The servers cannot see each other through DNS. Check by ping and NSLOOKUP. Also check that they can both see a domain controller, and the domain controllers can see each other.

2. A SMART HOST configured on the Default SMTP virtual server. If you have a SMART HOST configured on the Default SMTP virtaul server then you need to remove it.

You do know that you can upgrade Standard to Enterprise without harming data? It is a supported upgrade.

Simon.
0
 
jh_007Commented:
Have you set up any routing group connectors?

We run 8 Exchange servers in the same domain. - We had the same problem when we first upgraded. I called MS about it, and it 'should' work... but invariably doesn't.

You need to manually add the connections to the servers though: System manager: your admin group: routing groups; location: Routing group connector.

This should do it.

James.
0
 
NewDealSkatesAuthor Commented:
Simon,
DNS is resolving... and in the Prooperties of each server on the Directory Access tab both servers have 'All Domain Conntollers' enabled
Also, Server A has a SMTP virtual server configured to point to our ISP and Server B does not have a SMTP virtual server configured.

James,
Can you please provide more detail on how to configure the Routing group connector?
We have played around with this but not sure we have done it right... (How many routing goups do I need? Also how many Routing Groups Connectors do I need?)

Thanks in advance guys...

Giles
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
SembeeCommented:
On Server A - how exactly have you configured the SMTP virtual server to point at your ISP? It think that is your problem. If you have configured anything on the SMTP virtual server itself then the server is trying to send the email via your ISP.

Remove that configuration and change it to an SMTP Connector: http://www.amset.info/exchange/smtp-connector.asp

Simon.
0
 
NewDealSkatesAuthor Commented:
I didn't configure Server A... However, it is working!? And in the Default SMTP Virtual Server / Delivery Tab / Advanced, the SmartHost is set to the SMTP of out ISP 'post.merula.net'

If I change it do you not suppose that will just kill my original Server A

Giles
0
 
SembeeCommented:
You MUST remove that setting - that is why email is not going to your second server.
Remove it and replace it with an SMTP connector as I explained above.

This is the primary reason why I never recommend that the Smart Host setting on the Default SMTP virtual server is used. People forget about it and then wonder why their second server doesn't work.

Simon.
0
 
ikm7176Commented:
"SmartHost is set to the SMTP of out ISP 'post.merula.net' " mails are going to your ISP smart host remove the smart host settings and use DNS to send mails
0
 
NewDealSkatesAuthor Commented:
ikm7176

How do you use or setup the DNS to send mails?

Giles
0
 
SembeeCommented:
If you remove the Smart Host setting from your SMTP virtual server then Exchange will use DNS automatically. You only need to use a Smart Host or SMTP connector if your ISP blocks the direct sending of messages and makes you send the email through their servers.

Simon.
0
 
ikm7176Commented:
0
 
NewDealSkatesAuthor Commented:
Simon,

It is now workiing - Thank you very much.

Removing the SMTP from the Default Virtual Server then creating the connector and adding the ISP to the connector to foward through the Smart Host has worked.

I hope that's what you meant for me to do...!?

Many thanks to everyone else who contributed in such a short period of time!!!

I can sleep well tonight.
0
 
SembeeCommented:
That is indeed what I meant you to do.
You may have to add both servers as bridgeheads to the SMTP connector if you haven't already. This will mean they will both use it.

Don't forget to close the question.

Simon.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now