Solved

dma_intr errors on boot

Posted on 2004-08-24
16
458 Views
Last Modified: 2008-03-10
for a while now I get these errors on boot plus randomly while in terminal.

hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }

I have used seatools to do a full test of the harddrive which comes back with drive is fine no
bad sectors.
hdparm -i /dev/hda        #returns

/dev/hda:
 
 Model=ST380011A, FwRev=3.06, SerialNo=3JV6PWSM
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=unknown, BuffSize=2048kB, MaxMultSect=16, MultSect=16
 CurCHS=4047/16/255, CurSects=16511760, LBA=yes, LBAsects=156301488
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 *udma2 udma3 udma4 udma5
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: ATA/ATAPI-6 T13 1410D revision 2:  1 2 3 4 5 6

the drive seems fine, its just annoying when these errors pop up on the CLI when  I'm trying to do
something.
0
Comment
Question by:BobNZ2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 3
  • 3
  • +2
16 Comments
 
LVL 40

Assisted Solution

by:jlevie
jlevie earned 50 total points
ID: 11888353
While those errors point to a drive problem, it could also be a motherboard IDE controller problem. I'd suggest making sure that the Primary IDE drive(s) are properly configured w/respect to master/slave, swapping out the cable, and making sure that you have a current BIOS installed.

It's always helpful to know what Linux one is running for a question like this.
0
 

Author Comment

by:BobNZ2
ID: 11888456
Redhat 9.
kernel 2.4.20-8

Put in a new cable and have checked cable and jumpers on drives--master on end of cable slave in middle blue end into m/board
jumpers are correct.

current bios not sure... box is 4 years old and havent updated bios dont know if there is an update, will have a look.
0
 

Author Comment

by:BobNZ2
ID: 11888483
Turning dma off   hdparm -d0 /dev/hda stops the errors but makes for slow data transfer rate and needs to be done after each boot. I haven't found the bios setting that lets me change that. Would rather like to fix this without having to have dma switched off.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:BobNZ2
ID: 11889646
have found that setting ide=nodma in grub.conf will stop the errors at boot.
0
 
LVL 20

Assisted Solution

by:Gns
Gns earned 50 total points
ID: 11891710
Points a finger in the general direction Jim already pointed;-).

You could well try leave the dma setting alone and fiddle a bit with the Udma setting (the -X... option to hdparm IIRC). Do read and heed the warnings about this in the hdparm manpage though.

-- Glenn
0
 
LVL 2

Assisted Solution

by:marcin79
marcin79 earned 50 total points
ID: 11896691
I've notice exact the same problem when there was IRQ conflict (with a wireless card and the box was pre pentium)

Marcin
0
 

Expert Comment

by:Hunter555
ID: 11899063
You could also try checking to make sure you have the right chipset selected under "Generic PCI bus-master DMA support" in the kernel config? I know if you have the wrong one then DMA won't work at all but maybe you have one selected that is similar but not quite right?
0
 

Author Comment

by:BobNZ2
ID: 11899287
How do I go about doing that?
0
 

Accepted Solution

by:
Hunter555 earned 100 total points
ID: 11899529
Do you have the kernel source? (in /usr/src)

For starters try:
cat /proc/pci

To make sure of your IDE chipset. It should return one of the lines that contains "IDE interface" for example:

IDE interface: Intel Corp. 82801BA IDE U100 (rev 5).
0
 

Expert Comment

by:Hunter555
ID: 11899541
If you have the kernel source, you are going to have to (for example):
cd /usr/src/linux-2.4.20-8
make menuconfig

Choose:
ATA/IDE/MFM/RLL support  --->
                  IDE, ATA and ATAPI Block devices  --->
                              Then under "--- IDE chipset support/bugfixes" check to make sure it is enabled to support your chipset.

Then recompile the kernel and install.
0
 

Author Comment

by:BobNZ2
ID: 11899971
Thanks, I will try that tomorrow.
0
 

Author Comment

by:BobNZ2
ID: 11908198
cat /proc/pcii produced no such file or directory. I guess I will have to live without dma.

thanks for the help.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 11908895
The command is 'cat /proc/pci', not 'cat /proc/pcii'.
0
 

Author Comment

by:BobNZ2
ID: 11909028
LOL late nights early mornings and no coffee.

 cat /proc/pci returns
....
IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev 6).
Master capable. Latency=32
I/O at0xd000 [0x00f].
.....

"
ATA/IDE/MFM/RLL support  --->
                  IDE, ATA and ATAPI Block devices  --->
                              Then under "--- IDE chipset support/bugfixes" check to make sure it is enabled to support your chipset
"


ATA/IDE/MFM/RLL support  --->
                  IDE, ATA and ATAPI Block devices  --->  <*>VIA82CXXX chipset support

I take this to mean that my VIA chipset is supported. Intel P2 was also supported which is the processor chip I have.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 11909790
That chipset should be okay, providing the BIOS is setting it and the DMA & IRQ steering up correctly. That's where the BIOS update comes in.

Another potential problem could be that you haven't applied the errata updates to this system as evidenced by the 2.4.20-8 kernel (current is 2.4.20-31.9).

I'd suggest that you attend to those details and then see if the problem still exists.
0
 

Author Comment

by:BobNZ2
ID: 11909836
Thanks, will do that.  I appreciate the help.
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question