Solved

Yellow exclamation mark in Device Manager IDE Controller. Win98 won't recognize CD ROM drive.

Posted on 2004-08-24
21
1,391 Views
Last Modified: 2013-12-29
I have reformatted my Hard Drive but when I reloaded win98se my "standard Bus Mastering IDE Hard Drive controller" shows a problem in Device Manager. I have re-booted, re-installed the driver and removed and re-installed the controller. No help and No CD ROM recognized.  I can use the CD rom in DOS mode so I know that it works. Computer is an older IBM TP w/ teac CD ROM. I am a novice here too folks!
0
Comment
Question by:whastings
  • 8
  • 6
  • 4
  • +2
21 Comments
 
LVL 38

Assisted Solution

by:Insignificant Volunteer
Insignificant Volunteer earned 250 total points
Comment Utility
Yo don't sound like a novice, whastings.  You have already tried the first thing I would have suggested, and that is to see if it is accessible in DOS.

What is the make and model of your motherboard and what is your BIOS version.

If you aren't sure, download and install Everest Home Edition which will probably provide all these details.

Home Edition Download Free version (version 1.10)
http://www.lavalys.com/index.php?page=product&view=1&subpage=5

Direct Link:
http://www.lavalys.hu/downloads/everesthome110.exe (installer file)
or
http://www.lavalys.hu/downloads/everesthome110.zip (all files and runs as a standalone)

The Pro Edition is retail.
0
 

Author Comment

by:whastings
Comment Utility
Thanx BillDL; Another thought that will probably help. I have two IBM TPs, both 365XDs and I ahve switched the HDDs between the two computers. The HDD with the original win98 program recognized the cd rom and has no issue with the IDE controller. Only the newly formatted and programed drive(s) Two of 'em! so I believe the issue is a corrupted driver (.inf?).

If that's the issue, I must have a funky win98  CD ROM so I'll need to get whatever drivers (?) are corrupted from a 3rd party provider and install 'em (I don't know where nor how). I am a Carpenter by trade and this computer studd slays me!
Anyway, The Everest program - Motherboard <custom> IBM 26251E9, 133/66 MHz Pentium I processor. Bios is 15ET35W. I updated the BIOS yesterday too from the IBM Support website!

Everest, Neat program!

Thanx, Bill
0
 
LVL 38

Assisted Solution

by:Insignificant Volunteer
Insignificant Volunteer earned 250 total points
Comment Utility
A Carpenter by trade eh!  Here's a sideline you might get into:

http://www.exoticwoodcrafts.com/

http://www.google.co.uk/search?hl=en&ie=ISO-8859-1&q=wooden+PC+cases&btnG=Google+Search&meta=

I agree with you.  Windows 98 or Windows 98SE should identify the chipset on a Pentium I board and install the relevant .INF files, but my first instinct is that maybe the CD-Rom doesn't work with Bus Mastering, or something along those lines.

I notice from the IBM support pages, that the Thinkpad 365 range came with a 6x or 8x CD-Rom drive (TEAC CD-46E) that interfaced at up to Interface PIO mode 3, while the IDE Hard Drive could interface at up to PIO mode 4 (which is DMA-2).

(http://www-1.ibm.com/support/docview.wss?rs=0&q1=Thinkpad+365XD&uid=psg1DEDN-3E6KSY&loc=en_US&cs=utf-8&cc=us&lang=en)

Some explanations of the differences here:
http://www.windowsitlibrary.com/Content/435/03/6.html
http://www.seagate.com/support/kb/disc/ata_to_ultraata66.html
http://www.dataclinic.co.uk/data-recovery/learn-more-about-ata-ide-dma-hard-disk-drives.htm
http://thef-nym.sci.kun.nl/cgi-pieterh/atazip/atafq-3.html

What does it say in your CMOS Setup Screen about the settings for your CD-Rom?
Try changing them and see what happens.

I found the following pages as a reference.

Windows 98 installation information - ThinkPad 365X/XD
http://www-1.ibm.com/support/docview.wss?rs=0&uid=psg1DSHY-3VGJQA&loc=en_US

Software and Device Drivers - ThinkPad 365:
http://www-1.ibm.com/support/docview.wss?rs=0&uid=psg1DSHY-3PLLKA&loc=en_US

System Program Service Diskette for 365X/365XD

http://www-1.ibm.com/support/docview.wss?rs=0&q1=Thinkpad+365XD&uid=psg1DSHY-3VGJQA&loc=en_US&cs=utf-8&cc=us&lang=en

http://www-1.ibm.com/support/docview.wss?rs=0&uid=psg1COBN-38CG9B&loc=en_US

ftp://ftp.software.ibm.com/pc/pccbbs/mobiles/sytpx110.txt

Have a read at these and see what is relevant to your situation and perhaps you weren't aware of, if anything.
0
 
LVL 38

Assisted Solution

by:Insignificant Volunteer
Insignificant Volunteer earned 250 total points
Comment Utility
I also found an online facility to "Automatically Detect Drivers" that might be helpful:

http://www-1.ibm.com/support/us/all_download_drivers.html
0
 

Author Comment

by:whastings
Comment Utility
Hi BillDL;

Wow, Really nice cases! Wish that I had that skill but as a carpenter versus a cabinet-maker it would be like comparing what YOU do to what a computer operator does! I can frame a house or re-model one but that really fine work takes a highly skilled and committed craftsman. Not I !!

You sent me lots of reading and research to go through and I've chipped away at it understanding a fairly good amount of it. Not sure that it was exactly what I nee though. Still a yellow exclamation point in the IDE Controller and no CD Drive recognized.

The webpage that searches for necessary driver updates apparently doesn't like Win98!!Doesn't want to co operate w/ me and search! Mean Microsoft!

Not wanting to just sit idle and .... To that end, I borrowed my grand daughters 365XD ThinkPad (exactly like the two that I have here) - (Guess we're an antique family) and pulled her drive, placed it into both of my laptops and both had CD Drives recognized and neither had the "dreaded yellow !" on the IDE Controller. Problem must be on the CD that I used to load the program (only one that I have too) on the reformatted drives. Could there be a "switch" or something similiar that is incorrectly set when I downloaded? Perhaps something in the registry on config.sys setup, autoexec.bat or that CMOS thingy? Problem is, I have no idea what's right or wrong nor how to decipher those (in greek/"geek"codes). I can do most of the hardware install stuff but the coding intracies befuddle me!

Both of my "ailing" 365s have Teac CD 44E (4x) drives also, not CD-46Es (?) if that matters. My grand daughters is a CD-44E also.

[You asked]: "What does it say in your CMOS Setup Screen about the settings for your CD-Rom?
Try changing them and see what happens?" What is a CMOS Setup Screen and how do I locate it and best of all, change it to what? Sorry, carpenter you know!

Regards and thank you for your patience, Bill



0
 
LVL 6

Assisted Solution

by:caza13
caza13 earned 20 total points
Comment Utility
I don't know if this applies in your case, but whenever I reinstall Windows 98 on my computer I have to remember to reinstall some patches that came with my motherboard to resolve an IRQ routing issue.

VIA Chipset 4in1 Patch File ver. 4.43
  Note : This is chipset Patch driver. It informs the operating system how to properly configure the chipset for specific functionality properly reconized by the operating system.

I can't find much information about your motherboard, so I don't know if it needs any patches to operate with Windows 98.
0
 

Author Comment

by:whastings
Comment Utility
Hi caza13! Never had to install a patch beore. Not the first time that I reformatted and re=loaded Win98 euther. Just gets weider and weider. I am going to try ghosting my grand daughters HDD onto one of my drives and just for the heck of it see what happens. Just bought Norton Ghost 9.0 and will try that tomorrow morning Nre York time. I'll post the results then and kep my fingers crossed (legs to I guess!). 'Til then, Thanx guys, Bill
0
 
LVL 38

Assisted Solution

by:Insignificant Volunteer
Insignificant Volunteer earned 250 total points
Comment Utility
whastings.

The CMOS (Complimentary Metal Oxide Semiconductor) is a fancy acronym for a piece of silicon chip that stores hardware-related settings about your computer.  There will be a small battery somewhere on your motherboard which sends a trickle of power to this chip while your computer is powered off, and this is necessary to retain the data in memory.

These settings can be altered by booting into what is referred to the CMOS Setup Screen.  Some people erroneously refer to this as the BIOS Screen.  The BIOS Chip is one that doesn't need power to retain data in its memory because that data is permanently burned onto the chip in the form of instructions.  It's like the DNA of your motherboard, and allows the operating system (windows) to interface with the hardware components.

Different BIOS manufacturers use different methods of getting into the CMOS Setup.  You have to press a particular key VERY early on in the first stages of booting, and this will then show a primitive screen which has to be navigated using arrows, the enter key, the tab key, and other key combinations that are usually shown somewhere on each page of the screen.  There is always a way to escape from it and to then boot into windows, and this is usually something like "F10 to exit and disregard changes" or "F12 to exit and save changes".

Common keys used to boot to the CMOS Setup are ESC, DEL, F10, F1, and F2.  It could also be some combination like Ctrl + Alt + INS or Ctrl + Alt + F11 (I think this is the one for a Thinkpad), but depends entirely on the BIOS manufacturer.

You will probably see this info, and the key to press, if you watch the screen immediately your computer starts to boot.  Common BIOS manufacturers are Phoenix, Award, and Amibios.

Unfortunately I can't find a link to show you screenshots of the relevant sections where you will find the settings related to the drives, but look for IDE and tell us what it says.

0
 
LVL 1

Assisted Solution

by:CyberMatrix
CyberMatrix earned 205 total points
Comment Utility

Hi,

Maybe MSCDEX is the problem...it could be that in DOS it loads but with windows startup it is missing.

Read the instructions on this page...
http://www.pcguide.com/ts/x/comp/cd/recogDriver-c.html

It is for win95 but can be useful also in your case... give it a try

0
 

Author Comment

by:whastings
Comment Utility
Howdy BillDL, CyberMatrix & friends!

(BillDL) - I haven't been able to get into anything called CMOS Setup Utility but I did find the BIOS page. Tried "mashing" each and every and all of those keys and the only success I had was "F1" which got me into TP Diagnostics and Bios. Can't change antything in the BIOS so I ran the diagnostics, all was o'kay and I got out.

(CyberMatrix) - MSCDEX is in the config file and when I dbl click it a DOS window opens and says that it's "already running"? Doesn't say in DOS or WINDOWS, just "running".???

I did the following in hopes that it might give you guys an idea as to where my issue lies. It may seem wacky to you but, remember, a carpenters logic here!

Please keep this in mind as you read:

Both laptops are as identical as this:

Both are IBM Thinkpads Model # 2625-DEF
Both are 120/60 MHz
Both have 40 MB EDO RAM
Both Bios setups are Identical and were done on the same day from IBM Website (verified again today).
Both hard drives are 2.01 GB by Fujitsu
Both Hard drives were FDISK’d, partitions were removed and formatted FAT32 @ 100%
Both Hard Drives passed integrity tests and neither had bad sectors
Hard Drives were ghosted using Symantec Ghost 9.0 (one after the other) from the same “mother” HDD that had no data on it, only programs.

Lets refer to them as Laptop “A” and Laptop “B”, it may be less confusing. "A" being "good" and "B" being "troubled"!

I installed the newly ghosted hard drive into these laptops side by side and booted them up.

Laptop “A” - Booted normally, no issues no problems. Device manager shows no issues no problems! CD ROM is recognized in Device Manager and CD ROM drive works. “Standard Bus mastering IDE Controller shows no problems!

Laptop “B”  - Booted normally but when I open Device Manager it doesn’t show a CD ROM Drive at all and the “Standard Bus Mastering IDE Controller” shows the yellow exclamation mark in it!

I then went to “My Computer Properties / Performance;

 Laptop “A” shows 90% performance and no other issues.

Laptop “B” on the other hand also shows 90% performance but, under “File System” it states that “All Drives are using MS-DOS compatibility Mode” and the “Virtual Memory”  states “MS-DOS compatibility mode” also.

There is a box just under these headings and in there are two entries. Entry one states “Compatibility-Mode paging reduces overall performance” and entry two says “Master Boot Record modified. See the important details in Help.

I went to the details and got this

Compatibility mode paging reduces overall system performance.

Windows was unable to identify a real-mode driver or memory-resident program loaded
in your Config.sys or Autoexec.bat file. You will see another message that lists the
 name of the driver or program causing the problem.

Because Windows could not identify the driver or program, it has switched to MS-DOS
 compatibility mode to ensure the program will run. However, this decreases overall performance. To improve performance, remove the program or driver causing the problem, or contact its manufacturer for an upgraded version.

Master boot record has been modified.

The master boot record has been modified by some program.
This may be caused by disk manager software used to add large hard disk drives to older
computers, or encryption or other security software. It may also be caused by a virus on
your computer. If you do not have disk-management or security software installed, scan
you computer for viruses.

Important

Viruses can cause data loss. Check all the disks on your computer immediately for a
virus by using any virus-checking software.

I ran an updated virus scan, no viruses!

Finally, I went to the MS-DOS prompts on both computers, side by side and here it gets REALLY interesting!!

Remember, ghosted drives, same original, here is what MS-DOS revealed:

In C:\WINDOWS (both);

Laptop “A” (the one that works) – 209 Files with 56,236,305 bytes used.

Laptop “B” (the “bad” one) –         210 FILES with 39,460,345 Bytes Used!!!!

Isn’t that amazing!

Laptop “B” has an extra file called IOS.LOG with 1,101 bytes.

Laptop “A” doesn’t have that file at all,  although .........

Laptop “B”, in File WIN386 has 46,137,344 Bytes used and

Laptop “A” uses 29,360,354 Bytes in the same file!!

Does any of this raise any kind of a flag for my problem?

Hope t's not driving you guys "Nuts" like it is me!

Thanx a gigabyte!, Bill
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 1

Assisted Solution

by:CyberMatrix
CyberMatrix earned 205 total points
Comment Utility

Bill,

One of the links below should help you. It is exactly your problem based on the explanation you gaved us...

First try this:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;151911


If it does not solve it there are a few other things and explanations you can do available here:

http://support.microsoft.com/default.aspx?kbid=130179

0
 
LVL 1

Assisted Solution

by:CyberMatrix
CyberMatrix earned 205 total points
Comment Utility

And Bill if it helps you...I surely need the points.   ;)))
0
 
LVL 1

Assisted Solution

by:CyberMatrix
CyberMatrix earned 205 total points
Comment Utility

Another site with information on the same issue and surely understandable to a carpenter is also this one...very simple step by step instructions...

http://www.computerhope.com/issues/ch000143.htm
0
 
LVL 38

Assisted Solution

by:Insignificant Volunteer
Insignificant Volunteer earned 250 total points
Comment Utility
One thing that you should first look at on Laptop "B" is the following:

Start Menu > "RUN" option > and type MSCONFIG > click "OK"
Click the "Advanced" button under the "General" tab
Ensure that "Force Compatibility Mode Disk Access" is NOT checked.
If it IS, then uncheck it and click "OK", then click the "Apply" button and reboot.

If this isn't the case, then the links provided by CyberMatrix are excellent and surely this must be the problem.  Just why the two identical laptops could have different settings is a mystery if this turns out to be the problem.

From what you have said about your attempts to enter the CMOS Setup Screen, it appears that your hard drives MAY have a small Non-DOS partition containing diagnostics and system tools that allow you to change CMOS Settings.  This was a commonly used method by Compaq of being able to offer more options while keeping the actual capacity of the CMOS chip down.

Running FDISK to remove partitions (ie. wipe the drive) may cause problems and remove the ability to enter these screens if you ever consider this.  Using FDISK after booting to a Win98 boot floppy (or booting to DOS Mode after pressing F8 at startup) shouldn't mess things up if you only choose the option to VIEW Partition Information (usually option 4).  This would certainly confirm the presence of a Non-DOS partition containing the tools I mentioned.

0
 
LVL 4

Assisted Solution

by:Gaud-wo
Gaud-wo earned 25 total points
Comment Utility
Hi whastings,

So you have used another CD ROM that does work. What if you just switch the 2 drives? Does your CD ROM work in the other laptop? If it does, you can just leave it that way, right?
If you already tried it, never mind this (I havn't read through all posts here).

Someone already gave a hint ot a 'patch', I will give some more in-depth info to this:

Windows itself holds quite a few drivers, still, every PC is different. So all the chips on mainboards are unique, and after installing Windows, you should ALWAYS execute an installation program with mainboard chipset drivers! So not the BIOS update, real chipset drivers (these hold IRQ steering, ATA and IDE drivers, ...)

Still, I searched the IBM site for this driver package, and I din't find it - maybe it's contained in the setup package... Do yo ustill have the original IBM setup cd-rom that came with the laptop? Your drivers may be on that disk!
Or you can try some files from http://www-1.ibm.com/support/dlsearch.wss?rs=0&apar=include&q1=26251E9&tc=HWM0D&dc=D430&loc=en_US&cs=utf-8&lang=en&sort=rk&atrn=SWPlatform&atrv=Windows+98&cc=us .

I don't have that much experience with laptops, still, I sometimes use laptop harddisks. The onse I used must be 'jumpered', this is a small conducting piece you use to short some pins. Like this you can set the harddisk and CD ROM to master or slave. Did you find anything like this? Did you compare connectors and switches on the drives of the laptops?
Your CD ROM may also just have died (not so exceptional on older equipment), and only partially accessible by dos...

Glenn
0
 

Author Comment

by:whastings
Comment Utility
Morning Folks!

All of you sure kept me hopping with all of these great ideas! Unfortunately, although I cannot say that all of them didn't work, I can say that all of the ones that I understood and could do as a novice did not solve this pain-in-the-____ problem.

Frustrated, (and not the type to quit), I went out and purchased one new 3.2GB hard drive, FDISK'd it, Scandisked it, formatted it and ghosted it like the other two and BAM!, problem just vanished! Now I'm even more confused then ever!

I've switched this new drive back and forth and whichever computer that its in works fine. One of the other two drives, same thing, works great, the third drive is the culprit and I don't for the life of me understand why but ..... I'll sell it to an enemy and that'll make me feel a modicum better anyway! ;-] (kidding)

The two drives that I had originally been using and referred to in my last thread were identical drives, identical P/Ns, identical sizes (GBs), identical # cyclindres and heads, they were clones of one another and I had scanned them and everything too! I can't explain it and I'll bet that you can't either. Just another intrinsic computer twitch that makes you smack your brow and raise your eyelids in dis-belief I guess! I like the certainty of carpenter work much better. If a board is too short, it's too short, simple, straight-forward and fully understandable!

Being brand new to EE, what do I do now besides saying a deep felt thankyou to all of you for your concern and assistance?
I've gained a new respect for what you folks do and don't envy your probable frustrations from time to time.

Please let me know my next step, Regards, Bill
0
 
LVL 38

Accepted Solution

by:
Insignificant Volunteer earned 250 total points
Comment Utility
Yes, I agree that the differences between 2 otherwise identical systems is a puzzle.

The following index of questions will be helpful to you:

http://www.experts-exchange.com/help/

If you feel that you resolved this problem using the comments made by one particular expert, then you should click on the "ACCEPT" button next to the "Login" name of the expert who posted that comment.

Where you feel that more than one comment assisted you, then you can share your points between the experts by clicking on "SPLIT POINTS" at the bottom. To do this, first select the "PRIMARY USER" and allocate however many points you wish to allocate and select an appropriate "GRADE", then select the other user(s) and allocate points against him/her/them.

http://www.experts-exchange.com/help/closing.jsp#3

If you feel that you have resolved your problem in some other way not previously mentioned by any of the comments above, then you can post a "zero points" question for the attention of the Administrators in the "Community Page" asking for your points to be refunded.

http://www.experts-exchange.com/Community_Support/
0
 
LVL 38

Expert Comment

by:Insignificant Volunteer
Comment Utility
Thank you for that, Bill.
0
 

Author Comment

by:whastings
Comment Utility
Thank all of you folks!!!

It was an enjoyable experience and I learned some things which, at my age, is a good thing. It's kind of strange you know, I would come back to this site at anytime I needed assistance but I hope that I never have to! Know what I mean?

Best to all of you folks, you provide a much needed service and you do it very well!

Bill
0
 
LVL 4

Expert Comment

by:Gaud-wo
Comment Utility
The pleasure was ours. As you say, carpenting may be straightforward - but you must, like us, be puzzled and intrigued by the problems of your trade - as this problem poses a challenge to us.
We get our satisfaction by solving things that are 'Chinese' to others ;)

Oh, about your HDD: it may very well just have died. If it still puzzles you why it died, maybe you can bring it in with some PC repair shop or some guy that just knows a lot about PC hardware.
And, you may give this to your worst enemy thinking it will drive him nuts, I think the people that replied here would be more than glad to get that disk, I know I would :) I got a room full of old and new hardware, and sometimes I dig up old hardware with problems that I once gave up on, and manage to repair it somehow. Sold a pc made of 'used parts' yesterday, took me 2h to build, and it ran a recent 3D game seemlessly (Quake3), which even amazed me ^_^

Well, glad you got a working system out of this, and I'd be glad to help you again!

Glenn
0
 
LVL 38

Expert Comment

by:Insignificant Volunteer
Comment Utility
>>> We get our satisfaction by solving things that are 'Chinese' to others ;) <<<

That's perfectly stated.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

If you Lost your Administrator password for Windows XP, Vista, or 7 this CD will help you reset the password to blank so you can log in. Once in you should change that blank password to something!! Download the ISO on this page http://www.spl…
NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now