Sonicwall pro3060 failover VPN

Hi All,
I'm having an issue with the sonciwall pro3060 firmware 2.5.0.3 .
I have 2 offices one in the UK and one in the US , both offices have two sonicwalls
in a failover configuration.
The US has 3 internet connections fibre, t1 and ADSL
the UK has 2 internet connections T1 and ADSL

There is a vpn connection between the UK and US using IKE which allows for 2 endpoints
I am using the public IP of the fibre and T1 connections. as my endpoints to the US lan (10.5.0.0)

The issue is that when the T1 fails in the UK failing over to the adsl line
the vpn connection does not failover.

Any thoughts (got latest firmware form sonicwall but there documentation is flaky)
LVL 1
packetninjaAsked:
Who is Participating?
 
idyllicsysConnect With a Mentor Commented:
Do you have both sides configured for keep alive. Try disabling on one side. You only need one to create the connection at any time. What is probably happening is that the T1 goes down  and VPN connection goes down. The US side tries to contact the primary interface in the UK, while the UK side is trying to contact the secondary interface in the US.

Let me know

Ted
---------------
MCSE, CSSA
www.idyllicsys.com
0
 
stephaniesbConnect With a Mentor Commented:
Make sure you have Dead Peer Detection and keepalives set on only one side.
Also, the failover feature works well, but the preempt doesn't.  (It will fail over to the backup, but when the primary comes back up, it doesn't fail back)  This was fixed in firmware 2.5.0.4.  It's unreleased, but if you have a support contract you can call Tech Support and get it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.