Solved

Peer to Peer Home networking

Posted on 2004-08-25
24
1,118 Views
Last Modified: 2013-11-21
Hello

I have 2 computers in my home both with XP Pro as the OS. Both of them are connected to the internet thorugh a router.

I want to be able to share files and printers between the two computers. So I ran thehome and office networking wizard.

Now when I go to My network places in the first Computer, I'm able to see the other computer in the workgroup. But when I click on the computer name it asks for a user Id and password. I do not remember setting any userid or passwords.

The same happens when I go My network places in my second computer.

Can somebody tell me where to set or chnage this userid and password.

Thanks.

iceb


0
Comment
Question by:iceb
  • 8
  • 3
  • 3
  • +5
24 Comments
 
LVL 4

Accepted Solution

by:
JonSh earned 500 total points
ID: 11893933
Sounds like you have the guest account turned off...goto Start/Control Panel/User Accounts and enable the Guest account.
0
 
LVL 15

Expert Comment

by:Yan_west
ID: 11893972
If you want to be sure to access shares on both computer, you have to set up the same username and password on both computers.. if you want no password, you can enable to guest account, and give it access to the shares..
0
 
LVL 1

Author Comment

by:iceb
ID: 11894039
Yan West

How do I give Access to the shares ?

iceb
0
 
LVL 15

Expert Comment

by:Yan_west
ID: 11894059
Well, just enable your guest account.. think this is enough..

then right click on your share, and click the security tab, and add the guest account with "full access". Not sure if you have to do this tho..
0
 
LVL 1

Author Comment

by:iceb
ID: 11894135
I enabled my guest account. I'm still asks for a password from the other computer.

And I right clicked on the shared documents, wen to 'sharing and security' and there was no security tab there. Is there some setting that I should change to make this security tab visible.

iceb
0
 
LVL 1

Author Comment

by:iceb
ID: 11894150
oops typo ... IT still asks for a password from the other computer.
0
 
LVL 1

Expert Comment

by:Stoddy2369
ID: 11894208
Are your drives formatted as NTFS? If not they need to be. If they are then into Windows Explorer and click Tools - Folder Options - View and untick "Use Simple File Sharing". You should now be able to see the Security tab
0
 
LVL 1

Author Comment

by:iceb
ID: 11894269
This option "Use is simple File Sharing" is not there :-(
0
 
LVL 15

Expert Comment

by:Yan_west
ID: 11894292
Is your drive formated in NTFS? to check it out, right click on your C drive and click properties, check the value of "file system"..
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11894327
Windows XP (at least PRO) defaults a setting in Local Security Settings to something very unhelpful.
If all this does not solve your problem, check Local Security Settings, Network access: Sharing and security model for local accounts.  This may be set to (default) Guest only - local users authenticate as Guest.  Change this to Classic: local users authenticate as themselves.

Start/run: gpedit.msc
   Local Computer Policy
     Computer Configuration
      +Windows Settings
         +Security Settings
           +Local Policies
             +Security Options
         
          Double-click on Network Access:Sharing and Security Model for local accounts--
                 --change to "Classic - local users authenticate as themselves"

FOR HOME USERS ONLY WHEN ALL ELSE FAILS:
Look for and set these properties as shown also

Network access: Allow anonymous SID/Name translation     ==> Enabled
Network access: Do not allow anonymous enumeration of SAM accounts     ==> Disabled
Network access: Do not allow anonymous enumeration of SAM accounts and shares          ==> Disabled
Network access: Let Everyone permissions apply to anonymous users     ==>      Enabled

Now you may disable the Guest account as recommended for improved security (for the XP box).  Without this set properly nothing will work for XP!
0
 
LVL 1

Author Comment

by:iceb
ID: 11894341
The File System says NTFS. Hwo do I change this ? And what happend if I chaneg it ?
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 11

Expert Comment

by:PennGwyn
ID: 11894371
Your drives don't have to be NTFS formatted to be shared.  NTFS allows you to have file/directory permissions by user account, AS WELL AS share permissions, but at this point that's an extra complication you don't want or need.

0
 
LVL 1

Expert Comment

by:Stoddy2369
ID: 11894387
If Simple File Sharing option isn't there then I am pretty sure you are not using the NTFS file system. You need to convert it
0
 
LVL 1

Expert Comment

by:Stoddy2369
ID: 11894397
Ignore my last comment - just pressed submit and saw your reply. Sorry
0
 
LVL 2

Expert Comment

by:specman
ID: 11894522
You don't need to enable the guest account.

Just right-click on the folder/printer etc. that you want to share; then click "sharing".  From there you can select the options you want to use.  The easiest selection is to have let all users access the folder (since you're behind a router this is not as bad as it sounds...however there is still something of a risk in sharing anyways).  Do the same thing on each computer.  Now when you go to network places and click on the computer in question, you should see all the folders that you've setup as shared folders.  Not hard at all to setup.
0
 
LVL 4

Expert Comment

by:JonSh
ID: 11894578
Iceb, enable the guest account on both machines :)...also, Lrmoore's input is correct.  But I'm not as paranoid about guest accounts when behind a natting router at home :)

0
 
LVL 1

Author Comment

by:iceb
ID: 11894693
Thanks guys. It works with guest account turned On. I think I should give the marks to Yan West
 since he gave me this solution first.

Thanks again

iceb
0
 
LVL 1

Author Comment

by:iceb
ID: 11894772
Sorry JonSh .. I just realized that it is you who answered the question first. How can I award point to you ... now.

iceb
0
 
LVL 4

Expert Comment

by:JonSh
ID: 11894800
LOL...Iceb, I have no idea....ask the management :)
0
 
LVL 1

Expert Comment

by:Douglasfur
ID: 11895398
I believe that you have to set up a user account on each machine for the other machine.
You have two machines, A & B.

Be sure that all these accounts and changes are created by the Administrator on both machines. This is VITAL.

Start on Machine_A.

On Machine_A, you need to set up an account for the other machine, called something like User_B. If your user account on  the B machie is "Bob," then just make the account Bob. If you want to leave the password blank, that is okay.

Now right click on My Computer to get to System Properties. Select the "Computer Name" tab. There is a button on that tab that says "Change" next to the text that says "to change the name of this computer or join a workgroup click "Change." Make a note of the machine name (Important!) and verify that Machine_A is a member of "Workgroup." If it is not a member of "workgroup" change it to "workgroup."

Now you need to share the drive or folder that you want to let Machine_B access. Navagate in Explorer to the folder or file that you want to share. For this example, I will share the entire C: drive.

Open "My Computer" and right click on the C: drive. From the menu select "Sharing and Security..." Next, under the sharing tab you will see a "link" that says "If you understand the risk but still want to share the root of the drive, click here. Click it. (This particular screen only comes up when you share the entire root drive.)

Once you've clicked that link you will have a screen with different text. Under "Network Sharing and Security" there is a link that says "If you understand the security risks but want to share files without running the wizard, click here. That will give you a promt that asks you to either "use the wizard" or "Just enable file sharing." Select "just enable file sharing." Now in "Network Sharing and Security" put a check mark in the box that says "Share this folder on the network." When you put a check mark in that box, the "Share Name" box will cease to be grayed out and you can enter a share name for the network. In this case I'll call it Drive_C. So now the drive on Machine A is "Shared As" Drive_C.

Now go to machine B.
On machine B, you need to set up an account for your A machine. Call it whatever you want but I would suggest using the user name from computer A. If your user account on A is "George", make the account on B "George." If you don't want a password, leave it blank.

Now right click on My Computer to get to System Properties. Select the "Computer Name" tab. There is a button on that tab that says "Change" next to the text that says "to change the name of this computer or join a workgroup click "Change." Make a note of the machine name (Important!) and verify that Machine_B is a member of "Workgroup." If it is not a member of "workgroup" change it to "workgroup."

Now you need to share the drive or folder that you want to let Machine_B access. Navagate in Explorer to the folder or file that you want to share.
(These are exactly the same steps for Machine_B as they were for Machine_A)
For this example, I will share the entire C: drive.

Open "My Computer" and right click on the C: drive. From the menu select "Sharing and Security..." Next, under the sharing tab you will see a "link" that says "If you understand the risk but still want to share the root of the drive, click here. Click it. (This particular screen only comes up when you share the entire root drive.)

Once you've clicked that link you will have a screen with different text. Under "Network Sharing and Security" there is a link that says "If you understand the security risks but want to share files without running the wizard, click here. That will give you a promt that asks you to either "use the wizard" or "Just enable file sharing." Select "just enable file sharing." Now in "Network Sharing and Security" put a check mark in the box that says "Share this folder on the network." When you put a check mark in that box, the "Share Name" box will cease to be grayed out and you can enter a share name for the network. In this case I'll call it Drive_C. So now the drive on Machine A is "Shared As" Drive_C.

Now when you are on Machine_A and you browse in My Network Places, you will be able to access the Drive_C on Machine_B. If there was no password needed to logon to your user account on Machine_A, then you shouldn't need one to get to the shared drive. Just be sure that whatever password you use to logon to your user account on Machine_A is the same password for your user account on Machine_B.

You could also now map your Machine_A to the drive on Machine_B, so that it would then be available in My Computer.
But I guess that's a different question

This sounds a little confusing but if you go one step at a time, it should be very simple.

best of luck!

douglasfur

PS - XP Home doesn't have the gpedit.msc feature, which is really a shame.
0
 
LVL 1

Expert Comment

by:Douglasfur
ID: 11895408
I guess I'm a day late and dollor short.
oops!
0
 
LVL 1

Author Comment

by:iceb
ID: 11897756
Thanks for that great answer Douglasfur  ... but the problem has been solved already. Thanks anyways.

iceb
0
 
LVL 1

Expert Comment

by:Douglasfur
ID: 11904330
yw iceb
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Every server (virtual or physical) needs a console: and the console can be provided through hardware directly connected, software for remote connections, local connections, through a KVM, etc. This document explains the different types of consol…
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now