Improve company productivity with a Business Account.Sign Up

x
?
Solved

Setting default input language for all EXISTING user profiles

Posted on 2004-08-25
1
Medium Priority
?
2,225 Views
Last Modified: 2011-10-03
I have a new installation of Windows 2003 Server and 38 XP Pro Clients.

All is well with one notable exception - the Regional and Language Options are not set at the XP clients as I want them ie. English (United Kingdom) for all values.  At the moment they are set to English (US).  I am using UK format keyboards.  

I have noted at the server that in Control Panel>Regional and Language Options>Advanced tab and in the bottom section "Default user account settings" you can tick a box next to the statement "Apply all settings to the current user account and to the default user profile".  If you drag ? over this value the help text indicates that checking/ticking the box will affect "all new user accounts created on this computer".

So I gave it a go - I checked the box next to "Apply all settings to the current user account and to the default user profile" added a new (test) user and hey presto - correct input language applied!  The crucial test being the availability of "£" sign which you should get (in the UK) when you press shift 3; also corrected are the shift 2 key which gives the " mark and @ which is paired with the single quote ' key.  Unfortunately the change does not force itself onto existing user profiles (which is what I want it to do).

HERE'S THE CRUNCH QUESTION THEN ~ how do I get this change at the server level to apply to all EXISTING user profiles??  So that all users get the same English (United Kingdom) Input Language/Keyboard settings??  At the moment I am faced with re-making 30+ new user profiles just to fix this problem but if I do this it will in turn create a load more problems to replace it!!

Your help would be much appreciated :-)

Thanks in anticipation

Paul Truswell
0
Comment
Question by:ptruswell
1 Comment
 
LVL 10

Accepted Solution

by:
jhautani earned 1500 total points
ID: 11900833
User's current keyboard layout is configured in registry: HKEY_CURRENT_USER\Keyboard Layout\Preload\1, of which data contains the keyboard locale
You can use a script to change this setting and it will take effect after next logon.

Create a batch file with the following line (not 100% sure whether UK locale is 00000809):
  reg add "HKCU\Keyboard Layout\Preload" /v 1 /d 00000809 /f
and let user run it manually or if you are using AD put it in the user's logon script.

hope this helps
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

The HP utility "HP Lights-Out Online Configuration Utility for Windows Server 2003/2008" could be of great use when it comes to remotely configure a HP servers ILO WITHOUT rebooting the server. We would only need to create and run scripts using thi…
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
In this video I will demonstrate how to set up Nine, which I now consider the best alternative email app to Touchdown.
Watch the video of Kernel Migrator for SharePoint, which demonstrate the process easily of migration from SharePoint to SharePoint, OneDrive for Business & Google Drive servers, Public Folder to SharePoint, File Server to SharePoint. The tool has va…

602 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question