Access Denied myodbc using ODBC on Windows XP Pro.

I am trying to access mysql on my remote database.  I am trying set up the ODBC connection using the windows xp ODBC interface.  When I use the test connection. It tells me that Access Denied for User  password YES.

I am setting this up to access the database using msaccess xp  on this end. Is it going to be possible. And if So, How?
chasferrAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
moduloConnect With a Mentor Commented:
PAQed with no points refunded (of 125)

modulo
Community Support Moderator
0
 
akshah123Commented:
Seems to me that you are not entering the right password.
0
 
akshah123Commented:
Access Denied for User  password YES.

above message comes up when your odbc drivers reach the database and try to log in using the information that you provided but password is not right.  THus, you are reaching your remote database. Your username is also currect. However, either you are not providing password or it is incorrect.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
magicMushCommented:
When you try to access a mySQL server on remote desktop it will deny connection even if you have entered your username and password correctly.  This is due to security reasons.  What you need to do is add your ip address ( or hostname) (IP address of computer that connects to the server) to the MySQL servers known hosts list.
are you using any control panel for your remote host if you do there is usually an option (textbox ) where you can add yourIP to MySQL's host(Access Hosts) lists.




0
 
newdayCommented:
You need to tackle this in stages, as there can be a number of reasons that it will not work.

ON the server,

First establish the users that have access to the database. This can be found in the user privilege of you mysql data server.

At a minimum the must be a user configured with access from you clients IP address. This can be done specifically i.e. 192.168.1.23 or by sub domain i.e. 192,168.1.%

Ensure that you know if that user has a password set or not. No password is valid however if one is set then you must enter it at connection time.

On the client,

Create a new system DSN for the connection entering the drive, username and password

Use the test connection option to check that you have all the info entered correctly.

If you follow these steps you should quickly spot the cause of your problem, well it tends to work for me J
0
 
chasferrAuthor Commented:
newday   Thank you for your input. However, I have tried this extensively.  The info that is returned specifies that the user specfied "fsbo_OpenRealty" does not have access "password = YES".

I've tried without passwords, and with passwords.  I've use the extention fsbo_  I've tried it without it.   I also made sure that the user is added to the proper database within phpmyadmin. I've tried it on several different computers.  I am accessing using a windows operating system, with the myodbc3.5 for windows.  The server is on unix or linix whatever.  Same problem.  Hope someone can tell me something. Or, that it just can't be done
0
 
magicMushCommented:
could you tell me how you access the remote server.
such as do you have ssh access to the server
or any control panel like
cPanel or Plesk

0
 
chasferrAuthor Commented:
MagicMush,
      I use cPanel on a remote server running mysql.  Unix or linux system.
0
 
magicMushCommented:
Try:

in cPanel go to Manage Mysql/MySQL Databases

at the bottom of the MySQL page you will see

Access Hosts:
add the computers IP address to the access hosts.
and dont forget the wild cars are allowed.  (if you are using static ip you wouldnt need to use wildcards)

e.g if your ip is 81.31.154.25
you can use     81.31.154.%

IP addresses should be the on you access the internet with (assigned by your ISP) not any internal netwrok address if you are using more than one NIC.

OR you can do it with dns name
e.g
if your dns name is
spr1-bagu3-6-0-cust111.manc.broadband.ntl.com
you can use
spr1-bagu%-%-%-cust%.manc.broadband.ntl.com
how ever this will allow any one using ntl broadband to access you mysql database so make sure you use password.

this will allow other computers to access to MySQL database remotely.

this is how I access to my MySQL servers remotely using Java->ODBC connection.

Hope this will help and if you need any more info let us know :)


0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.