Default Option: Explore, Open

Windows XP has two options for "opening" a folder: "Open" and "Explore".  Ordinarily, double-clicking a desktop folder (such as my computer) will use the "open" command, while either "open" or "explore" can be accessed via the right-click menu.  Then, if it is opened using "explore", double-clicking any folder within will open in the same window with the same settings (regarding "folder" view on left hand side).
In the aim of making the initial double-click use the "explore" command, I used "folder settings (file types tab)" to set the default action as "explore".  This worked, however if a folder is being viewed without the "folder view" (i.e. having used the "open" command), a new window will be opened using the "explore" command.  (The same thing but in reverse happens if I set "open" as default).  This I do NOT want.  I want the same window always used.
What I would like is to have the initial soft selection of command returned, rather than the hard selection I have currently.  I can't return to the initial "no default" setting as the "folder options (file types tab)" has only a "set default" option, (no "remove default" option).
System restore did not rectify this.
I am comfortable using regedit if two or more people suggest the same thing and nobody disagrees (or you convince me I should).

(Sorry, I've removed some of the niceness in asking the question to try to be clear.  I will be grateful, despite my tone.  Thankyou!)
shirlinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
SheharyaarSaahilCommented:
Hello shirlin =)

Well i dont know if u ahve tried it already or not,,,, but im just checking so dont mind :)

if u goto Explorer>Tools>Folder Options>General>under Browser Folders, there are two choices

Open each folder in Same Window
Open each folder in its own window

Are u sure that u have not selected the Second choice ;-)
0
 
shirlinAuthor Commented:
I already tried this it doesn't work, :-)  even if I set it to "own window" apply it, then set it back to "same window".

The folder still opens within its own window, but only if the current window matches the "default" option I have set in "file types" for "folder" type.  I.e. if default is "explore", it will open in its own window if the folder tree view is displayed on the left - but not if it isn't.

But thanks for the first reply.
0
 
SheharyaarSaahilCommented:
ok okkkk..... so i get ur point NOW....

what u want is to open all folders in the same window despite they are Explored or Opened !!!!!
u dont need to OPEN another window if u are Exploring a folder....right :)
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
shirlinAuthor Commented:
That's the problem. :D
As I made the change in the "file-types" tab of folder options, I suspect what needs to be changed is an entry in the classes section of the registry, but I don't understand binary, or I just can't find the right setting :).

Of course, there may be another way.
0
 
SheharyaarSaahilCommented:
now that's a Unique task..... needs too much knowledge and research,,, coz its all related to registry settings !!!!
Shud i give u the contact number of Bill Gates ;-)

anywayzzzz i cud find only this discussion coz they are talking abt some HKEY_CLASSES_ROOT\Directory\shell registry for opening folders in the same window..... thought can be useful for u >> http://www.annoyances.org/exec/forum/winxp/t1026188651

!! Good Luck !!
0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
shirlinAuthor Commented:
Awesome!  Initially, I thought it didn't work.  Because some registry settings take effect immediately, and some after log off/on.  But a registry change and then a little fiddle with the "file types" tab to make "explore.exe" refresh the settings did the trick.

In the words of my very close friend, (who's an excitable girl from Japan):
Yaaaay! Hullah, Hullah! Waaaaiiiiii! Yay! Wa!

A small thing, but damn irritating.
And I learnt some more about the registry.
Thankyou.
0
 
SheharyaarSaahilCommented:
lol...... glad u got it resolved my frined...... Cheers ^_^
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.