IIS 6.0 and InterDev (Can't connect)

I used to work on IIS 5.0 (Windows 2000) using Visual InterDev and everything was going great, and now I migrated to Windows 2003 Enterprise and IIS 6.0 but I can't connect to IIS from InterDev anymore, it's giving me an error "Unable to contact web server http://servername"

what happened ? even I tried to create a virtual directory with my old ASP pages and it gave me a 404 error as if the pages aren't there...
Any idea what is causing this ? do I need an SP for InterDev to get it to work with IIS 6 ? I also tried to run IIS 6 in Isolation Mode (IIS 5 Compatible) for no avail...

Who is Participating?
ajaikumarrConnect With a Mentor Commented:

Check this article related to "Unable to contact web server"

first point, by default, IIS 6 will only display html files, so if you want to enable asp, front page extensions, etc, you have to enable these applications and extensions to run in IIS.

so, go into Internet Services Manager and allow web server extensions, etc. and then see if it works!

try this tooo (http://www.experts-exchange.com/Web/Web_Servers/IIS/Q_20878965.html)
Enable a Pre-existing Web Service Extension in IIS 6.0 (i.e. asp)

1. Open IIS Manager, expand the master server node (that is, the
   <Servername> node), and then select the Web service extensions node.

2. In the right pane of the IIS Manager, right-click the extension that
   you want to enable. In this example, this is Active Server Pages.

3. Click to select the Allow check box.

Add a New Web Service Extension to IIS 6.0

 To permit IIS to serve content that requires a specific Internet
    Server Application Programming Interface (ISAPI) or Common Gateway
    (CGI) extension that is not already listed in the Web service
extensions list,
    follow these steps:

1. Open IIS Manager, expand the master server node, and then select the
   Web service extensions node.

2. In the right pane of the IIS Manager, click Add a new Web service
   extension under Tasks.

3. In the Extension name box, type a friendly name for the extension
   that you want to add (for example, "FrontPage Server Extensions").

4. In the Required files box, click Add, and then select the path and
   name of the file that will handle requests for the specific extension.
   After you select the path and file name, click OK.

5. If the extension must be enabled immediately, click to select the
   Set extension status to allowed check box.

6. Click OK to save your changes.

raybeamAuthor Commented:
I couldn't verify the solution throughly, maybe there was somethin missing in my 2003 installation, I reverted back to Windows 2000 and everything is working perfectly, that's why I gave a B grade...but I guess this question can prove usefull to others having the same problem...


Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.