Solved

HTTP Error Administering Public Folders

Posted on 2004-08-25
5
1,155 Views
Last Modified: 2012-05-05
Exchange 2000 running on Windows 2000 (Windows Small Business Server 2000, actually).

In System Manager, when I attempt to expand the "Public Folders" group, I get a error box with this information:

----
The operation failed due to HTTP error 405
Facility: Exchange System Manager
ID no: c1030af4
Exchange System Manager
----

The HTTP error varies -- sometimes it's 501.  The "ID no", however, seems to stay consistent.

This guy had the same problem, but with HTTP error 502.

http://www.webservertalk.com/archive127-2004-3-141341.html

Doesn't look like he got any help.

I've Googled the crap out of this, with no success.  I dismounted the store, and ran ESEUTIL up, down, and sideways.  The public store has been checked, defragmented, compacted, etc. from here to Timbuktu.  It couldn't be in better shape, yet the error continues.

I'm really intrigued at the concept of an HTTP error in Exchange.  I don't get it.

Deane
0
Comment
Question by:deane_barker
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 4

Expert Comment

by:ehammersley
ID: 11898774
Right, your store is coming back clean because it's not at fault.  The HTTP error is most likely because Exchange System Manger uses http against IIS to connect to the public folder store.  The error you're receiving is due to a problem with IIS.  Restart IIS, in case you haven't rebooted the server.  ExAdmin is the virtual folder in IIS that you're interested in.

I hate to be so generic with my link but I can't narrow it down further.  This link will take you to Microsoft's KB, there are several articles concerning similar issues with ESM and public folders.  They are ALL connected by IIS, and so is yours.  It will give you a good start to checking the health of IIS.  Two that stand out as most common, changing the default port from 80 and a non-default host header.  Doesn't seem like they should be connected, but they are.

http://support.microsoft.com/search/default.aspx?Queryc=public+folders+exadmin&Query=public+folders+exadmin&srch=sup&catalog=LCID%3D1033%26CDID%3DEN-US-KB%26PRODLISTSRC%3DON&Product=exch2k&KeywordType=ALL&Titles=false&numDays=&MaxResults=25&srchstep=3&InCC_hdn=true&querySource=gASr_Query

0
 
LVL 1

Author Comment

by:deane_barker
ID: 11902411
Sure enough -- there's a big, red, "Error" sign next to the folder.  The question is, why?  Is there a log somewhere?

This is also complicated by the fact that I'm running IIS on a different port.  I have Apache on this machine, running on Port 80.  I've moved the Default Web Site off to Port 81.  Does Exchange not like this?
0
 
LVL 4

Accepted Solution

by:
ehammersley earned 350 total points
ID: 11903269
The big red error sign is deceptive.   That is probably due to the WWW service starting prior to the Exchange IS server... a very common bug in Exchange 2000.  The virtual directories with red stops are really running... they just don't look like it.  The problem there is that the Exchange IS service provides IFS and those specific virtual direcories point to BackOfficeStorage.  There's nothing you can do about that and everything will operate normally even though they have the red error signs.  And yes, this is logged in the Event Log.

Now, the web services.

Port 80 is the key.  When the ExAdmin folder is not located on a virtual server running on port 80 you will receive an error like this.  Check out this article:

http://support.microsoft.com/default.aspx?scid=kb;en-us;325920&Product=exch2k

If I was you... I would stop apache, set IIS back to port 80, restart IIS and make sure the ESM Public Folder problem is indeed fixed by moving it back to port 80.  Then I would worry about how to fix it around Apache.  Just to make sure you don't do more work than needed.
0
 
LVL 1

Author Comment

by:deane_barker
ID: 11904142
You nailed it -- problem solved, and points well spent.

Very stupid limitation of Exchange, IMHO.  Do you know how trivial it would be to allow the setting of a different port?  Why does Microsoft insist on such tight integration to the exclusion of everything else?  Frustrating.
0
 
LVL 4

Expert Comment

by:ehammersley
ID: 11905796
I'm glad you atleast identified the root cause.  I hope you are able to create a solution that fits into your current configuration somehow.

I agree on the Microsoft issue.  It's tough to identify issues like this during development but in my opinion you don't hardcode something as flexable as a port number.  I wish you all the luck on this work around.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question