Urgent:  DTS package problem - Permission Denied

Posted on 2004-08-25
Last Modified: 2013-11-30
hi experts:

I created a DTS package in SQL Server 2000 to import simple CSV file.  It works in sql server.  Then I saved the DTS package as VB file and edit it by adding a form and a button to execute it in VB.  It works perfectly in VB.  Then finally I copy and paste the codes into a new ActiveX DLL project to generate a COM object so I can use it in my ASP pages.  

Now here's the problem:  
when I run the ASP page to execute the DTS COM, I get the "Permission Denied" error.
I know the DLL register correctly because the 1st debug statement in the COM object shows.  It is the main function where it execute the DTS package gets the "permission denied" message.  So what did i missed?  how can i fix the problem?  any help will be greatly appreciated!

Question by:kingsfan76
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
LVL 46

Accepted Solution

fritz_the_blank earned 250 total points
ID: 11898048
Make sure that the IUSR_ and IWAM_ accounts have the proper permissions.

LVL 31

Assisted Solution

alorentz earned 250 total points
ID: 11898075
To add, IUSR_ and IWAM_ accounts have the proper permissions ON THE SQL SERVER AND THE DLL.
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

LVL 12

Author Comment

ID: 11898764
I had the dll security set correctly.
I added sercurity access for the file "dtspkg.dll" (which is the MS DTSpackage object library referenced in the VB COM object).  now the "permission denied" error is gone, but i get this new error:

>>> Automation error The specified module could not be found.

this error line is on
>> Set goPackage = goPackageOld
in COM object

the datatype for them are declared as the following:
>>Public goPackageOld As New DTS.Package
>>Public goPackage As DTS.Package2

LVL 12

Author Comment

ID: 12147865
i couldn't get DTS with COM to work in our https server.  Tried using ActiveX also, it works within the server but would not work from outside.  Ended up using ADODB to read the xls and CSV files (had to do xls because Excel would not produce correct CSV files (No quotes on text string).

anyway i think permission is probably the problem... thanks for the response and i'll split the points with a grade of B, hope you guys don't mind

LVL 46

Expert Comment

ID: 12147873
That sounds fine. Good luck with your project,

LVL 31

Expert Comment

ID: 12147926
A "B".....ruined my night! :)

Good luck!

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
It is possible to export the data of a SQL Table in SSMS and generate INSERT statements. It's neatly tucked away in the generate scripts option of a database.
This video shows, step by step, how to configure Oracle Heterogeneous Services via the Generic Gateway Agent in order to make a connection from an Oracle session and access a remote SQL Server database table.
Via a live example, show how to backup a database, simulate a failure backup the tail of the database transaction log and perform the restore.

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question