ODBC data source fails to connect to SQL Server 2000 via dial-up, but ok on broadband.

Posted on 2004-08-25
Medium Priority
Last Modified: 2008-03-17

Hello, I have a situation in which a laptop user works from home, using a proprietary application.
This application connects to a SQL Server at the office using ODBC.  Although I think irrelevant at this point, the user connects to office LAN via VPN.

The ODBC data source setup on client's laptop connects successfully and therefore the application runs well, so long as he is at home (where he has a broadband connection to Internet).

If he leaves home and goes on the road (w/ same laptop), uses dial-up to connect to Internet, the application subsequently fails (I check and find that it is the ODBC data source that does not connect successfully).  

Machine is running XP Home with the latest version of SQL Server data source.
Error is something along the lines of: SQL Server not found or invalid user name (I'm paraphrasing).

My attempts at solution:
ODBC is setup to authenticate using Windows NT authentication (not SQL Server user authentication).
Note that there are 6 other users on home, broadband connections with no problems at all who connect to the office LAN every day.
This implies - I believe - that it is indeed just a dial-up issue.
I've tried different dial-up ISPs; inquired with them to determined if it is a known problem.
I checked the time-out settings in SQL Server, for the possibility that connection is timing out and set it to its highest.

I hope this information helps.  Thanks.
Question by:JohnItem
  • 3
  • 3

Accepted Solution

gclay1 earned 760 total points
ID: 11909481
Hi - I have a couple of ideas you can try...

First, try using the HOSTS file on the XP Home system to help the name resolution process.  If you are not familiar with the HOST file, just perform a search for HOSTS*.  There will be a couple on the system... be sure to choose the one in the OS system's DRIVERS/ETC folder.  Open the HOSTS file in notepad.  You should see an entry that looks like this...       localhost

Try adding another line to help resolution of your SQL servers host name, like this...       localhost

...where <IP ADDR> is the ip address of your SQL server, and <SVR-NAME> is the netbios name of your SQL server, separated by a tab.  Be sure to save the HOSTS file as text only.

Second, have a look at the settings for the dial-up account to make sure NetBios Over TCP/IP is enabled...

1.  Right click on the dialup account and select PROPERTIES
2.  Go to the NETWORKING tab and highlight the INTERNET PROTOCOL (TCP/IP) item, then click PROPERTIES.
3.  Click the ADVANCED button.
4.  Select the WINS tab and make sure the setting for ENABLE NetBios Over TCP/IP is selected.

Give these two approaches a try and let me know.
Good luck!

Author Comment

ID: 11918085
I've taken the two steps above, but I'm afraid the message remains.

Exactly it is:
Microsoft SQL Server ODBC Driver Version 03.81.9002

Running connectivity tests...

Attempting connection
[Microsoft][ODBC SQL Server Driver][Named Pipes]SQL Server does not exist or access denied.


Thank you for the continued support.

Expert Comment

ID: 11919010
Hi again...
Have you checked the properties of your ODBC connection to make sure your are using TCP/IP instead of named pipes?

1.  Highlight the connection, click CONFIGURE, then NEXT.
2.  Click the CLIENT CONFIGURATION button.  Make sure it is set to TCP/IP.
3.  Also try changing both Server Name and Server Alias to the IP address, instead of the name.

I'm still thinking...
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.


Expert Comment

ID: 11919037
By the way, if changing the alias to IP address does not work, try REMOVING the alias in the Client Configuration section...

Author Comment

ID: 11989997
My apologies for the delay... User is on holidays and I do not have access to PC until his return.
Guess it's not as urgent as they had me believe.

I will test modifications as soon as possible and get back to you.  I will also increase the points to 190 (all I have so far).

Author Comment

ID: 12102473
Thank you gclay1.

Your first post did the trick.  I used the Hosts file, which I would never have considered.

However, the reason it failed (see my second post) the first time is because the ODBC data source WAS set to TCP/IP.  
In actuality it works when set to named pipes.  Not sure why.

Client is happy as am I.  I've increased points to 250.


Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question