Solved

Suse - Telnet

Posted on 2004-08-25
10
1,134 Views
Last Modified: 2013-11-13
Hi,
  I want to enable Telnet on my Suse 9.1 box.  I know the security issues but it just for testing purposes.  I can connect using Secure Shell or Putty.  When I try to connect with Telent it displays "connection refused".
  Any help?  Thanks.  george
0
Comment
Question by:jungleGeorge
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 11

Expert Comment

by:avizit
ID: 11899865
are you sure your telnet server is running ?
0
 
LVL 11

Accepted Solution

by:
avizit earned 475 total points
ID: 11899874
if its not running try the following



Edit the file  /etc/xinetd.d/telnetd
changing the two lines to:
# default: on
disabled = no
then run the command
/etc/rc.d/init.d/xinetd restart
0
 
LVL 24

Assisted Solution

by:sciuriware
sciuriware earned 25 total points
ID: 11899932
You better use YAST to switch on the telnet services, be careful with editing system files on SuSE:
those get overwritten sometimes.
;JOOP!
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 

Author Comment

by:jungleGeorge
ID: 11899963
Thanks for the quick feed back.  I will look at it in the morning.  I will award the points once the service is functional.  Thanks.  George
0
 
LVL 48

Expert Comment

by:hernst42
ID: 11901214
Make sure the package telnet-server is installed
rpm -qa | grep telnet should list that package
in /etc/xinetd.d/telnet replace the disablesd = yes with disabled=no
restart your xinted and you should have a running telnet-server

(Just tried on my SuSE 9.1 box)
0
 

Author Comment

by:jungleGeorge
ID: 11909700
Hey,
  I can logon locally with telnet but it returns no ping or a connection to telnet.  I think the firewall is enabled and not letting it answer.  
0
 
LVL 48

Expert Comment

by:hernst42
ID: 11911859
Could be just configure your firewall to let telnet through.
yast2->security -> firewall
0
 

Author Comment

by:jungleGeorge
ID: 11919215
I turned off the firewall.  (It is a test box behind a firewall) Telnet is now working locally, and from my other Suse box.  When I try to connect with a Windows machine I get an error that it can not open port 23.  george
0
 
LVL 11

Assisted Solution

by:avizit
avizit earned 475 total points
ID: 11919229
try with a different client
e.g putty http://the.earth.li/~sgtatham/putty/latest/x86/putty.exe

sometimes windows native telnet client has problems
0
 

Author Comment

by:jungleGeorge
ID: 11919287
That works for me.  Thanks.  I have another question that I will be posting later about how to install SSH on Suse.  I have the question answered for this topic and the points are awarded.  I decided to split the points since several comments drove me to the path of it operating successfully.  jungleGeorge.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Create a Windows 10 custom Image with custom task bar and custom start menu using XML for deployment.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question