Solved

getting split.c:51:4: #error while installing mtr-0.44

Posted on 2004-08-26
4
214 Views
Last Modified: 2013-12-06
Hi,
I am trying to install mtr-044 on a Fedora Core release 1. Its a program which pings and does traceroute simultaneously. While issuing the command 'make' i get the follwoing error:

root@test mtr-0.44]# make
make  all-recursive
make[1]: Entering directory `/home/test/mtr-0.44'
Making all in img
make[2]: Entering directory `/home/test/mtr-0.44/img'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/test/mtr-0.44/img'
make[2]: Entering directory `/home/test/mtr-0.44'
gcc -DHAVE_CONFIG_H -I. -I. -I.     -g -O2 -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -c split.c
split.c:51:4: #error No curses header file available
make[2]: *** [split.o] Error 1
make[2]: Leaving directory `/home/test/mtr-0.44'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/test/mtr-0.44'
make: *** [all-recursive-am] Error 2
[root@test mtr-0.44]#

What does that error mean? Previously I was running the same program in Redhat 7.1 without any errors.

TIA,
S.
0
Comment
Question by:shekharbasnet
  • 2
  • 2
4 Comments
 
LVL 6

Expert Comment

by:de2Zotjes
ID: 11901686
Ther error is clear: there is no curses header file available.
The header file is needed to inform the mtr packet about the capabilities of your curses libraries (roughly).

The easiest solution is to install the rpm that contains those header files. In redhat/fedora speak those are the devel-packages. So you probably have a ncurses library on your system (check with rpm -q -a|grep curses), install the devel-rpm for the SAME version:

rpm -q -a|grep ncurses

ncurses-5.2-26

rpm -iv ncurses-devel-5.2-26.rpm

You will probably have to search for the file on your distribution medium or the internet.
0
 
LVL 2

Author Comment

by:shekharbasnet
ID: 11924392
Ok, I downloaded and isntalled the relevant devel-rpm.

[root@test mtr-0.44]# rpm -qa | grep curses
ncurses-5.3-9
ncurses-devel-5.3-9
[root@test mtr-0.44]#

But  I am still getting the same error. Any other suggestions?

TIA
s.
0
 
LVL 6

Accepted Solution

by:
de2Zotjes earned 125 total points
ID: 11926885
You need to "clean" out the configuration data that is stored for the mtr package:

make distclean (might produce an error, no such target)
make clean

ls -a| grep cache

remove any cache files having anything to do with config.

After all this do another
./configure
make all
0
 
LVL 2

Author Comment

by:shekharbasnet
ID: 11929118
Perfect...

Thanks a lot

-s
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Monitor input from a computer is usually nothing special.  In this instance it prevented anyone from using the computer.  This was a preconfiguration that didn't work.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

947 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now