Solved

Creating write cache for A: (floppy) drive

Posted on 2004-08-26
2
351 Views
Last Modified: 2013-12-06
I try setting up write behind cache for the floppy drive but it doesn't seem to be working.
I have the following in my autoexec.bat file:
smartdrv a+ /N

And I get the following when I query smartdrv:
******************************************
C:\WINDOWS\DESKTOP>smartdrv
Microsoft SMARTDrive Disk Cache version 5.02
Copyright 1991,1993 Microsoft Corp.

Cache size:  2,097,152 bytes
Cache size while running Windows:  2,097,152 bytes

            Disk Caching Status
drive   read cache   write cache   buffering
--------------------------------------------
  A:       yes           yes          no
  B:       yes           no           no
  C:       yes           yes          no
  D:       yes           yes          no
Write behind data will not be committed before command prompt returns.

For help, type "Smartdrv /?".
C:\WINDOWS\DESKTOP>
******************************************

However, when I write to the A: drive the command prompt does not return untill all the data is completely written to the drive.

How can I setup the cache so that the command prompt returns once the data is in the cache buffer?
0
Comment
Question by:Axter
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
2 Comments
 
LVL 10

Expert Comment

by:For-Soft
ID: 11904776
Try /N switch with SMARTDRV.
By default SMARTDRV writes down hdd cache before command prompt returns for all cached drives.
0
 
LVL 10

Accepted Solution

by:
For-Soft earned 500 total points
ID: 11904963
It works good with Windows 95. All I did was running in AUTOEXEC.BAT.
SMARTDRV /X
Then I turned on write cache for all my drives:
SMARTDRV a+
SMARTDRV c+
SMARTDRV d+
Then I switched write behind on:
SMARTDRV /N
And it worked.
After copying large file to a: I was browsing the directory tree on C: drive. Fdd was writing something from time to time. Then I pressed CTRL+ALT+DEL. Smartdrv displayed writing down cache data. FDD was active for some time. Then computer restarted.
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
An article on effective troubleshooting
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question