Solved

when ever i display a  ® symbol in my JSP or someother special chacters in my JSP i get a ?

Posted on 2004-08-26
10
160 Views
Last Modified: 2010-04-01
hello
when ever i display a  ® symbol in my JSP or someother special chacters in my JSP i get a ?

What is strange is on a different box it works fine.

Same version of tomcat and jdk

This one is driving me crazy.

please help, this is got to be a simple one.
0
Comment
Question by:paries
10 Comments
 
LVL 11

Expert Comment

by:sompol_kiatkamolchai
ID: 11905170
Try this

<html>
&#174;
</html>
0
 
LVL 11

Expert Comment

by:sompol_kiatkamolchai
ID: 11905198
You can represent ® with &#174; in html.

This is HTML Entity Element.

If you want another sign, please check it from this url

http://www.htmlcodetutorial.com/characterentities_famsupp_69.html
0
 
LVL 11

Expert Comment

by:sompol_kiatkamolchai
ID: 11905203
Hope that help.

SomPoL
0
 

Author Comment

by:paries
ID: 11905408
That does not really solve my problem

the jsp is reading a text file
on one machine all the special character display fine
on the other they are all question marks.

0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 19

Expert Comment

by:ramazanyich
ID: 11906538
The probelm is that on client PC character encoding which doesn't include  registered trademark can be enabled. Try to set encoding on clinet by using JSP directive at the beginning of your JS page:
<%@ page contentType="text/html; charset=iso-8859-1" %>
0
 

Author Comment

by:paries
ID: 11906571
the problem was in my /etc/sysconfig/i18n
0
 
LVL 3

Expert Comment

by:haobaba1
ID: 11916900
Hey Paries what was the problem?
0
 

Author Comment

by:paries
ID: 11917511
my site is a combo of perl and j2ee

When i upgraded to rh9 the perl got these wierd messages

so i changed the file /etc/sysconfig/i18n on one machine but not the other

i can not remember what it was originally but now the line in the file reads
LANG="en_US"

Hope that help
randy
0
 

Accepted Solution

by:
ee_ai_construct earned 0 total points
ID: 11947437
Closed, 500 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Moderator
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

In 2017, ransomware will become so virulent and widespread that if you aren’t a victim yourself, you will know someone who is.
A customer recently asked me about anti-malware and the different deployment options available for his business. Daily news about cyberattacks, zero-day vulnerabilities, and companies that suffered a security breach made him wonder if the endpoint a…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now