Solved

Digit translation on AS5350 gateway

Posted on 2004-08-26
7
444 Views
Last Modified: 2010-04-12
I have a calling card platform with AS5350 and matrix 4.1 billing software on server. I have a major problem when trying to translate local call to international format (0208 to 0044 208), or simply trying to get any translation rule working. I have to go to the billing to do it but then again, the 020 won't work when I try to translate it to international format 0044 20. I have to call the nb with international format to get it working. any help please? Is it the billing or the tcl script messing me about? I am about to drop the whole thing together as people I know as experts cannot help at all. Please Please help as I cannot have a good slip due to the card already printed, cannot be sold because of this.
0
Comment
Question by:jeanpoman
  • 3
  • 2
  • 2
7 Comments
 
LVL 3

Expert Comment

by:rwotherspoon
Comment Utility
I can help you but need to work the patterns with these questions like this:

1.  What is the entire digit string you get from the calling party?
2.  What is the entire digit string the called party (phone company) is expecting from you in order to place the call?
3.  What type of interface are you using for the inbound and outbound calls?
0
 

Author Comment

by:jeanpoman
Comment Utility
Thanks a lot Rwotherspoon for your assistance, the whole string is anything from london: 0208 893 6333. The phone company is expecting 44-208-893 6333. What I am doing now is to key the 0044 208 893 6333 knowing that the billing software will stip off the 00 and forward the call to the port 1/0:D where I terminate my local calls.
Out bound & Inbound are all using the same port on interface serial 1/0 (E1). The configuration on dial-peer is port 1/0:D. The command used is "translation-rule 10044 then define rules and apply the "translate-outgoing called 10044" on the dial-peer 1 pots. Right now I have removed the command as It is being confused with the translation in the matrix billing system.
Here is the configuration:

Current configuration : 4000 bytes
!version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RDCGW
!
boot-start-marker
no boot startup-test
boot-end-marker
!
enable secret 5

resource-pool disable
clock summer-time summer date Mar 28 2004 1:00 Oct 31 2004 1:00
spe default-firmware spe-firmware-1
aaa new-model
aaa authentication login default local group radius
aaa authentication login h323 group radius
aaa authorization exec h323 group radius
aaa accounting connection h323 start-stop group radius
aaa session-id common
ip subnet-zero
ip cef
ip host prompts 172.17.1.2
!
isdn switch-type primary-net5
voice class codec 1
 codec preference 1 g723r53
 codec preference 2 g723r63
 codec preference 3 g729r8
 codec preference 4 g729br8
 codec preference 5 g726r16
 codec preference 6 g726r24
 codec preference 7 g726r32
 codec preference 8 g711alaw
 codec preference 9 g711ulaw
 codec preference 10 g723ar53
 codec preference 11 g723ar63
 codec preference 12 clear-channel
 codec preference 13 gsmfr

controller E1 1/0
 framing NO-CRC4
 pri-group timeslots 1-31

controller E1 1/1
 framing NO-CRC4
 pri-group timeslots 1-31
!
controller E1 1/2
 framing NO-CRC4
 pri-group timeslots 1-31
!
controller E1 1/3
 framing NO-CRC4
 pri-group timeslots 1-31
gw-accounting syslog
gw-accounting aaa
!
!
!
interface FastEthernet0/0
 ip address 212.58.135.141 255.255.255.128
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.17.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clockrate 2000000
!
interface Serial0/1
 no ip address
 shutdown
 clockrate 2000000
!
interface Serial1/0:15
 no ip address
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice modem
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Serial1/1:15
 no ip address
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice modem
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Serial1/2:15
 no ip address
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice modem
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Serial1/3:15
 no ip address
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice modem
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Group-Async0
 no ip address
 group-range 2/00 3/59
!
ip classless
ip route 0.0.0.0 0.0.0.0 212.58.135.129
ip http server

radius-server host 172.17. auth-port 1812 acct-port 1813
radius-server key ascent
radius-server vsa send accounting
radius-server vsa send authentication
call rsvp-sync resv-timer 60
call language voice fr tftp://172.17./fr_tts.tcl
!
call application voice debit tftp://172.17./app_debit_m.tcl
call application voice debit uid-len 6
call application voice debit retry-count 5
call application voice debit language 1 en
call application voice debit language 2 fr
call application voice debit set-location en 0 tftp://prompts/prompts/en/
call application voice debit set-location fr 0 tftp://prompts/prompts/fr/
!
voice-port 1/0:D
 cptone GB
!
voice-port 1/1:D
 cptone GB
!
voice-port 1/2:D
!
voice-port 1/3:D
!
!
!
dial-peer voice 1 pots
 application debit
 incoming called-number .T
!
dial-peer voice 2 pots
 destination-pattern .T
 no digit-strip
 port 1/0:D
!
!
!
line con 0
line aux 0
line vty 0 4
line 2/00 2/59
 modem InOut
line 3/00 3/59
 modem InOut
!
scheduler allocate 10000 400
ntp clock-period 17179781
ntp server 130.88.200.98 prefer
end

RDCGW#


User Access Verification

Username: jpoman
Password:

RDCGW>enable
Password:
RDCGW#show runn
RDCGW#show running-config
Building configuration...

Current configuration : 4000 bytes
!
! Last configuration change at 00:25:15 summer Sat Aug 28 2004
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RDCGW
!
boot-start-marker
no boot startup-test
boot-end-marker
!
enable secret  
!!
resource-pool disable
clock summer-time summer date Mar 28 2004 1:00 Oct 31 2004 1:00
spe default-firmware spe-firmware-1
aaa new-model
!
!
aaa authentication login default local group radius
aaa authentication login h323 group radius
aaa authorization exec h323 group radius
aaa accounting connection h323 start-stop group radius
aaa session-id common
ip subnet-zero
!
!
ip cef
ip host prompts 172.17.1.2
!
isdn switch-type primary-net5
!
!
voice class codec 1
 codec preference 1 g723r53
 codec preference 2 g723r63
 codec preference 3 g729r8
 codec preference 4 g729br8
 codec preference 5 g726r16
 codec preference 6 g726r24
 codec preference 7 g726r32
 codec preference 8 g711alaw
 codec preference 9 g711ulaw
 codec preference 10 g723ar53
 codec preference 11 g723ar63
 codec preference 12 clear-channel
 codec preference 13 gsmfr
!
!
!
!
!
!
!
!
!
!
!
!
!
controller E1 1/0
 framing NO-CRC4
 pri-group timeslots 1-31
!
controller E1 1/1
 framing NO-CRC4
 pri-group timeslots 1-31
!
controller E1 1/2
 framing NO-CRC4
 pri-group timeslots 1-31
!
controller E1 1/3
 framing NO-CRC4
 pri-group timeslots 1-31
gw-accounting syslog
gw-accounting aaa
!
!
!
interface FastEthernet0/0
 ip addr 255.255.255.128
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.17. 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clockrate 2000000
!
interface Serial0/1
 no ip address
 shutdown
 clockrate 2000000
!
interface Serial1/0:15
 no ip address
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice modem
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Serial1/1:15
 no ip address
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice modem
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Serial1/2:15
 no ip address
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice modem
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Serial1/3:15
 no ip address
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice modem
 isdn send-alerting
 isdn sending-complete
 no cdp enable
!
interface Group-Async0
 no ip address
 group-range 2/00 3/59
!
ip classless
ip route 0.0.0.0 0.0.0.0 212.58.135.129
ip http server
!
!
!
!
radius-server host 172.17. auth-port 1812 acct-port 1813
radius-server key ascent
radius-server vsa send accounting
radius-server vsa send authentication
call rsvp-sync resv-timer 60
call language voice fr tftp://172.17./fr_tts.tcl
!
call application voice debit tftp://172.17/app_debit_m.tcl
call application voice debit uid-len 6
call application voice debit retry-count 5
call application voice debit language 1 en
call application voice debit language 2 fr
call application voice debit set-location en 0 tftp://prompts/prompts/en/
call application voice debit set-location fr 0 tftp://prompts/prompts/fr/
!
voice-port 1/0:D
 cptone GB
!
voice-port 1/1:D
 cptone GB
!
voice-port 1/2:D
!
voice-port 1/3:D
!
!
!
dial-peer voice 1 pots
 application debit
 incoming called-number .T
!
dial-peer voice 2 pots
 destination-pattern .T
 no digit-strip
 port 1/0:D
!
!
!
line con 0
line aux 0
line vty 0 4
line 2/00 2/59
 modem InOut
line 3/00 3/59
 modem InOut
!
scheduler allocate 10000 400
ntp clock-period 17179785
ntp server 130.88.200.98 prefer
end
0
 
LVL 3

Expert Comment

by:rwotherspoon
Comment Utility
I will try and provide a coherent response today - however, I have been preparing for hurricane Frances in Orlando.  Please be patient.  Thanks !
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 3

Expert Comment

by:rwotherspoon
Comment Utility
I will try and provide a coherent response today - however, I have been preparing for hurricane Jeanne in Orlando.  Please be patient.  Thanks !
0
 
LVL 12

Accepted Solution

by:
Joel_Sisko earned 500 total points
Comment Utility
Jeanpoman,

Were you able to resolve this matter? I amy be of some assistance.
0
 

Author Comment

by:jeanpoman
Comment Utility
Dear Joel, I saw many of your comments and I can assure you that it is only God who can bring a person like you here to help people like myself. The issue is sorted now. I have another problem related to VOIP-to-VOIP termination: I am running a call shop and I have a cisco AS5350 to terminate my calls. The problem is that, the callshop has a fxs gateway (welltech 4-fxs gateway) making calls via internet rather than PSTN. those calls will hit my gateway and only calls going to E1 are terminated. Calls I am sending to my other partners connected to my cisco by voip won't be terminated. I do not have a gatekeeper. What I should do? Will it be the same probleme if I cannect SIP phones as well?
0
 
LVL 12

Expert Comment

by:Joel_Sisko
Comment Utility
jeanpoman,

Thank you for the ego boost (I give God the credit for all my knowledge). In regards to your current issue, will gladly help. Also might recommend that you might want to post your above question as a new one, though my knowledge runs deep, there is always someone else that knows a little more.

Will need more clarification of your setup:

PSTN connections
Internet connections
VoIP protocols being used
configs for Cisco equipment
Partners setup/connections

Just a few parting thoughts for the night:

Without a gatekeeper, I think you will be relying upon how your dial peers have been configured, this might be part of the routing issues that you have now. In regards to the SIP phones and how your VoIP network is setup, you might not have the above problems, just for the fact that the SIP messaging format helps to route the call thru a network.
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Article by: user_n
How Sip Phone (User Agent) works and communicates with sip servers 1.  There is a sip server and a sip registrar.  The sip server and sip registrar can be one server or two different servers. The sip registrar is the server on which it is record…
Hey there Heard about jingle, the add on for XMPP that enables point to point audio between two XMPP clients. No server config necessary. Actually quite a cool feature. However, how good is it if you can not use those voice capabilities to do a P…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now