Solved

ISAPI DLL will not execute with Windows XP Professional.

Posted on 2004-08-27
10
178 Views
Last Modified: 2010-04-05
I have a project which runns on Windows 2K, but since changing to windows XP I cannot get the thing to execute.
In both occasions I use IIS.

I have re-compiled the WEB DLL to an EXE, and this works fine.
But with XP I just cannot get the DLL's to run. All I get is "The page cannot be displayed".


Is there a setting on the IIS that I have missed ?
0
Comment
Question by:chunky1
10 Comments
 
LVL 13

Expert Comment

by:BlackTigerX
ID: 11914371
(from IIS manager) did you set the Execute Permissions to Scripts and Executables in the folder where you dropped your ISAPI DLL?

if you did, then the only other thing to do is use a log file where you write from your ISAPI file all the steps, then you'll be able to see where it "broke"

Other thing you might want to do is in your Internet Options | Advanced, Browsing, check OFF the option "Show friendly HTTP error messages"
0
 
LVL 7

Expert Comment

by:DavidBirch2dotCom
ID: 11915089
You may need to set the DLL as an 'Allowed Web Server Extension' under the ISS manager, this got my projects up and running.

DAvid
0
 
LVL 7

Expert Comment

by:DavidBirch2dotCom
ID: 11915167
This file has alot of info related to moving between 2000 and 2003/XP might be of some use
www.microsoft.com/korea/ windowsserver2003/docs/MovingNT4.doc

page 9 looks interesting - have you checked your security measures ?

David
0
Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

 
LVL 13

Expert Comment

by:BlackTigerX
ID: 11916843
for XP you should only need to set the Scripts and Executables permission... for 2003 is where you need to add the "allowed server extension"
0
 
LVL 7

Expert Comment

by:DavidBirch2dotCom
ID: 11921867
BlackTigerX  > technicalities technicalities, it still might well help - wouldnt it depend on which version of ISS is running ?
0
 
LVL 1

Author Comment

by:chunky1
ID: 11940638
In IIS I have the Execute permissions set to 'Scripts & Executables'.

I cannot create a log file from my DLL as it never loaded, This I have prooven by inserting a basic 'beep' statement in the oncreate routine.

I have set my browser configuration to dis-allow any friendly messages, after looging at the log file for the IIS status 500 is returned.

I have tried looking for where I can set the DLL as an allowed Web Server Extension, but I am not sure where this is. I have a setting tab called 'Server Extensions'  but in here I have two options :- 1. Enable Authoring. 2. Don't inherit secuity settings.

IIS is version 5.1

I have also read the interesting article from David but after reading through it and doing some investigating, I dont seem to have a copy of the lockdown wizard.
0
 
LVL 13

Expert Comment

by:BlackTigerX
ID: 11965089
you need to put your logging mechanism not inside the class only, but from the DLL, so you can see before it even creates the module
are you using any third party components from that ISAPI DLL? if you are, then that could be the problem if you don't have the necessary DLLs in the other machine

"allowed Web Server Extension" is only required in Windows 2003 (IIS 6), for IIS 5.1 you only need to do the Scripts and Executables
0
 
LVL 7

Expert Comment

by:DavidBirch2dotCom
ID: 11965884
The IIS look down tool is located here

http://www.microsoft.com/technet/security/tools/locktool.mspx

have you got microsofts ISAPI Filter Enabled? you need that to run any ISAPI dll's, I assume its automaticaly enabled...

David
0
 
LVL 7

Expert Comment

by:DavidBirch2dotCom
ID: 11965891
A lot of general ISAPI info here, prehaphs somthing there might help

http://www.dataweb.de/en/support/isapi.html

David
0
 
LVL 1

Accepted Solution

by:
primusmagestri earned 75 total points
ID: 11967296
Set the security level to low to default web site and your virtual directories (for test only). Set the user that will be used to authenticate with this application (put in a local user on that machine, not the usual IUSR_... :)) Try to debug your application and see where it fails.
From my experience, there should be no problem running an ISAPI dll on wXP if it worked on w2K.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A lot of questions regard threads in Delphi.   One of the more specific questions is how to show progress of the thread.   Updating a progressbar from inside a thread is a mistake. A solution to this would be to send a synchronized message to the…
In my programming career I have only very rarely run into situations where operator overloading would be of any use in my work.  Normally those situations involved math with either overly large numbers (hundreds of thousands of digits or accuracy re…
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now