"Failed to Save Document." Error

Hello,

I opened a Crystal Report that had previously been created.  If I edit something with the existing database connection, i'm able to save the document with no issues.  However, when I changed the database that the report was using (which I need to do), it gave me an error "Failed to Save Document".  Any suggestions on how to fix this?   Crystal Reports v10

(I went to Database > Set Datasource Location > updated the database with the new db, and updated the sproc to the new one)

Thanks for any help you can provide! =)

LVL 1
rock815Asked:
Who is Participating?
 
mlmccConnect With a Mentor Commented:
Sorry.  You should try CONVERT DATABASE DRIVER.  That works somewhat differently from SET DATASOURCE LOCATION

You can "change" the driver back to the same driver but it will walk you through connecting to the database.

mlmcc
0
 
mlmccCommented:
Did you verify the database?

Click DATABASE --> VERIFY DATABASE

Can you view the report after making the changes?  Is the data changed appropriately?

mlmcc
0
 
rock815Author Commented:
Yeah I verified the database, but you cannot see the data after the change was made.  I realize there are probably some stored procedure issues, but shouldn't you still be able to save the document?  Thanks again!
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
mlmccCommented:
I have run into this under other circumstances.  I don't recall right now how we got around it.

If you can't see the data then apparently there is something incorrect in the connection.

Did you change the database driver?  You might try changing it.  You will also get to change the database and location.

Click DATABASE --> CHANGE DATABASE DRIVER

mlmcc
0
 
rock815Author Commented:
I'm currently using v10 of Crystal.. I don't see an option for Change Database Driver off the Database tab.  :-/
0
 
mlmccCommented:
I don't have CR here and I know the CHANGE DATABASE DRIVER option is not correct.  Look at the options near VERIFY DATABASE in the list.  One of them should allow you to change the database connection method.  I had to do that when we moved our reports from the development server to the production server.

mlmcc
0
 
rock815Author Commented:
mlmcc, that's actually what I did with my original post, I believe.  The "Set Datasource Location"....

It's weird, when I try to save it locally it won't even allow me to...  It pops up three pop ups:

1) Failed To Save Document.

2) Failed to Save Database Information

3) Query Engine Error: 'The specified object was not saved.'

Does this help you help me? :-)  Thanks again!
0
 
rock815Author Commented:
That seemed to work!
0
 
mlmccCommented:
Glad I could help

mlmcc
0
 
delzzzoneCommented:
I just had same problem under CR10. Solution (for me)Database/Set Datasource Location. Dialog appears, select sp in Current Data source (upper)window Select same connection/sp inm lower window and click 'Update'
0
 
Partha MandayamTechnical DirectorCommented:
I use Crystal 9 and I don't see a CONVERT DATABASE DRIVER option. Is that specific to Crystal 10? How can I solve this problem in Crystal 9?
0
 
rock815Author Commented:
Start a new thread and I'll answer it there, so I can get points.. haha...

Just reply to this one once you do.. Thanks
0
 
mlmccCommented:
The Convert option is in CR7 & 8.  I don't have CR9 so can't check for it.

mlmcc
0
 
rock815Author Commented:
Well, I later found that I was getting the "Failed to Save" error because I had changed the stored procedure that the report was connecting to.  When I changed the stored procedure, there was a reference to an old field still in the Sort control.  So I removed it from the Sort and it was able to save the document.  So, I would imagine if you changed something, be sure you have all the references of a non-existing field removed.

Hope this helps....
0
 
Partha MandayamTechnical DirectorCommented:
I checked and there are no non-existing fields referenced. Any other ideas???
0
 
rock815Author Commented:
Did you only check the Sort?  If so, be sure to check everything for old references that are no longer in your field list... check formulas, groups, actually on your report, running total formulas, etc...

Other than that, I would say to re-create the report from scratch.. as tiresome as that can be...

Good luck - let me know if you find a solution
0
 
matthewhamerCommented:
Dependency checker can shed some light on some ropey formulas sometimes:

Report --> Check Dependencies
0
 
klinge_ttcCommented:
I know this forum is already closed, But still I thought I will put my comment because I could not get a proper answer from anywhere. But it worked for me.
We were having crystal reports 9 with vb6 and we upgraded to crystal report 10 with VS2005.
When I brought some reports some said "Failed to Save Document".
After lot of trial-n-error, I found out that in my old version, the table from which report was build was having space in between, eg. "The Table". So what I did is went into Database-Database Expert and renamed it to "TheTable" without space. And save as new report. And then imported that report into VS2005.

Hope that helps.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.