Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Win98 (first edition), ME and Netware SBS 6.5 / drives won't map

Posted on 2004-08-27
12
Medium Priority
?
321 Views
Last Modified: 2012-05-05
New SBS 6.5 server that maps drives fine on any of the customer's XP workstations. However, on the 98 and ME workstations, the users get dumped to the root of the DATA volume and not to their appropriate user directories.  The drives say that they are mapped and the scripts run fine but the path's, when you open My Computer, show only the DATA vol not the specific user directory or document directory.

Any thoughts?

I am convincing customer to upgrade pc's to XP pro but is their any quick fix in the meantime? Clients are all upgraded to the latest revisions for the specific workstation operating systems.

Thanks.
0
Comment
Question by:bscott13
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +1
12 Comments
 
LVL 34

Expert Comment

by:PsiCop
ID: 11915002
Ugh. ME. Talk about garbage. But you already know that.

HOW are you mapping the drives? MAP ROOT X:=SERVER/VOLUME:USERS\USERNAME ? If not, can you post the relevant snippet of the login script?

Have you turned off the Default Login Script with the NO_DEFAULT command in the login script?
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 11915010
What versions of the client are in use in each environment?
0
 
LVL 35

Assisted Solution

by:ShineOn
ShineOn earned 1600 total points
ID: 11915403
If you are not mapped ROOT, then they WILL show up differently.

XP, as Win2K and NT, have ROOT mapping turned on by default at the client side.  In order to make the NT-based Windoze systems act like all the non-NT-based Windoze systems do, you have to turn map rooting off.  DSPoole recommends that you add the environment setting to the beginning of the login script: DOS SET MAPROOTOFF=1

That way the mapping will be the same across all versions of Windoze, which will simplify your debugging.  This will also let you control root-mapping centrally.
0
Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

 

Author Comment

by:bscott13
ID: 11917038
Here is the login script:

NO_DEFAULT
MAP ROOT F:= EKD_OFFICE\DATA:DOCUMENT
MAP ROOT G:= EKD_OFFICE\DATA:USERS\JodeeH
MAP ROOT SEARCH1:=EKD_OFFICE\SYS:PUBLIC


Client is 3.4 for 98/ME and 4.91 SP2 for XP
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 11917103
I don't think the ROOT keyword is valid with a SEARCH drive. Certainly doesn't help anything.
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 11917116
My previous comment was NOT a solution to your issue. Still working on that.
0
 
LVL 3

Assisted Solution

by:roseanne
roseanne earned 400 total points
ID: 11917996
This is the first time I've ever heard of a win98 box having problems with Map Root.  Usually it's the w2k boxes that had problems with map commands.

What if you tried the syntax like this:

MAP ROOT F:=.DATA.EKD_OFFICE.OU.O:DOCUMENT
(where OU is the organizational unit in which the server object resides, o is the orgnization. NW6 seesm to like using tree names in some of it's references now, so it might need to be ou.o.t)

Also, I've always mapped search drives like this:
MAP S1:=SERVER\VOL:DIR

Well, actually, I've always mapped them as SERVER/VOL:DIR1\Dir2... but that's very old school.

A thought:  What if the win98 or ME boxes are having difficulties with long file names in the Map command?  Not likely, but a thought.

BTW, do you have the login script display window open while the script is running and have the Novell client set to NOT automatically close it when done, this way you can see any errors if some are produced?


resources:
http://www.novell.com/documentation/nw65/utlrfenu/data/h7onc376.html
0
 
LVL 35

Accepted Solution

by:
ShineOn earned 1600 total points
ID: 11923294
Yes, you can map-root search drives.  I do it all the time with SYS:\Public.  It does help, in that it keeps the search drive rooted at the right spot in the volume.  Your casual user won't be browsing up to the root of the volume and breaking the search path.  I usually have it as MAP ROOT INS S1 to make sure it is at the head of the search path.

I don't understand how the normally-broken-in-reverse scenario got swapped so the NT-based boxes map fine but the non-NT based Windoze don't map root like you tell them to.

Is the login script a container login script, a profile login script or a user login script?  You don't say, but I noticed you have G mapped to a specific user directory, which is a bit odd for a login script used by more than one user.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 11923304
Just another thought - if your users have decided to map the drives locally using the Windows Explorer "map network drive" option, that may be overriding the login script.
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 11923327
Hey - I just had a light bulb go off!

WinNT based Windoze display mapped drives differently!  If you map root on a Windows 9x box, all you see in the tree side of the Explorer screen is the drive letter and the volume name - it doesn't show you what subdirectory the drive letter is mapped to!

It's probably not a problem at all, just a difference in the way Explorer shows the mapped drives in the left-hand pane.
0
 

Author Comment

by:bscott13
ID: 11928177
Thanks everyone...your comments got me thinking about things in a couple of different ways until I finally got the systems to work correctly.  So I split points amongst the 3 most relevant suggestions.

I finally got things bandaided so that the users are working correctly for now.  Convinced customer to upgrade 8 year old pc's and get rid of Win98 FIRST edition for XP Pro.

Thanks again for the input and suggestions... you all ROCK!!!
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 11934101
Just a quick question: Did you mean to have ShineOn as an Accepted and Assisted Answer? Its OK if you did, just wanted to make sure you didn't have a slip of the mouse. BTW, its OK to do that - have the same person with an Assisted and Accepted Answer - so don't think I'm saying you have to change it if that is what you intended.
0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A while back, I ran into a situation where I was trying to use the calculated columns feature in SharePoint 2013 to do some simple math using values in two lists. Between certain data types not being accessible, and also with trying to make a one to…
While opting for any web-to-print solution, you need to discuss with your team and some of your end users and know their opinions about your decisions. In this article we list down some questions you need to ask yourself.
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Suggested Courses

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question