Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

configuring cisco 1720 to work with broadband cable

Posted on 2004-08-27
3
Medium Priority
?
395 Views
Last Modified: 2013-12-14
Config is below... I can ping www.cisco.com, DHCP interally works fine, but can't get pc's to route out ethernet 0... I need some help


Building configuration...

Current configuration : 984 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname winebev-1720
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$SpK9$wUBMxRRsBzItXHg/Taxek1
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.253
ip dhcp excluded-address 192.168.1.250
ip dhcp excluded-address 192.168.1.249
 --More--         !
ip dhcp pool 1
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.253
   lease 3
!
ip cef
!
!
!
!
interface Ethernet0
 ip address dhcp
 ip nat outside
 half-duplex
!
interface FastEthernet0
 ip address 192.168.1.253 255.255.255.0
 ip nat inside
 speed auto
!
ip nat inside source list 1 interface Ethernet0 overload
ip nat inside source list internal interface Ethernet0 overload
 --More--         ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 192.168.0.0 255.255.0.0 Ethernet0
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password
 login
!
end

0
Comment
Question by:youngm40
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 36

Assisted Solution

by:grblades
grblades earned 750 total points
ID: 11920375
Hi youngm40,
> ip route 192.168.0.0 255.255.0.0 Ethernet0
This is incorrect. The subnet mask should be 255.255.255.0. You are also routing it out the internet interface.
Should this line be there at all?
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 750 total points
ID: 11929970
You are missing access-list 1 to define the traffic to be NAT'ed.

access-list 1 permit 192.168.1.0 0.0.0.255

As grblades suggests, the "ip route 192.168.0.0 255.255.0.0 Ethernet0" command is not necessary.  Should be removed.
0
 

Author Comment

by:youngm40
ID: 11930744
I figured it out late on friday 8/27, and got it to work... I had to add... the following below...


ip nat inside source list 1 interface Ethernet0 overload
ip nat inside source route-map cable interface Ethernet0 overload
===== not exactly sure which one of the above lines made it work, but I can figure that out easily=== I just wanted to let you guys know what I did...


access-list 1 permit 192.168.1.0 0.0.0.255
route-map cable permit 10
 match ip address 1
 match interface Ethernet0

as well as to the ip dhcp pool 1
I added DNS-Server XXX.XXX.XXX.XXX



I removed

ip route 192.168.0.0 255.255.0.0 Ethernet0

because I knew that the ip route statement before that would encompass all traffic that comes in on the internal interface...

Thanks for all the help


0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

    Over the past few years, small business and home owners have become so dependent on internet that a need for redundancy has arisen.    What happens when your small business or home / home office loses its internet connection?  The results c…
Sometimes you have to pull out old tricks to get a new firewall to work… While we were installing a new Sonicwall at a customers site we found that sites they were able to visit before were not working.  It seemed random and we could not understa…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question