Solved

I do not receive login: prompt when I dial into UnixWare 7.1 system

Posted on 2004-08-27
26
463 Views
Last Modified: 2013-12-05
Hi!

I have been accessing this system (UnixWare 7.1.1) succesfully all this time through dial-up usimg my US Robotics modem.

All of the sudden now, I do not get login prompt. In fcat there are two seperate similar systems with same modems. I was bale to get in both and do my work remotely. Both systems modems will answer  but the cursor will keep on flashing, without login prompt.

What may have wrong overnight? - Juts like a blown fuse.

I have rebooted the system and modem numerous times so far, no change in the behavior.

The interesting part is I can get in through TCP/IP connection using telnet, but inhibits  login prompt through dial-up.

I suspect somehow login through dial-up have been disabled on both systems - accidentally or deliberately - have no clue.
Please help! This is urgent.

westclox
0
Comment
Question by:westclox
  • 12
  • 10
26 Comments
 

Author Comment

by:westclox
ID: 11916452
I do want to mention that I have tried to dial-up from 4 different systems that I have and have also called my buddies remotely and they have tried also. Same situation.

No login prompt.  The cursoem will keep flashing at you.

This eliminates anything to do with my modem/s or system/s.

westclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 11916630
It sounds like the getty process listening out on the modem port has been disabled - I'll dig around for details, but the first thing I would check `ps -ft /dev/whateverport` to see if theres a getty running and if /etc/inittab has been changed recently
0
 
LVL 20

Accepted Solution

by:
tfewster earned 500 total points
ID: 11916949
Whups, it's not `getty` under Unixware - it's ttymon.  Check /etc/saf/ttymon1/_pmtab

There is a comprehensive setup guide at http://zenez.pcunix.com/tmp/ou8faqz/cache/241.html

Other links here:
http://www.experts-exchange.com/Operating_Systems/Unix/Q_20948597.html

0
 

Author Comment

by:westclox
ID: 11917462
tfewster!

I did check the links out. The latter one primarily focusess on the modem setup etc.... I seriously do not believe that it is anything to do with modems. I have been dialing into thers modems for almost a month on a daily basis. It always worked.

My instinct tells me that somehow the logins are disabled. I'm not sure how, though!

westclox
0
 

Author Comment

by:westclox
ID: 11917481
The _pmtab file shows:

VERSION=2

I am not even sure what the means, or what entries ahould be in there.

westclox
0
 

Author Comment

by:westclox
ID: 11917736
Sorry!

I do see a next line of string.

I'll try and figure that out. However, why would one want to change anything in there?

westclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 11917931
The config line should look something like:
term00m::u:reserved:reserved:login:/dev/term/00m:boPhr:0:auto:60:115200_8N:ldterm,ttcompat:login\: :::::#

The flags in field 8 are important - But if the timestamp on the file shows it hasn't been changed recently, that's probably not the problem; If it HAS been changed, consider making a copy and restoring an older version from backups.
0
 

Author Comment

by:westclox
ID: 11918037
Field 8 shows just :hr:

I took the r out and made it worse. So I insrted it back again.

weestclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 11918174
I presume you've checked thru steps 2 & 3 in http://zenez.pcunix.com/tmp/ou8faqz/cache/241.html

Modem setup:

scoadmin/Hardware-> Modem Manager-


Check the permissions on your port:  should be set to uucp:uucp
                chown uucp:uucp  /dev/term/00m

Connect to your modem via cu:
#cu -l term/00m                      You type this
Connected
~[hostname].                         You type this:  exit from cu
#


Port setup:
scoadmin/Hardware/Serial manager should show something like
               Port    Logins          Speed   Description
 {icon}  term/00m        enabled         115200  COM 1 modem
0
 

Author Comment

by:westclox
ID: 11918322
Modem Manager Shows:
        Type:       Standard
        Answers:  No
        Port:         term/01m
        Speed       57600
         Dailer:      Standard_Modem

Serial Manager:
          Port:     /term/00h      Logins: Enabled      Description: COM1   Hardware Flow Control
                      /term/01        Logins: disabled     Description: COM2    Hardware Flow Control

Within /dev/term directory ALL  entries are  "root"   "root"  with the exception of "0h"  which is "root"   "tty".

westclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 11918420
OK, the most obvious issue is
/term/01        Logins: disabled

I'm not sure what's happened here - the device files should match up, maybe someone has tried adding another device on that line and messed it up.

Modify/Delete/Re-add devive 01m  in scoadmin/Hardware/Serial manager; That will modify the _pmtab, so you may have to stop & restart the port monitor manually (if scoadmin doesn't do it) with `sacadm -k -p ttymon1 ; sacadm -s -p ttymon1`

I suspect /dev/term/01m should have owner:group as uucp:uucp, but that might get fixed when you make the Serial port setting change.


0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:westclox
ID: 11918939
Hi! tfewster,

I did exactly what you suggested. Deleted the modem and re-installed it as Standard Modem as it should be. Reconfigured the ports.

The Modem Manager shows:
      /term/01m

The Serail Manager shows:
     /term/00h                  Login: Enabled                COM1   Standard Flow Control
    /term/01m                  Login: Enabled                COM2   Modem

Executed the two "sacadm" commands as suggested.

Although, I have not rebooted the system.

Dialed into the system, and exactly the same situation.  Modem answers and the cursor keeps flashing with no login:

I belive there has to be an extension to another layer of componnet "/term/01m" which actually says excute login command.
For some reason it is not executed. I did not change the ownerships, though!

I'll try and see if it makes any difference.
westclox
0
 

Author Comment

by:westclox
ID: 11919113
Hi!

I also changed the ownership for /dev/term/01m to "uucp"    "uucp " - No chnage in the behavior.

Still no login: prompt.

As far as I know about System V kernel unix which is most of them out there; a "login" is binary called by the getty process. We need to determine how does that process get spawned?

westclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 11919713
SCO Unixware and a few other System V Unixen use the "Service Access" model instead of getty.

Please post the contents of /etc/saf/ttymon1/_pmtab   (and ttymon2/_pmtab, if it exists)

Did you try the `cu` test?
#cu -l term/01m                      You type this
Connected
~[hostname].                         You type this:  exit from cu
#
0
 

Author Comment

by:westclox
ID: 11924225
Hi! tfewster,

Yes I did try the cu command. I do get Connected message.

I am not clear about the tilda synatx when you mention ~[hostanme].  I hate to ask you, but can you spell that for me in terms what is it that is exactly I am typing. I am assumimng if my hostname is e.g.  "mountain" then are you suggesting that I type:

# ~mountain and press Enter.

If my hostanme is  apple.orange.bananas.com

# ~apple.orange.banana.com

Are the above correct assumptions? I thinkl I did type the way I have described above and did not like the syntax. However, after I reconfigured the modem, I also learned the "pmadm -l "commad to check if login is enable for the port configured. And it is. This is straight out of UnixWare 7.1 System handbook.

I will try and cut and paste the cu output and as well tilda output, which is basically just exit from cu. However, I do see connected message to the cu command for the port I am testing.

Still no login: prompt

This is so frustrating, that i can't believe it can be that complicated. It has taken a toll on me, to figure something that can be so easy to resolve. Both systems same behavior and no login surprises me. I'm absolutely sure something has been tampered as I have been accessing both system remotely all the time withouit any problem, especially week and half ago, all was working fine.

Furthermore, I do have one of my own UnixWare 7.1.1b system running on laptop. I configured the exact same US Robotics 56K modem external Standarad Modem on a serial port /term/00m. I can dial into my own system and I am able to get login without any problem. I don't have to press Enter key either.

Sorry, for the dissertation, due to sheer frustration.
westclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 11926026
Sorry for the confusion, it's just "~." to quit out of cu.

As to the rest, I'm as confused as you are.  What does the _pmtag file currently look like? Someone else may be able to read it and spot an issue.

Also, please post the output of `pmadm -l`

It may be worth reconfiguring the modem with the AT commands as described in http://zenez.pcunix.com/tmp/ou8faqz/cache/241.html though we seem to have communication working from both ends.

0
 

Author Comment

by:westclox
ID: 11928676
Hi! tfewster

I have verified using  the pmadm plus sacadm commands taht the modem is installed correctly and appropriate ports enabled as Standard Modem - Incoming Only 8 N.

I can alos excute cu -l term/01m commands on both modem sI egt Connected prompt all the time. term/00m will say NO DEVICE FOUND,.

However, after it says Connected, I was hoping that I can submnit AT commands to the modem. Instead it does not let me send any commands nor do I see it when I type. This is the same for both modems, again. It just stares at me with Connected display. I acm press ~[hostname]. to exit and works fine.

Howver no response to AT commands plus still no login prompt after the modem answers.

westclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 11930031
OK, we can try reconfiguring the modem - But we won't save the changes permanently until we're sure they are right:
cu -l term/01m
ATE1               # To switch keyboard echo on
ATF1               # Local echo ON
ATQ0               # Display result codes
ATI5                # Show saved settings - Make a note of these & ensure they match the port settings!
AT&F0             # Reset modem to factory settings - And test if it now works

If it works, we can make the settings permanent in the modem and also in the Unixware dialler - tho' that should only matter for  dial-out.

Background info & references:
http://www.experts-exchange.com/Operating_Systems/Unix/Q_10304549.html
http://www.usr-emea.com/loc-unkg/modem_files/techref_uk.pdf
http://zenez.pcunix.com/tmp/ou8faqz/cache/241.html   (again!)
0
 

Author Comment

by:westclox
ID: 11933528
Thanks! for the above details....

I will check it out immediately and let you know,

Just FYI - I am currently dialing using pcAnywhere into somebody's elses Windows system and accessing these unix boxes from that PC.  What a bummer way - without that, I will be completely out of luck.

westclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 12153613
Agreed,  jmcg - If you think there is info here worth saving?  Otherwise, I have no objection to it being deleted.
0
 

Author Comment

by:westclox
ID: 12219678
It has been a while since I am following up on this issue. I was engaged on other assignments and thus could not follow-up on  tfewster's earlier recommendations and checkpoints.

Well, today I got back into it, and have resolved the issue. First of all the modems should have been connected to COM2 instead of COM1 - as part of implementation. That was corrected and configured appropriately through Modem and Serial Manager.

Secondly, the dip switches were not set correctly on both modems and both systems. It seesm one may have been tampering with the switches, as I was able to dial in and login prior to this incidence.

US Robotics 56K modem required 3 5 and 8 dip switches in DOWN position. Once they were set, I was able to dial in and get my login prompt immediately.

tfewster:
Your AT command sets for confirming the port responses were extremly helpful. { cu -l term/01m }
I tried all the AT commands you suggested and received results as expected. This was definitely and education for me. Thanks a bunch and much........much appreciate all your help and patience.

westclox
0
 
LVL 20

Expert Comment

by:tfewster
ID: 12220579
Ack, I forgot about dip switches as most modems don't have them any more; However, looking at an old guide for the US Robotics Sportster says switch 5 DOWN = Disable auto-answer: If your model is the same, that implies that the port monitor is re-enabling auto-answer through AT commands...

Anyway, I'm pleased to hear you solved the problem and thanks for posting the solution.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
Introduction Regular patching is part of a system administrator's tasks. However, many patches require that the system be in single-user mode before they can be installed. A cluster patch in particular can take quite a while to apply if the machine…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now