HDD Problems

Recently I cloned a HDD all was working well until a few days ago, on boot the systems sometimes cannot find the HDD (which has 3 partions) once it finally does boot to windows XP the system hangs after only a few minutes.  I have run partion magic and recieved the following errors:

1. improperly dismounted
2. file record marked used
3. cross linked files
4. lost cluster
5. index sequence mismatch

I am at loss on how to recover my system particularly the messages 2 and 5.

What do I do?
Who is Participating?
ChireruConnect With a Mentor Commented:
Chkdsk should be able to take care of most of that..  

Go into My Computer, right click each partition, one at a time, and click properties.  Go to the tools tab, and click the "Check Disk" button.  Check atleast the "Fix Errors" box and click start.  

Some of the drives (any that have open files or are the boot/system partitions) will say it's not possible to fix it right now.  Click Yes to have it check on next boot.  After running it on all 3, reboot to check the drives it could not check.  

After the reboot checks everything, it will reboot again, and load up windows.  Check the event log to see if there were problems, and that they were fixed.
CallandorConnect With a Mentor Commented:
You problem with the drive not being detected can be a CMOS battery that needs replacing or a power supply that can't deliver enough current on startup.  What brand and rating of power supply are you using, and what is it powering in your system?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.