?
Solved

htm/html file association gone

Posted on 2004-08-28
25
Medium Priority
?
454 Views
Last Modified: 2013-12-28
After upgrading my browswer to Firefox 0.9, the htm/html file associations are gone. Even after re-creating it under >File Types, any double-clicking on an htm/html file does not open it in the browser. This issue applies to Eudora too, where clicking on a URL in a message defaults to IE, even though Firefox is both my default browser as well as listed in Eudora's ini  file as the "URL-Helper".

Thanks.
0
Comment
Question by:pax
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 11
  • +2
25 Comments
 
LVL 57

Expert Comment

by:Pete Long
ID: 11922142
Open the Control Panel and go to the Internet Options.
Click the Programs tab.
whats listed as the default browser?
0
 

Author Comment

by:pax
ID: 11922456
PeteLong,

There is no explicit entry for default browser - it is not an option provided. The checkbox if IE should check if it is the default browswer is unchecked.
0
 
LVL 3

Expert Comment

by:ITsheresomewhere
ID: 11923035
Even though you stated you "recreated" the association and linked it to Firefox here is one trick you might try.

Open Explorer and locate a html file on you disk.  Left click on the file to highlight it.
Then hold down the shift key while right clicking on the highlighted file to open the sub window.  Select "Open With".  The Open With Window will appear and a list of programs appears.  Highlight Firefox and make sure the "always use this program..."
box is checked.  This reassociates all htm/html documents and actions to the Firefox progam.

Hope this helped.

ITsy

0
WordPress Tutorial 1: Installation & Setup

WordPress is a very popular option for running your web site and can be used to get your content online quickly for the world to see. This guide will walk you through installing the WordPress server software and the initial setup process.

 

Author Comment

by:pax
ID: 11923073
ITsy,

My right click in Explorer does not have the Open with option - it used to a long time ago...
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11923525
Pax try holding down the shift key as you right click :)
0
 

Author Comment

by:pax
ID: 11923891
Itsy has already suggested that, and I know of that option, however, my right click menu does not include the "open with" option...
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11923979
Ok read this and first see if it applies to you, note that it mentions that the open with option can be removed because you obviously don't have the file association.   http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/q218/8/05.asp&NoWebContent=1

Also read this http://www.vlaurie.com/computers2/Articles/Association.htm note the point where it says about double clicking on an item and it will bring up the open with dialogue..   If you get that far select "firefox" or "IE" or whatever your using and tick the checkbox that says always open files of this type.

That should sort it, I guess you have installed something that has messed your settings up.

Still no luck, post back with your findings then we can look at the registry after that :)
0
 

Author Comment

by:pax
ID: 11924177
pjcrooks2000,

Thanks. I have tried the MS fix and created:

HKEY_CLASSES_ROOT\Unknown\shell\openas\command
The "default" value for this key should read:

C:\%windir%\rundll32.exe shell32.dll,OpenAs_RunDLL %1

I now have the open with option on the shift-right-click, but the dialog that pops up wants rundll.32.exe no matter what file it's on, and won't accept any other executable.

The double clicking didn't work.

I then got contextEdit, as mentioned in the vlaurie.com article, and that helped me find that I still had an html extension entry under "FirefoxHTM" file. Once I added "open" to the entry, all htm files now open in firefox. Great!! Almost done: From within Eudora, clicking a url still brings up IE, though the "URL-Helper" in the ini file is firefox. Would you be willing to help me with that before I give you the points?

Thanks.
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11925013
Ok then now I have never used Eudora, i prefer to use Mozilla thunderbird myslef so I can not be exactly sure if Eudora is your problem or firefox is your problem.

I would say read this about Thunderbird from Mozilla, its their email program I use it and think its great :) http://www.webuser.co.uk/products/Mozilla_Thunderbird_07_review_2069-500.html

If you want to try and fix the problem you could do:
Read it may help
1) http://support.microsoft.com/default.aspx?scid=kb;en-us;256953
2)Remove IE ?   I would :)
3) Try read this http://www.freewebspace.net/forums/showthread.php?t=57949
4) In firefox go to tools>Options>General tab and click on the default browser tab to make sure it is set to the default browser.
5) I have not used Eudora as siad already but have you checked the options on it for opening default browsers?  Perhaps it's set to launch IE in there somewhere.

Try those out anyway  :)
0
 

Author Comment

by:pax
ID: 11926153
pjcrooks2000,

Thanks. I will have a look at Thunderbird. The MS site did not help. I have once  before removed IE, and decided it caused more trouble than it was worth, and left me with all sorts of explorer malfunctions - so I reinstalled. The freewebspace article seemed to apply, but did not make any changes when executing the reg file. And yes, Firefox is the default browser. One sort of workaround I have just found is to rename IE, so that it can't be executed, and guess what, Eudora now opens links in Firefox. So this is pretty good, except that I will have to rename IE evertyimte I need it (which is  occasionally). Regarding Eudora and browsers, Eudora reads its settings from its ini file, and the relevant entry is: URLHelper=C:\Program Files\Mozilla Firefox\firefox.exe - and no, there is no entry for IE in there. I also ran RegMonitor and noticed that Eudora calls for this:

9.43486160      Eudora:FFF4E4E5      QueryValueEx      HKCR\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32      SUCCESS      ""C:\PROGRA~1\INTERN~1\iexplore.exe""      

I don't fully understand the LocalServer32 bit, but if I change that entry to Firefox, then it's true that IE no longer opens the link, but a link clicked within Eudora will then open my home page in firefox - weird.

Maybe I need to reinstall Eudora. Any more suggestions?

Thanks.
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11926516
Actually that was what I was going to say next, try re installing Eudora, but try out thunderbird, it is really very good :)  

Good luck with it...
0
 
LVL 3

Expert Comment

by:BenReynolds
ID: 11926847
Grasping at straws here. Is the Viewing Mail, Message Window, use Microsoft's Viewer checked?
0
 

Author Comment

by:pax
ID: 11926945
BenReynolds,

No, I don't use the MS viewer.
Anybody have a clue as to where the setting/entry is that makes Eudora invoke IE?
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11926976
Check this out sport,

Look at NetscapeURLDDE, try send the url to the system instead.... Althought this does mention Netscape... have a read anyway

http://www.eudora.com/techsupport/ini.html

Yours

pjcrooks2000
0
 

Author Comment

by:pax
ID: 11927012
pj,

No change either way. I have also just cross-posted this part of this thread under the Eudora section.
0
 

Author Comment

by:pax
ID: 11927034
From the Eudora site:

                  Go to Start: Run:

                        Type http://www.eudora.com

                              Click OK

This will force Windows to open the URL http://www.eudora.com in the default web browser.

Well, it does bring up IE. So maybe I need to reinstall Firefox....? Unless someone knows where to change that default browser setting in the registry or elsewhere...
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11927039
Awwww i thought that might have been it there for a second what  a shame I don't use the proggie, have you tried Thunderbird at all?

Do you get the feeling i am pushing thunderbird?......  lol
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11927044
have a go at this assuming you have not done so already

http://www.computing.net/security/wwwboard/forum/13228.html

0
 

Author Comment

by:pax
ID: 11927093
Pj,

Did that too. Don't have an entry for the URL:HyperText Transfer Protocol with Privacy setting, but the URL:HyperText Transfer Protocol already was FireFox, and the shortcut I changed to FireFox - No change...
0
 
LVL 8

Accepted Solution

by:
pjcrooks2000 earned 750 total points
ID: 11927136
Hmmm well i think I am all outta ideas now :(

Apart from the obvious one I keep pushing at you, get thunderbird :)

0
 

Author Comment

by:pax
ID: 11927647
PJ,

I already downloaded it, and will give it a whirl, and I probably will re-install both apps. And it's still curious to me how that works...
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11927678
I think it is very fast and very secure.. if thats what you meant by how it works.  I think you can also import all of your Eudora contacts and messages into it too.. Well you can with Doubtlook and Doubtlook post :)  I am sure i read something about being able to import Eudora.

OK coolio I hope I have been a great help to you, sometimes two heads are better than one hey!  On the other hand a two headed monster needs to be shot!  
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11927681
hehe I am chuckling to myself Doubtlook post .. Coff coff !
0
 

Author Comment

by:pax
ID: 11932046
Pj,

I meant I was curious as to why Eudora continues to invoke IE, but it appears that this will have to remail a mystery.

You is a funny person.

Here's the points
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11932095
Wink Wink Nudge Nudge PaxMan  :)  
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are many software programs on offer that will claim to magically speed up your computer. The best advice I can give you is to avoid them like the plague, because they will often cause far more problems than they solve. Try some of these "do it…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Suggested Courses

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question