Solved

SUSE 9.1 pro ... where is gnome?

Posted on 2004-08-28
7
413 Views
Last Modified: 2013-12-15
Hi, anyone know how can I get gnome as my default desktop in SUSE 9.1 pro?

thx
0
Comment
Question by:iqula
7 Comments
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 11922716
Im not sure of the official details but I have a workaround. Edit /etc/inittab and change the default run level to 3. This means that your system will boot into text mode. Edit or create a file in your home directory named .xinitrc and include the line exec gnome-session.  Edit .bashrc in your home directory and add the line startx to the end of it. Now when you boot you will presented with a textmode login. Login with your username & password and xwindows will start automatically with gnome as the desktop.
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 11922725
In redhat or fedora all you would have had to do was run switchdesk & select gnome :)
0
 

Author Comment

by:iqula
ID: 11924262
I tride that but cannot get it up, even running startx gnome wont work.
0
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

 
LVL 17

Expert Comment

by:owensleftfoot
ID: 11925157
What error messages do you get? Are you sure you installed gnome? Gnome does come with the suse distro but kde is the default desktop.
0
 
LVL 44

Accepted Solution

by:
Karl Heinz Kremer earned 500 total points
ID: 11925412
You need to install the Gnome packages with YaST2. Once you've done that, you can use YaST2 to also change your window manager - or you can do it manually by editing configuration files (which is how I would do it).

If you want to use YaST2, select the "System" section, and then select "/etc/sysconfig Editor".
You need to adjust two settings: The display manager and the window manager.
To change the display manager go to "Desktop" and then select "Display Manager" and then "DISPLAYMANAGER". This is set to "kdm", replace this setting with "gdm".
To change the window manager, go to "Desktop" and then select "Window Manager" and then "DEFAULT_WM" and change it from "kde" to "gnome".

As I said, you can also do this by editing the files /etc/sysconfig/displaymanager and /etc/sysconfig/windowmanager. Just look for DISPLAYMANAGER and DEFAULT_WM and change them accordingly.

0
 
LVL 16

Expert Comment

by:xDamox
ID: 11926181
if you open yast then goto add and remove applications this will allow you to install gnome if you
already have gnome install before you login change you session to gnome
0
 
LVL 44

Expert Comment

by:Karl Heinz Kremer
ID: 11926578
xDamox, isn't this exactly what I said (just with a few more words)?
0

Featured Post

Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question