Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Enable remote access to a computer with XP SP2 firewall enabled

Posted on 2004-08-30
5
Medium Priority
?
240 Views
Last Modified: 2013-12-04
My applications uses remote access to computers for configuration purposes. For example, registry, stop/start services, accessing shares etc.

On computers with XP SP2 firewall enabled it seems that there seems to be no connection at all, eventhough Ping works.

The configuring computer runs with a user with administrative priviledges on the remote computer.

When I disable the firewall everything works fine.

Any idea's what needs to be done to enable the remote access, even for a specific IP or user ?

thanks,
Dani

0
Comment
Question by:logindani
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 16

Expert Comment

by:JamesDS
ID: 11931312
logindani
The reason you can't get at the machines is because the XP2 firewall has switched off access to Remote Desktop and Remote Assistance

Start, Settings, Control Panel, Windows Firewall, Exceptions Tab, enable the Remote Desktop and/or Remote Assistance checkboxes and hit ok

Cheers

JamesDS
0
 

Author Comment

by:logindani
ID: 11932412
Sorry, tried it doesn't work.

Just to clarify, I'm not trying to connect as a remote desktop but attempting to access the computers filesystem/registry etc. from a remote location on the network. For example open RegEdit and select Connect Network Registry. With administrative rights on the remote computer I would expect to get access.
0
 
LVL 11

Expert Comment

by:Paul S
ID: 11934458
try opening these ports through SP2's firewall program

1067
139
4923
139

then try the remote registry again.
0
 
LVL 11

Expert Comment

by:Paul S
ID: 11934466
have you setup any exclusions for the network? you could just allow all ports open to certain ip addresses.
0
 
LVL 16

Accepted Solution

by:
JamesDS earned 1020 total points
ID: 11939192
logindani
Start, Settings, Control Panel, Windows Firewall, Exceptions Tab, enable the file and printer sharing checkboxes

Cheers

JamesDS
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many of us in IT utilize a combination of roaming profiles and folder redirection to ensure user information carries over from one workstation to another; in my environment, it was to enable virtualization without needing a separate desktop for each…
Recently, I read that Microsoft has analysed statistics for their security intelligence report. It revealed: still, the clear majority of windows users do their daily work as administrator. An administrative account is a burden, security-wise. My ar…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question