Solved

Wrong IP address returned by DNS.

Posted on 2004-08-30
3
243 Views
Last Modified: 2012-08-13
Here is what I have.

Windows 2000 DC (DC2) running IIS that hosts three websites.
Three IP addresses (A,B, and C) are assigned to the server's NIC.  3 DNS A records: one for each IP address.  IP A is the original IP with B & C added for use as a dedicated IP for two websites.  These websites are publically accessible through NAT at the firewall.
There is another DC (DC1) on the domain that provides DNS resolution for the network.  All clients are configured to use DC1 as their only DNS server.

Website B & C are password protected wtih NTFS.

When I ping the server name I get IP C back when I want to get IP A.  Anytime I try to access website A, I get the password prompt for website C.  I have checked DNS and see all the A records for the three IP addresses.  I even went as far as to uncheck the box

I created a host header name for website A so it would correctly access the website with sysadmin.blah.com. That piece works fine.

I have been going in circles on this.

Any suggestions on how to control which IP address is returned by DNS?  I had deleted out the A records for IP B & C, bu they came back.







0
Comment
Question by:averyb
  • 2
3 Comments
 
LVL 83

Accepted Solution

by:
oBdA earned 500 total points
ID: 11936507
The addresses defined are getting dynamically registered in DNS, with the regular host name of the machine. Uncheck the "Register this connection's addresses in DNS" in the TCP/IP settings of the NIC, and you should be able to use your manually created hosts records.
In addition, you might find these interesting:

Multiple IP Addresses Registered to Multiple Domains Under Dynamic DNS
http://support.microsoft.com/?kbid=254031

How to enable or disable dynamic DNS registrations in Windows 2000 and in Windows Server 2003
http://support.microsoft.com/?kbid=246804
0
 
LVL 4

Author Comment

by:averyb
ID: 11937003
Thanks for the input.

I tried that.  I didn't finish the sentence (I even went as far as to uncheck the box . . . " in my first post.  After I unchecked it I deleted out all of the A records other than the primary one.

I'll look over the links you provided and post back.
0
 
LVL 4

Author Comment

by:averyb
ID: 11951860
Huh.  I must have fat-fingered something the first time around.

I unchecked the box and deleted the A records and everything is still fine.  Must have missed one of the A records the first time around.

Everything working as expected.

Thanks
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Fine Tune your automatic Updates for Ubuntu / Debian
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
A company’s greatest vulnerability is their email. CEO fraud, ransomware and spear phishing attacks are the no1 threat to a company’s security. Cybercrime is responsible for the largest loss of money to companies today with losses projected to r…

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now