Solved

Locked myself out of Ownership & Permissions..unable to read & write to a disk.

Posted on 2004-08-30
25
407 Views
Last Modified: 2013-11-17
I use OSX 10.3. I am the administrator and have inedvertently locked myself out of being able to write to a disk. This was some how done while I was trying to erase a cdrw. Now I can't download pdf files...can't make a "download" folder to desktop. I can't seem to find where to regain my access again. Please advise. All the info windows say..you can only read. It is also the same when I log in under another user. I have read this apple page. I am unfamiliar with the terminal..:((

http://docs.info.apple.com/article.html?artnum=106712
0
Comment
Question by:coolmom
  • 10
  • 5
  • 4
  • +2
25 Comments
 
LVL 1

Expert Comment

by:x40ozbaby
Comment Utility
If you do not feel comfortable with the terminal then you can try this handy little app that does all the "terminal stuff for you"
it is called Batchmod.
check it out at http://www.versiontracker.com/dyn/moreinfo/macosx/12057
best of luck.
0
 
LVL 2

Expert Comment

by:Scorp888
Comment Utility
Have you tried repairing the permissions of the disk with the Disk Utility in Utilites ?

Command U from finder.

Try that first.

or is that is what you are using and getting the errors?
0
 
LVL 7

Expert Comment

by:njxbean
Comment Utility
Yea, if i were you i would repair permissions a couple of times.  that should fix the problem.
0
 

Author Comment

by:coolmom
Comment Utility
Why am I unable to erase my cdrw. The write status says.."read only". Is there a way to unlock the permissions to this volume? I have ran disk utility several times ..seems to be ok. When I use "erase" on it..I get msg "Optical Erase failed...with the error:Whole disk required, slice passed" Please advise. Thanks
0
 
LVL 1

Expert Comment

by:x40ozbaby
Comment Utility
previously it sounded like it was a HardDrive issue not a CDRW issue. It sounds like you may have finished the disk instead of writting a session. (try a different disk) that will rule out it being a specific disk. Your current one may be "bad" thus not allowing you to write or erase it.
0
 

Author Comment

by:coolmom
Comment Utility
I tried another disk...same problem..says read only. This was only partially filled.

When I try other volumes..like my hard drive..in get info..the read/write is grayed out in ownerships/permission..I can't change it.
0
 
LVL 1

Expert Comment

by:x40ozbaby
Comment Utility
ok,
first off, do you remember your password, the one used to install software updates from apple and to install some applications?
if so..
try this, get info on your hard drive:
- click on the "triangle" next to the "Ownership & Permissions:" catagory, it will then tell you what access rights you have. however do the following as well
- click on the "triangle" next to the "Details:"
         - it should say Owner: system and read/write for the access
                               Group: admin         read/write for the access
                               Others:                  read only
if it does not say that click the lock icon next to "system and read/write for the access" then select the correct group and then type in your password. and assign the correct access rights.

However, if you have read/write there is no need to change it. (it is grayed out so that you know that it is secure, thus noone can change the rights without knowing your password.

Are you sure you are using blank CDRWs and not written to CDRWs, CDROMs, or CDWs? (cant hurt to double check)
0
 

Author Comment

by:coolmom
Comment Utility
Under "Ownership"..read & write is grayed out.
Under Details..sytem..read& write is grayed out.
Under admin...access..read & write is grayed out
as is others..read only...gray...sigh
The lock is unlocked...I know my password. I even tried my alternate user...same thing..waaaaaah...I think I messed it up when I was trying to erase that disk..which is a cdrw...clicked on something wrong..
0
 
LVL 7

Expert Comment

by:njxbean
Comment Utility
Archive and reinstall.  or run disk warrior.
0
 
LVL 23

Expert Comment

by:brettmjohnson
Comment Utility
I know you are not familiar with using the command line in Terminal.app, but
this may be a case where you might need to.  Please launch the Terminal application
(found under /Applications/Utilities) and run the following commands, then post
the output here:

whoami
id
ls -la ~


0
 

Author Comment

by:coolmom
Comment Utility
eeeek...very scary..this is what I got..hope you don't hack me from all this stuff..:((

Last login: Mon Aug 30 08:37:55 on console
Welcome to Darwin!
[Shirley-Demuths-Computer:~] shirleyd%
[Shirley-Demuths-Computer:~] shirleyd% whoami
shirleydemuth
id
ls -la ~
[Shirley-Demuths-Computer:~] shirleyd% id
uid=501(shirleydemuth) gid=20(staff) groups=20(staff), 80(admin)
[Shirley-Demuths-Computer:~] shirleyd% ls -la ~
total 48
drwxr-xr-x  23 shirleyd  staff    782 14 Jul 22:50 .
drwxrwxr-t   6 root      admin    204  5 Feb  2004 ..
-rw-r--r--   1 shirleyd  staff      3 30 May  2003 .CFUserTextEncoding
-rwxr-xr-x   1 shirleyd  staff  15364 30 Aug 14:49 .DS_Store
-rw-r--r--   1 shirleyd  staff      0  2 Jan  1970 .MCXLC
drwx------  13 shirleyd  staff    442 30 Aug 19:45 .Trash
drwxr-xr-x   2 shirleyd  staff     68 19 Aug 05:55 .java
drwxr-xr-x   4 shirleyd  staff    136 28 Aug  2003 .jpi_cache
drwxr-xr-x   3 shirleyd  staff    102 28 May 19:10 .temp
drwx------   6 shirleyd  staff    204 30 Aug 14:47 Desktop
drwxr-xr-x   3 shirleyd  staff    102 28 Jul 19:37 Dick's Folder
drwxr-xr-x   9 shirleyd  staff    306 30 Aug 14:47 Documents
drwxr-xr-x  11 shirleyd  staff    374 15 Jan  2004 Games
drwxr-xr-x  19 shirleyd  staff    646 30 Aug 20:37 Incomplete
drwxr-xr-x   7 shirleyd  staff    238 31 Oct  2003 Installers
drwx------  42 shirleyd  staff   1428 30 Aug 08:33 Library
drwx------  20 shirleyd  staff    680 28 Aug 21:48 Movies
drwx------   5 shirleyd  staff    170  5 Jan  2004 Music
drwx------  32 shirleyd  staff   1088 25 Jun 20:53 Pictures
drwxr-xr-x   4 shirleyd  staff    136 23 Oct  2003 Public
lrwxr-xr-x   1 shirleyd  staff     63 30 May  2003 Send Registration -> /Users/shirleydemuth/Library/Assistants/Send Registration.setup
drwxr-xr-x  10 shirleyd  staff    340 30 Aug 20:31 Shared
drwxr-xr-x   6 shirleyd  staff    204  6 Nov  2003 Sites
[Shirley-Demuths-Computer:~] shirleyd%
0
 
LVL 1

Accepted Solution

by:
x40ozbaby earned 250 total points
Comment Utility
mvanvli1:~ mvanvli1$ ls -la
total 56
drwxr-xr-x  20 mvanvli1  mvanvli1   680  3 Aug 23:23 .
drwxrwxr-t   5 root      admin      170 26 Oct  2003 ..
-rw-r--r--   1 mvanvli1  mvanvli1     3 26 Oct  2003 .CFUserTextEncoding
-rw-r--r--   1 mvanvli1  mvanvli1  6148 29 Aug 22:34 .DS_Store
drwx------   3 mvanvli1  mvanvli1   102 30 Aug 00:01 .Trash
-rw-------   1 mvanvli1  mvanvli1     0  1 Mar 23:57 .Xauthority
-rw-------   1 mvanvli1  mvanvli1   497 27 Aug 18:35 .bash_history
drwxr-xr-x   3 mvanvli1  mvanvli1   102  5 Feb  2004 .java
-rw-r--r--   1 mvanvli1  mvanvli1    34 16 Jun 18:47 .lpoptions
-rw-r--r--   1 mvanvli1  mvanvli1   181  2 Mar 18:50 .profile
drwx------   2 mvanvli1  mvanvli1    68 26 Mar 23:32 .ssh
-rw-------   1 mvanvli1  mvanvli1   501  3 Aug 23:23 .viminfo
drwxrwxrwx  19 mvanvli1  mvanvli1   646 29 Aug 22:43 Desktop
drwx------  19 mvanvli1  mvanvli1   646 11 Jul 18:59 Documents
drwx------  34 mvanvli1  mvanvli1  1156 28 Jun 21:41 Library
drwx------   6 mvanvli1  mvanvli1   204  6 Jun 20:51 Movies
drwx------   4 mvanvli1  mvanvli1   136 27 Oct  2003 Music
drwx------  19 mvanvli1  mvanvli1   646 21 Jul 17:30 Pictures
drwxr-xr-x   4 mvanvli1  mvanvli1   136 26 Oct  2003 Public
drwxr-xr-x   5 mvanvli1  mvanvli1   170 26 Oct  2003 Sites

It should look like the above, the staff group seems to have taken over a lot of the rights. Plus your desktop folder needs to have its access changed.

d = If the letter 'd' appears it means that it is not a regular file but a directory
r = read
w = write
x = execute (run/launch application)
 example for desktop -> drwxrwxrwx has three major groupings
the first grouping is for the owner _ _ _ should be r w x
the second grouping is for "group" _ _ _  should be r w x
the last grouping is for "Others" _ _ _  should be r w x

-rw-------     means that the owner can read and write to the file but not
                                 execute it, and nobody else can do anything.
-rwx------     means that the owner can read, write, and execute the
                                file, but nobody else can do anything.
-rw-r--r--     means that the owner can read and write to the file, the
                               group can read the file, and everyone on Alcor
                                can also read the file.
-rwxr-xr-x     means that the owner can read, write, and execute, and the
                             group and everyone else on Alcor can read and execute
                              but not write the file.
-rwxrwxrwx  means that everyone on Alcor (including of course the
                              file's owner and group) can read it, execute
                               it, and write to it.  You want to avoid this since anyone
                                could destroy that file by overwriting it with garbage,
                               or an empty file.

And no, there is NO reason to archive and reinstall! It is just a permission issue, which can be fixed without drastic measures such as reinstalling.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 1

Expert Comment

by:x40ozbaby
Comment Utility
whoops forgot to put this in....
mvanvli1:~ mvanvli1$ id
uid=501(mvanvli1) gid=501(mvanvli1) groups=501(mvanvli1), 79(appserverusr), 80(admin), 81(appserveradm)
 

should look similar to that

the main problem is that you are in the "group" of "Staff" (switch that to your shortname the "shirleyd" and give that full rights (read/write)) and that should fix up a lot of your issues
0
 
LVL 23

Assisted Solution

by:brettmjohnson
brettmjohnson earned 125 total points
Comment Utility
coolmom:
Your id and permissions do seem quite in-line.  This might be restricted to a Finder problem.
Try deleting ~/Library/Preferences/com.apple.finder.plist

If that doesn't work, run the following command in Terminal (very carefully - it deletes files and
will rearrange icons on your desktop and icon view in the Finder but should do no damage.):

find ~ -name ".DS_Store" -delete

BTW:  I made an assumption that you know that ~ means your home directory (Unix notation).
So ~/Library is the Library folder in your home directory.

x40ozbaby:
Actually, staff group is OK.  
And the ~/Desktop permissions should NOT provide full access to group and others. (chmod 700 ~/Desktop)

0
 
LVL 7

Assisted Solution

by:njxbean
njxbean earned 25 total points
Comment Utility
x40ozbaby, i know that he doesnt NEED to do a archive and install.  However, with his experience, it will probably be easier and quicker to do that.  Again, i would suggest reinstalling.
0
 

Author Comment

by:coolmom
Comment Utility
Interesting thread..to say the least..ty all for this help. If nothing else..I am learning some definitions.

I'm a little confused as to what my next step should be. You say..too much is taken over by staff? Is it worth to change it. Delete the plst? How to change to my shortname?

When I look at info for my home..says I have read/write.

I deleted Library/Preferences/com.apple.finder.plist
because it was easy to do...now I reboot...(crosses fingers)
0
 

Author Comment

by:coolmom
Comment Utility
Things seem the same..my hard drive is same. Access settings still grayed out.
0
 
LVL 23

Expert Comment

by:brettmjohnson
Comment Utility
You can verify that your primary group should be staff - it may have been set that way by
your system administrator.  Launch "/Applications/Utilities/Netinfo Manager.app".  If a
root domain window doesn't automatically open, select "Domain"->"Open"->"/" from the menu.
Navigate to / -> users -> mvanvli1  in the browser view at the top half of the window.
Scroll down through the Propery/Values view in the bottom half of the window until you
locate the "gid" property and note its value.  In your case, its value should be 20 (staff), but in
stand-alone installations it is usually the same value as the "uid" property.

If your primary goup id (gid) is not staff (20), you can indeed try to reset the group ownership
for all the files and folders in your home directory with the following command (in Terminal):

chgrp -R mvanvli1 ~

This will recursively (-R) change the group ownership (chgrp) of all files and folders under
you home directory (~) to the named group (mvanvli1).


0
 

Author Comment

by:coolmom
Comment Utility
ok...I noted the gid...it is 20. So I don't need to change it? What does Netinfo do?
0
 
LVL 23

Expert Comment

by:brettmjohnson
Comment Utility
> What does Netinfo do?

Netinfo is the network information database that Apple inherited from NeXT.
It is roughly equivalent to Windows Active Directory or Sun's NIS, but has had
scalability issues [far] in the past and is quietly being replaced by Open Directory.

0
 
LVL 2

Assisted Solution

by:Scorp888
Scorp888 earned 100 total points
Comment Utility
Can I confirm that you've run the disk utility and it didn't work? Or that it's not been run yet, this should definately be looked at, as it may fix a lot of the problems you're finding.
0
 

Author Comment

by:coolmom
Comment Utility
I have run Disk Utility several times. I did again and repaired the following..is there anything in this that would stop me from my first objective..to erase my cdrw. It still says I can only read..in the Get Info pane.

Repairing permissions for “WAD”
Determining correct file permissions.
We are using special permissions for the file or directory ./System/Library/Filesystems/cd9660.fs/cd9660.util.  New permissions are 33261
Permissions differ on ./private/var/log/install.log, should be -rw-r--r-- , they are -rw-r-----
Owner and group corrected on ./private/var/log/install.log
Permissions corrected on ./private/var/log/install.log
Permissions differ on ./private/var/log/wtmp, should be -rw-r--r-- , they are -rw-r-----
Owner and group corrected on ./private/var/log/wtmp
Permissions corrected on ./private/var/log/wtmp
The privileges have been verified or repaired on the selected volume

Permissions repair complete
0
 
LVL 2

Expert Comment

by:Scorp888
Comment Utility
How exactly are you trying to erase the cd-rw?

From the disk utility tool?
0
 

Author Comment

by:coolmom
Comment Utility
I use Disk Utility...erase tab...I get the error msg "Optical Erase failed...with the error:Whole disk required, slice passed"

I am wondering if the media is not good also. I have tried 2 brands (Memorex and Verbatim) Both in "get info" say I have read only rights. I then went "old school"...to my G4 tower, running 9.2 and erased the Memorex but not the Verbatim. It came up with an error msg on the tower. At least I have an option. But I also have DVD-RW that I might want to erase. Only can do that on OSX. So the permission issue is bothering me.

Things are pointing to a reinstall or just live with it. I'm able to do everything else..so far. I will close this question having kept you all too long. I don't think I can fix completely as the Terminal is intimidating. As much as I love Mac, this side of it is difficult. I leave it to those with more brain cells than I..:)) Really appreciate all the feedback . I certainly know more than when I started. I even opened the Terminal for the first time..woohoo!
0
 

Author Comment

by:coolmom
Comment Utility
Ok..I split up the points. Hope I did it right. Please check.
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Apple's Mac OS X has become an official member of the malware club. The Flashback Trojan has affected over half million Macs, worldwide. It is behavior that ultimately gets malware onto a person’s computer. Obsolete or out-of-date software helps…
Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now