Solved

read only files

Posted on 2004-08-30
5
186 Views
Last Modified: 2013-12-04
I went from NT4.0 to windows server 2003 enterprise edition. Everything went well except the files transferred from NT to 2003 have read only attributes. I changed the attributes in 2003 but when I check the properties of the file again it reverts back to read only. Any ideas? Thanks.
0
Comment
Question by:sergenet
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 65

Expert Comment

by:SheharyaarSaahil
ID: 11933810
Hello sergenet =)

You Cannot View or Change the Read-Only or System Attribute of Folders
http://support.microsoft.com/?id=326549
0
 
LVL 11

Assisted Solution

by:Paul S
Paul S earned 250 total points
ID: 11934024
how are you changing the properties?

when i want to change a lot of files and folders to read-only i will right click on the root folder of all the files i want to change and select search. in the search for box type "*.*" then click search. after all the files show up click on the first one, then hold down shift and push end. this will select all the files. then right click on a file goto properties uncheck read-only and click apply then ok. see if that works. (try this two ways: 1) with folders included 2)without folders included.)
0
 
LVL 23

Accepted Solution

by:
rhandels earned 250 total points
ID: 11934079
Hi,

To me it looks like a permissions problem. Maybe you don't have proper permissions on the files. You could try taking ownership of the files and then change the read only attribute (make sure to have full control)

Another option (if all else fails) is going to the old Dos box and using the attrib option. Go to the folder using the dos propmt and type in

attrib -r /s

Attrib is the program that's used to change file attributes. -r makes sure that the read only attribute is deleted and /s makes sure that all subfolders are changed...
0
 

Author Comment

by:sergenet
ID: 11944074
None of the above.  The security settings from NT was being inherited. Unchecking that was the solution. Thanks for trying.
0
 

Author Comment

by:sergenet
ID: 12212412
Please close this question as it has been solved. It was a security issue that none of the answers solved.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, a new law in my state forced us to get a top-to-bottom analysis of all of our contract client's networks. While we have documentation, it was spotty at best for some - and in any event it needed to be checked against reality. That was m…
In a recent article here at Experts Exchange (http://www.experts-exchange.com/articles/18880/PaperPort-14-in-Windows-10-A-First-Look.html), I discussed my nine-month sandbox testing of the Windows 10 Technical Preview, specifically with respect to r…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question