Access to Root in REd Hat

Linuz-newbie..........
I can not create a directory in /usr/local in RED HAT.

I am trying to install nagios  on Red Hat. The documentation directs to create a dir in /usr/local... but when i go to the FILE SYSTEM, it doesn't show an option to Create Folder ( its greyed out )

Any solutions to that

I have the adminitrative rights to the root too.. actually i created an "administrator account only"
if you know how to add user to a directory, please instruct that also ..
jibranilyasAsked:
Who is Participating?
 
icemanwolConnect With a Mentor Commented:
What you need to do is have ROOT access to your system, the easiest way to do this is open a Terminal window and then type SU and press enter, now enter your root password.  You are now running as ROOT in linux, Any programs you lauch in this terminal will also run with ROOT access and you can do anything to your system so be careful!  To create a directory in there you would type cd /usr/local (then press enter) and then type MKDIR directories_name.  If the terminal windows is too complex for you (it can be overwhelimg with new users) you can run a grafical window with root privalages by typeing nautilus or konqueror and pressing enter.  I would sugget useing the latter as little as possible because if you make a mistake there is no turning back.  Hope this answers your qustion
0
 
lrmooreConnect With a Mentor Commented:
iceman is correct.
Right-click on the desktop, select New Terminal

[lrmoore@shrike lrmoore]$ su
password:
[lrmoore@shrike lrmoore]#cd /usr/local
[lrmoore@shrike local]#mkdir nagios
[lrmoore@shrike local]#cd nagios
[lrmoore@shrike nagios]#pwd
/usr/local/nagios
[lrmoore@shrike nagios]#
0
 
jibranilyasAuthor Commented:
i got that far. but i am still unable to drag files to the/usr/local/nagios folder ...
actually, i can't create one anywhere in usr from the "explorer mode" TERMINAL let me create the nagios  dir.

how can i make this machine less  restrictive ?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
jibranilyasAuthor Commented:
also, when i go to the properties of that nagios folder, it says "you are not the owner, so you don't have permissions .."
0
 
jibranilyasAuthor Commented:
this is where i get stuck in nagios installation


[nagios@localhost nagios-1.2]$
[nagios@localhost nagios-1.2]$ make install
cd ./base && make install
make[1]: Entering directory `/usr/local/nagios-1.2/base'
/usr/bin/install -c -m 775 -o someuser -g nagios -d /usr/local/nagios/bin
/usr/bin/install: invalid user `someuser'
make[1]: *** [install] Error 1
make[1]: Leaving directory `/usr/local/nagios-1.2/base'
make: *** [install] Error 2
[nagios@localhost nagios-1.2]$
0
 
jibranilyasAuthor Commented:
got the fix for the pervious error

everything is working now except that I didn't get an "etc" directory under nagios folder.. The documentation mentioned that you will have 5 directories   bin, etc,sbin,share,var    i didn''t have etc.  The etc dir  should have "Main, resource, object, and CGI configuration files ... on my terminal , i did see  

*** Main program, CGIs and HTML files installed ***
 
You can continue with installing Nagios as follows (type 'make'
without any arguments for a list of all possible options):

please inform me if this is normal..
0
 
lrmooreCommented:
I didn't even get those with a RPM install of nagios.
Look in /etc/nagios/  for the config files.
0
 
jibranilyasAuthor Commented:
i ran

make install-config

that threw some config files in the etc dir...
btw, i manually created the etc dir..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.