Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

CGI.AUTH_USER

Posted on 2004-08-30
5
Medium Priority
?
1,637 Views
Last Modified: 2013-12-24
Hi All

Variable  #cgi.auth_user# did not give the values when I run the application on XP. In NT, it give correct login name and application works perfect !!

1. I am having application.cfm file in my folder, in that I assigned the variable  as follow :
<CFSET #UserId# = cgi.auth_user>.

2. In my application, I have email function that deliver the status email to concerned people on daily basis.  This application first get the name of the user  from the above variable and search the email-id which already stored in database based on the variable.  It is working perfect in NT. But in XP I could not see the value of the variable and finally, the email function did not work.

We use IE 6.0.2800

If you provide the appropriate comments  will be highly appreciated.

Thanks in advance.
0
Comment
Question by:cmurugavel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
5 Comments
 
LVL 21

Accepted Solution

by:
pinaldave earned 100 total points
ID: 11939003
How about this? I devide your answer in three parts.:))
Problem:
CGI variables like auth_user & remote_user are only available when users are authenticated.

Explaination.
On Win NT it will work as it authorises the user.
On XP it does not (as per your setting so it does not work).

Solution: Go to IIS Internet Manager and changed the authentication method for my Virtual directories to only allow "integrated windows authentication" . This will fix your problem.
Regards,
---Pinal
0
 
LVL 21

Expert Comment

by:pinaldave
ID: 11939007
Make sure that you turn off Anonymous Users in the directory security
section of the site and allow Basic Authentication, now when you try and
browse the site for the first time you will be presented with a login
dialog.
Regards,
---Pinal
0
 

Assisted Solution

by:jonbigelow
jonbigelow earned 100 total points
ID: 11946609
What Pinal said was right, but there's another possible step:

In IE go to Tools > Internet Options > Security
Click on the custom level button for the zone that your site is in (I assume this is an intranet)
Scroll down to User Authentication and check "Automatic login only in Intranet zone"

That way your browser will pass the username and password automatically when challenged by the server.
0

Featured Post

10 Questions to Ask when Buying Backup Software

Choosing the right backup solution for your organization can be a daunting task. To make the selection process easier, ask solution providers these 10 key questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever sent email via ColdFusion and thought of tracking this mail to capture the exact date and time when the message was opened ?  If yes, then this article is for you ! First we need a table user_email with columns user_id , email , sub…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question