[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

2003 Server Remote Desktop Access Problem

Posted on 2004-08-31
13
Medium Priority
?
1,141 Views
Last Modified: 2013-12-04
I'm trying to allow a user to use remote desktop to access the server, but they keep getting the message "The local policy of this system does not permit you to logon interactively". This user is not trying to logon as administrator.

I've found articles that mention going to the Remote tab on Control Panel/System, and clicking on "Select Remote Users", but this button is disabled.

All help greatly appreciated.
Akash
0
Comment
Question by:akashchopra
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
  • +1
13 Comments
 
LVL 8

Assisted Solution

by:KerryG
KerryG earned 375 total points
ID: 11944597
"Usually" a user has to be in the administrator group to be able to terminal server into the server.

You can try this and see if it works for you:

Open Terminal Services Config Tool ( Start -> Programs -> Administrative Tools) Click on connections, right click on RDP-Tcp and select properties, Permissions Tab, add the group of users you allowed to logon locally and set their permissions (guest or user).
0
 
LVL 1

Accepted Solution

by:
jimmybartlett earned 375 total points
ID: 11945824
You're going to have to make the server a "terminal server" which allows multiple connections at once. Control panel -> add/remove programs -> add/remove windows components -> check the "terminal services" box and next your way through the install. You may need licensing for this, but try it without first.
0
 
LVL 25

Expert Comment

by:mikeleebrla
ID: 11946331
there are two modes of terminal server,,, application mode and administrative mode,,, which mode is your server in??
0
Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

 
LVL 8

Expert Comment

by:KerryG
ID: 11946858
If you read his original post, terminal server is obviously already running and more than likely in administrative mode based on the error he is getting. In this mode, only administrators are allowed to login unless you set the permissions for that user or group to log on locally.
0
 
LVL 1

Expert Comment

by:jimmybartlett
ID: 11948971
Actually, you can remote desktop to any xp pro or better machine even if terminal services is not enabled.  Remote desktop is a separate function from terminal services.
0
 
LVL 8

Expert Comment

by:KerryG
ID: 11949121
jimmybartlett,
 That is not entirely true, you still have to go to the system control panel (my computer/properties), go to the remote tab and enable it. Uses have to have passwords in order for it to work as well.
0
 
LVL 1

Expert Comment

by:jimmybartlett
ID: 11949146
That's not called Terminal Services. That's called Remote Desktop. Two different services, controlled in two different places, but using the same protocol to connect.
0
 
LVL 8

Expert Comment

by:KerryG
ID: 11949166
I am quite aware of that but you still need to enable it properly unlike your statement which implies it is automatic.
0
 
LVL 1

Expert Comment

by:jimmybartlett
ID: 11949441
"Actually, you can remote desktop to any xp pro or better machine even if terminal services is not enabled.  Remote desktop is a separate function from terminal services."
My exact statement. No implication of automatic ability. Just stating that Terminal Services doesn't need to be turned on. But we digress. Akash, have you tried anything yet?
~Jimmy
0
 
LVL 1

Author Comment

by:akashchopra
ID: 11950190
Ok, I've tried installing Terminal Services, but it seems like I'll need to spend some time reading up on it before I can get it configured. I've given the users terminal services permissions using the Terminal Services Config Tool, but they can't run the application because they have been denied access to the C: drive. It all seems like a complicated way of achieving something simple! Plus I'll need to get it licenced after the 120 day grace period.

All I really want is to allow certain users access to a particular application installed on the server. Remote Desktop seemed to be a reasonable way to achieve this, but I can't seem to find out how to give the users the necessary permissions. Currently only Administrators can Remote Desktop onto the server, but obviously I'd rather not give these users Administrator rights.

0
 
LVL 1

Expert Comment

by:jimmybartlett
ID: 11952767
You should have them connect to your server with TSWeb. It's an activex control that works through IE. All they have to do is visit the web page of the server and login. the activex control takes it from there. They don't need access to the mstsc.exe application on the C: drive. add/remove windows components -> select Internet Information Services and click details -> select World Wide Web Service and click details -> Check the Remote Desktop Web Connection. (you will have to set up IIS to get this working properly) I have the client set to connect when someone types in http://myserver.mydomain.com/tsweb. they can then select their screen resolution etc.
0
 
LVL 1

Author Comment

by:akashchopra
ID: 11961383
Hmm, I'm not keen on installing IIS on the server (I want to keep all web traffic away from the server), but I may have to end up going down that route.

Thanks for the tips - I'm going to split the points for the two suggestions that have got me part way to a solution.
0
 
LVL 1

Expert Comment

by:jimmybartlett
ID: 11963988
Thanks! Actually, web traffic doesn't go up unless you design a site on the machine. I've been running IIS on my XP Pro box just so i can access it remotely from non-xp machines, and never have I had a visitor that wasn't myself. Just don't advertise the server, don't put any content on the default page, and your web traffic should be zero.
0

Featured Post

Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
Article by: btan
The intent is not to repeat what many has know about Ransomware but more to join its dots of what is it, who are the victims, why it exists, when and how we respond on infection. Lastly, sum up in a glance to share such information with more to help…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question