Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

IE Webcontrol toolbar

Posted on 2004-08-31
5
Medium Priority
?
500 Views
Last Modified: 2012-06-27
Any one know how to make a hylerlink using this control.

there is no hylerlink attribute and the onclick is always erroring out

                                    <iewc:Toolbar id="myToolbar" runat="server"
                                    BackColor="#FFFFFF" Width="70" Orientation="Horizontal"
                                    DefaultStyle="background:#EDF2FC;border:solid 1px #EDF2FC;font-size:8pt;"
                                    HoverStyle="background:#CCCCCC;border:solid 1px #cccccc;"
                                    SelectedStyle="background:#EEEEEE;border:solid 1px #cccccc;">
                                          <iewc:ToolbarButton onClick="doit()" Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Home&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"  />                                          
                                          <iewc:ToolbarSeparator />
                                          <iewc:ToolbarButton   Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Configurator&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;" />
                                          <iewc:ToolbarSeparator />
                                          <iewc:ToolbarButton Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Processor&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;" />
                                                      </iewc:Toolbar>
0
Comment
Question by:Yog
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
5 Comments
 
LVL 8

Expert Comment

by:shovavnik
ID: 11944177
Just a guess.

Try "javascript:doit()".

0
 
LVL 5

Author Comment

by:Yog
ID: 11945308
i had no luck

here is my entire code.

i am not getting what is wrong here

----------

<%@ Register TagPrefix="iewc"
Namespace="Microsoft.Web.UI.WebControls"
 Assembly="Microsoft.Web.UI.WebControls" %>
<%@ import namespace="Microsoft.Web.UI.WebControls" %>
<html>
      <head>
            <title>toolbar</title>
            <style>
            BODY
            {
                  font-family:verdana,arial,helvetica;
                  margin:0;
            }
            </style>
            <script language="javascript">
                  function doit(){
                        document.WebForm2.action="config_tree.aspx";
                        document.WebForm2.submit();
                  }
            </script>
      </head>
      <body MS_POSITIONING="GridLayout">
            <form id="WebForm2" method="post" runat="server">

                                    <iewc:Toolbar id="myToolbar" runat="server"
                                    BackColor="#FFFFFF" Width="70" Orientation="Horizontal"
                                    DefaultStyle="background:#EDF2FC;border:solid 1px #EDF2FC;font-size:8pt;"
                                    HoverStyle="background:#CCCCCC;border:solid 1px #cccccc;"
                                    SelectedStyle="background:#EEEEEE;border:solid 1px #cccccc;">
                                          <iewc:ToolbarButton onClick="javascript:doit()" Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Home&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"  />                                          
                                          <iewc:ToolbarSeparator />
                                          <iewc:ToolbarButton   Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Configurator&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;" />
                                          <iewc:ToolbarSeparator />
                                          <iewc:ToolbarButton Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Processor&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;" />
                                          <iewc:ToolbarSeparator />
                                          
                                    </iewc:Toolbar>


            </form>
      </body>
</html>

0
 
LVL 8

Accepted Solution

by:
shovavnik earned 200 total points
ID: 11945351
Try in the Code Behind to set the attribute.  Your code will look something like this.  I'm not sure what the name of the toolbar buttons collection si, so use IntelliSense.

myToolbar.ToolbarButtons[ 0 ].Attributes[ "onclick" ] = "doit()"
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this Article, I will provide a few tips in problem and solution manner. Opening an ASPX page in Visual studio 2003 is very slow. To make it fast, please do follow below steps:   Open the Solution/Project. Right click the ASPX file to b…
Today is the age of broadband.  More and more people are going this route determined to experience the web and it’s multitude of services as quickly and painlessly as possible. Coupled with the move to broadband, people are experiencing the web via …
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question