IE Webcontrol toolbar

Any one know how to make a hylerlink using this control.

there is no hylerlink attribute and the onclick is always erroring out

                                    <iewc:Toolbar id="myToolbar" runat="server"
                                    BackColor="#FFFFFF" Width="70" Orientation="Horizontal"
                                    DefaultStyle="background:#EDF2FC;border:solid 1px #EDF2FC;font-size:8pt;"
                                    HoverStyle="background:#CCCCCC;border:solid 1px #cccccc;"
                                    SelectedStyle="background:#EEEEEE;border:solid 1px #cccccc;">
                                          <iewc:ToolbarButton onClick="doit()" Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Home&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"  />                                          
                                          <iewc:ToolbarSeparator />
                                          <iewc:ToolbarButton   Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Configurator&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;" />
                                          <iewc:ToolbarSeparator />
                                          <iewc:ToolbarButton Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Processor&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;" />
                                                      </iewc:Toolbar>
LVL 5
YogAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
shovavnikConnect With a Mentor Commented:
Try in the Code Behind to set the attribute.  Your code will look something like this.  I'm not sure what the name of the toolbar buttons collection si, so use IntelliSense.

myToolbar.ToolbarButtons[ 0 ].Attributes[ "onclick" ] = "doit()"
0
 
shovavnikCommented:
Just a guess.

Try "javascript:doit()".

0
 
YogAuthor Commented:
i had no luck

here is my entire code.

i am not getting what is wrong here

----------

<%@ Register TagPrefix="iewc"
Namespace="Microsoft.Web.UI.WebControls"
 Assembly="Microsoft.Web.UI.WebControls" %>
<%@ import namespace="Microsoft.Web.UI.WebControls" %>
<html>
      <head>
            <title>toolbar</title>
            <style>
            BODY
            {
                  font-family:verdana,arial,helvetica;
                  margin:0;
            }
            </style>
            <script language="javascript">
                  function doit(){
                        document.WebForm2.action="config_tree.aspx";
                        document.WebForm2.submit();
                  }
            </script>
      </head>
      <body MS_POSITIONING="GridLayout">
            <form id="WebForm2" method="post" runat="server">

                                    <iewc:Toolbar id="myToolbar" runat="server"
                                    BackColor="#FFFFFF" Width="70" Orientation="Horizontal"
                                    DefaultStyle="background:#EDF2FC;border:solid 1px #EDF2FC;font-size:8pt;"
                                    HoverStyle="background:#CCCCCC;border:solid 1px #cccccc;"
                                    SelectedStyle="background:#EEEEEE;border:solid 1px #cccccc;">
                                          <iewc:ToolbarButton onClick="javascript:doit()" Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Home&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;"  />                                          
                                          <iewc:ToolbarSeparator />
                                          <iewc:ToolbarButton   Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Configurator&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;" />
                                          <iewc:ToolbarSeparator />
                                          <iewc:ToolbarButton Text="&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Processor&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;" />
                                          <iewc:ToolbarSeparator />
                                          
                                    </iewc:Toolbar>


            </form>
      </body>
</html>

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.