Cannot retreive field value

I have documents that may contain up to ten fields po_link1 po_link2 etcc.....

THese fields do not exist physically on the form
I can seem them if they are created in the doc properties box

I am not able to retreive their values

I have tried on the form in a new field using both below. Link1 := @If(@Contains(po_link1;"");"";po_link_1)
Link1:=  po_link1;

I also tried in script using and they both fail
POLinks(1) = prdoc.getItemValue("po_link1")
POLinks(1) = prdoc.po_link1(0)
How do I retreive the po_link1 etc... values??
Who is Participating?
Sjef BosmanConnect With a Mentor Groupware ConsultantCommented:
Very odd. What's the item's info as shown in the Properties box? Did you try to just create fields on the form with the name, Computed, with the same value, i.e. just po_link1?

And in script:
    item= prdoc.getfirstitem("po_link1")
    if item is nothing then print "Nothing!"

Are you sure that it is po_link1 and not po_1ink1?

Easiest way of showing them all in Formula:
- a CfD field with @Trim(po_link1:po_link2:...)
qwaleteeConnect With a Mentor Commented:
POLinks(1) = prdoc.po_link1(0)

That should work, assuming it exists on the document.  You can try:

If prdoc.hasItem("PO_Link1") Then
    Print "Found PO_Link1 value, assiging to POLinks(1)"
    POLinks(1) = prdoc.po_link1(0)
    Print "No PO_Link1 field exists"
End If
imjameswAuthor Commented:
Thanx I will use you suggestions
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.