Solved

xp boot failure "Logon user interface" popup that says vsgina.dll - yes - thats a 'v'.

Posted on 2004-08-31
10
846 Views
Last Modified: 2008-01-09
Attempted to upgrade from ME to XP. The install went ok. When it tries to reboot (for the umpteenth time) I get a popup that says "The logon user interface DLL vsGina.DLL failed to load". The popup only has one button "Restart".

This is 100% reproducible.

I have googled for 'vsGina' and found nothing. Im assuming that its a typo and is supposed to be 'msGina'. In any event I have tried:

reinstall
repair install
'expand msgina.dl_ c:\windows\i386' from the install disk.

No go. Same result each time.

Suggestions?
0
Comment
Question by:ethereal11
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 5

Expert Comment

by:Luniz2k1
ID: 11946055
0
 

Author Comment

by:ethereal11
ID: 11946218
well.. I can't read Russian and I don't have any products installed from "Vacman".  

This file 'vsgina.dll' doesn't appear anywhere on my system. Maybe something in the registry?
0
 
LVL 6

Accepted Solution

by:
tanelorn earned 500 total points
ID: 11946258
Hi,

I'd recommend wiping the drive and doing a fresh install of xp.  upgrades are kinda messy...

if this is not possible, you will have to have another machine on a network with which to remotely edit the registry on the target machine

once you can connect the registry on the target machine
navigate to this key

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]

look for an entry that says
"GinaDLL"   in your case it will have a value of vsgina.dll

I would delete this key as a default  XP install does not have it.
and then reboot the target machine.

I've had to play with the gina's before when we migrated off of the novell client.
this should take care of it


Tanelorn
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 
LVL 6

Expert Comment

by:tanelorn
ID: 11946278
I wonder if you could make a copy of the msgina.dll file and rename it to vsgina.dll.....


Tanelorn
0
 
LVL 6

Expert Comment

by:tanelorn
ID: 11946314
I would try the file copy and rename before the remote registry business...

I think that is the least pain.  if that works, you can delete the key once you are on the system...
0
 

Author Comment

by:ethereal11
ID: 11946486
ok - i fixed it. I found a reference to 'vsGina' in the registry under HKLM/SOFTWARE/Microsoft/WindowsNT/CurrentVersion/Winlogon. There were two references to Gina there with one being to 'vsGina' and one to 'msGina'. Since this machine won't be used with a login anyway (its a home machine) I renamed both to '_old' and rebooted. Lo and behold. It boots.

Sigh. Now to get SP2.
0
 
LVL 9

Expert Comment

by:woodendude
ID: 11947892
hold off on the sp2!
0
 
LVL 6

Expert Comment

by:tanelorn
ID: 12718052
Hi,

I think I helped this person..  renameing the references in the registry, is the same as deleting them. so I think technically I had the correct answer...

I think I should get the points for it..

any other thoughts??

T
0
 

Author Comment

by:ethereal11
ID: 12727371
Thats true. The pointage is yours.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As the title indicates, I have done this before. It chills me everytime I update the OS on my phone, (http://www.experts-exchange.com/articles/18084/Upgrading-to-Android-5-0-Lollipop.html) because one time I did this and I essentially had a bricked …
Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.
Suggested Courses

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question