[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 304
  • Last Modified:

An administrator has denied permission to use Windows Messenger - how to allow?

I go to Remote Assistance, click on invite someone to help you.
Under Windows Messager, it says "An administrator has denied permission to use Windows Messenger."

I'm the admin.  How can I grant permission to use WM?
0
raymm
Asked:
raymm
  • 14
  • 7
  • 7
  • +1
1 Solution
 
SheharyaarSaahilCommented:
Hello raymm =)

hey is Messenger service disbaled ??
goto Start>Run>services.msc
look for Messenger, right clik it chosoe Properteis, and select the Startup type as Enable
restart and now check for the problem ??
0
 
SheharyaarSaahilCommented:
>> and select the Startup type as Enable

i mean set it to Automatic :)
reboot and check !

and if this fails, then Download these tow registries and run them,

http://messenger.jonathankay.com/do...senger_user.reg
http://messenger.jonathankay.com/do...lemessenger.reg

Restart and now check for the problem ??
0
 
raymmAuthor Commented:
Thank you SheharyaarSaahil.

Messanger is disabled.
I rtclk, chose Properties, nothing happens, I don't get the box that allows me to set Messanger to enabled or auto.
Now that I check, I can't get the box for any of the services.

So, then I try the registry links you provided, they produce a page cannot be found.
I try to DL the reg file, can't.

What to do?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
SheharyaarSaahilCommented:
hmmmmm ok i'll check it out,,,, meanwhile try this, goto Start>Run>msconfig>Services
and here u can see the Messenger listed, tick it and restart, now when u will see in services.msc, Messenegr shud be running, is it ??
0
 
raymmAuthor Commented:
meanwhile try this, goto Start>Run>msconfig>Services
and here u can see the Messenger listed, tick it and restart, now when u will see in services.msc, Messenegr shud be running, is it ??

I did goto Start>Run>msconfig>Services.  I found Messanger.  
Rtclk, all tasks, everything grey.
Rkclk, properties, no response.
Action menu, Start to Restart, all grey.
Action menu, All Tasks, all grey.
Other items in Start>Run>msconfig>Services, can restart, etc.
I must have the most screwed up install of WinXP Pro on earth.
0
 
SheharyaarSaahilCommented:
wait a minute.... where are u looking now...
first i asked u to goto Start>Run>services.msc
where all was disabled !!

now im asking to goto Start>Run>msconfig>Services
here u will get many services with check boxes, and u have to tick Messenger
infact better u click on ENABLE ALL
restart and now check for the problem ??
0
 
sramesh2kCommented:
This is due to a policy settting:

Open Registry Editor and navigate to:
HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger\Client

In the right-pane, double-click PreventRun to 0

Close Registry Editor and open HelpCenter

You should no longer see the error
0
 
sramesh2kCommented:
Error "Administrator has denied permission to use Windows Messenger" while inviting someone to help you using Remote Assistance:
http://www.winxptutor.com/wmrestrict.htm
0
 
Mukul-VarmaCommented:
Reinstall. Would take less time! ;-)

Actually, I never used Remote Assistance, so I'll stay out of this!
0
 
raymmAuthor Commented:
Thanks for the ideas, here is where I am.
I have a new clean install of Win XP Pro.
From one client I have gotten an email and a Messanger request.
When I accept each of them, I got "Remote Assistance-Web Page Dialogue" box saying "Remote Assistance failed.  Please try again."
Any suggestions?

Re the other client, I will try the regedit suggestion above and report back.
0
 
raymmAuthor Commented:
The new clean install of Win XP Pro has solved the Messanger service problem on my computer.
0
 
raymmAuthor Commented:
I've read some other posts, I'm using the Win XP SP2 firewall.  Does that have to be disabled? Is there something less drastic than disabling?
0
 
raymmAuthor Commented:
The info below fixed the error "Administrator has denied permission to use Windows Messenger" on one client.  
http://www.winxptutor.com/wmrestrict.htm

I still have the "Remote Assistance failed.  Please try again." problem.
Hoping for help.
0
 
sramesh2kCommented:
313492 - You may receive a "Remote Assistance failed" error message on a Windows XP-based Internet Connection Sharing client computer that uses the Internet Connection Firewall feature:
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q313492
0
 
sramesh2kCommented:
308210 - Remote Assistance May Not Connect to a Multiple-Homed Windows XP Computer with the Personal Firewall Feature Enabled:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q308210
0
 
raymmAuthor Commented:
But I have SP2 installed.
0
 
raymmAuthor Commented:
sramesh2k:

Read the links, they all say get the latest SP, but I have SP2 installed.
0
 
sramesh2kCommented:
Do you have a personal firewall installed, raymm ?
0
 
raymmAuthor Commented:
Using Win XP SP2 firewall.
0
 
sramesh2kCommented:
This, from a MS Tech might help:

------
Go to the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Ole\

Look for an "EnableDCOM" value. It should be set to "Y". (If it is missing
or is set to "N", that would explain this problem.)
------
0
 
raymmAuthor Commented:
Found it, it is set to "Y".
0
 
sramesh2kCommented:
Umm. Can't think of any, right now. As it's a clean isntall, it may not be a policy setting. Just in case, the Remote Assistance Policy settings are discussed here:

http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/intmgmt/20_xprem.mspx

http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/adminra.mspx#XSLTsection123121120120
0
 
raymmAuthor Commented:
Nope, won't be policy, I haven't set any, don't know how.
0
 
raymmAuthor Commented:
Thank you for your efforts though.
0
 
SheharyaarSaahilCommented:
ray.... remember i gave u some registry files which are throwing Page Cannot be Opened...... go here >> http://www.mcse.ms/archive69-2004-3-477626.html

I can Download them from this site.... can u ??
0
 
raymmAuthor Commented:
She:  yes, dl'd from that site, will advise.
0
 
SheharyaarSaahilCommented:
ok :)
0
 
raymmAuthor Commented:
I couldn't get Remote Assistance working, I got Application Sharing working, that enabled me to do what I wanted.
Odd that I could get Application Sharing working but not Remote Assistance.
0
 
SheharyaarSaahilCommented:
when u goto Start>Run>msconfig>Services
are all the services ticked here ??

and just for "Testing" have u tried using Remote Assistance with Firewall disabled yet ??
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

  • 14
  • 7
  • 7
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now