?
Solved

compile / install postfix on solaris 9

Posted on 2004-08-31
9
Medium Priority
?
2,707 Views
Last Modified: 2013-12-27
Dear,
i have one workstation ultra60 with solaris 9 apache2/mod_perl2/perl-585/PHP4 installed.
I'd like to install a mail server with Postfix.
Following the instructions, I removed the sendmail package that was coming with the OS by pkgrm, and compiled postfix with
./configure -DHAS_MYSQL= . . . (some thing like that)

but then, when run the make commad, I got this error

Falal error: make cannot target "updates"
Fatal error: make cannot target "error"

so, can you help me out?.
I;ve been wandering the internet for days and came up with nothing.

Thanks in advance



0
Comment
Question by:valleytech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
9 Comments
 
LVL 38

Expert Comment

by:yuzh
ID: 11948272
For start you need to have a working C complier, you can download gcc (and other GNU
tools) from:

http://sunfreeware.com/

please download gcc +make+  zlib +_ libgcc + glib + openssl + libtool + libiconv
+autoconf + automake + flex + boson from the about site.

and set PATH LD_LIBRARY_PATH to used them, eg:
PATH=/usr/local/bin:$PATH  #to make sure that you are using the GNU tools
LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/local/lib
export PATH LD_LIBRARY_PATH

then run
configure
make

Have a look at the instructions in the following docs to learn how to install:
http://www.postfix.org/INSTALL.html
http://ultra.litpixel.com:84/articles/rswp/frameset.html

0
 

Author Comment

by:valleytech
ID: 11959355
thanks for your reply...
however, another problem came out.
after executing the "make" command , i got this:
ld:Fatal error Symbol Refefrence Error
No outputs written to location

I;ve already done what you advised me to do. Here is my PATH
usr/dt/bin
usr/sbin
usr/openwin/bin
usr/local/bin
usr/local/sbin
bin
/usr/bin
/usr/ccs/bin
/usr/ucb

thanks a lot for helping me
0
 
LVL 38

Expert Comment

by:yuzh
ID: 11959661
You should use: ABSOLUTIVE path, eg:
usr/dt/bin    should change to: /usr/dt/bin
bin                                        /bin

fix your PATH first, and make sure that you set LD_LIBRARY_PATH you use the required
libs.

Have you download the gcc compiler and the other tools mentioned in my 1st comment?
you need them to make postfix to work for you !

Good luck!
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:valleytech
ID: 12147809
Dear,
My PATH is excatly like what you have suggested!

My GCC ccompiler's version is 4.3.
When I set LD_LIBRARY_PATH and compiled Postfix, I got this "DO NOT SET LD_LIBRARY_PATH"
Here is my configuration for postfix prior to compiling:
make -f Makefile.ini makefiles \
CCARGS=-DHAS_DB = "-I/usr/local/Berkeley.4.2/include" \
              AUXLIBS="-L/usr/local/Bekeley.4.2/lib -ldb"

After that, i unset LD_LIBRARY_PATH, the configuration was execuated neatly. However, with the "make" command, I got this "Symbol referencing error"

0
 
LVL 38

Expert Comment

by:yuzh
ID: 12157194
Please have a look at the following information page:
http://www.agamemnon.net/documents/postfix/faq.html#db

Full FAQ:
http://www.agamemnon.net/documents/postfix/faq.html

Did you remember to set:
PATH=/usr/local/bin:$PATH  #to make sure that you are using the GNU tools

and also check your Makefile(s) to make sure that you are using the GNU gcc, and make.

Do you want me to re-open this question for you?
0
 

Author Comment

by:valleytech
ID: 12669782
can you please re-open this question...

here is my PATH:
/usr/sbin :/usr/bin:/usr/dt/bin:/usr/ucb:/usr/ccs/bin:/usr/local/bin

all of those packages have been installed.!!!...
I still got that error and started to get frustrated!!

How can I check the Makefiles ( you meaned the Makefiles from postfix source code folder??)

Thanks in advance
0
 
LVL 38

Accepted Solution

by:
yuzh earned 2000 total points
ID: 12671211
No, problem, I unaccept the question for you.

    >>I still got that error and started to get frustrated!!
    >> How can I check the Makefiles.
    The Makefile should be under the source code dir, created
by configure script, check it after you run configure.
   

   Please post the error messages.

yuzh

0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Let's say you need to move the data of a file system from one partition to another. This generally involves dismounting the file system, backing it up to tapes, and restoring it to a new partition. You may also copy the file system from one place to…
I promised to write further about my project, and here I am.  First, I needed to setup the Primary Server.  You can read how in this article: Setup FreeBSD Server with full HDD encryption (http://www.experts-exchange.com/OS/Unix/BSD/FreeBSD/A_3660-S…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Suggested Courses
Course of the Month15 days, 9 hours left to enroll

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question