d015 rollback files

zen starter kit/ winXP.  When running NAL we get a d015 unable to create rollback files.  With win2k we just give everybody rights to c:\documents and settings\default user\local settings\temp  and it fixes it.  This does not work on XP home or Pro.  How can we solve this problem? Have checked Novell TIDs but can't find anything pretaining to XP there.
thanks
hage1Asked:
Who is Participating?
 
ShineOnCommented:
Are you using DLU?  If not, just wondering if it might work better if you use All Users\Temp instead of Default Users\Temp?

Or, perhaps you could try creating a C:\Temp, give all local users/groups full "permissions" to C:\Temp,  and set the environment vairiable for TEMP to C:\Temp in the login script.

'Course, this might have something to do with how the ZEN app is set up. I don't remember how fine the control is on the starter pack apps as far as things like working directory and such.
0
 
slappa1Commented:
1. Full Control access to the NALCACHE subdirectory (normally c:\nalcache)
2. Read\Write rights to HKEY_CURRENT_USER\Software\NetWare\NAL\1.0
3. Read rights to HKEY_LOCAL_MACHINE\Software\NetWare\NAL\1.0
4. Read rights to HKEY_LOCAL_MACHINE\SOFTWARE\Novell\ZENWorks
4. Full Control to the user's TEMP directory, normally found in "C:\Documents and Settings\<userid>\Local Settings\Temp
5. The System user on NT/W2K/XP should have full rights to all areas of the workstation, it is not necessary to modify the System user's default rights in order for ZfD4 NAL to work properly.  NAL relies on the system user's rights to allow the installation of most software.

Normal users get most of these rights automatically, however rights to the NALCACHE directory may need to be explicitly given on locked down workstations.


above from <link=http://support.novell.com/cgi-bin/search/searchtid.cgi?/10074299.htm>tid</link>

even tho this is from zfd4 it show's you what rights are needed.

use regedt32 to set the registry rights.
0
 
ShineOnCommented:
NALCACHE started with ZFD 3.2.  The ZEN starter kit shouldn't be used with XP.  It was barely able to support NT4.

Sorry to be a wet blanket, but unless someone says otherwise that *successfully uses* the starter kit with XP, that's my story, and I'm stickin' to it.
0
 
hage1Author Commented:
I tend to agree.  It does work nicely with win2K, so I thought it might be possible to tweak it for XP.  I'm still open for ideas.  If all else fails, it's win2K for us.
0
 
hage1Author Commented:
You found it ShineOn.  You do not have to create any directoried or assign any rights.  Just add the following to login script.
                      set temp="c:\windows\temp"
                      set tmp="c:\windows\temp"
I got the idea from your answer.  Thanks much all.
Carl Hage
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.