• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 383
  • Last Modified:

Copying files with a Batch file

I have a batch file that copies autocad .dxf files from a file server to my hard drive (c:). I would like to direct those files being copied to the folder c:\my documents\drawings.
Here is the existing line that gets me to the c: drive:
           copy j:\hal\synth\hsga\sheet?.dxf c:\.

Thanks Jeff

0
fanguru1
Asked:
fanguru1
  • 2
  • 2
1 Solution
 
Dufo G. BelskiRetired bureaucrat/desktop supportCommented:
Just change it to

copy j:\hal\synth\hsga\sheet?.dxf c:\my documents\drawings
0
 
Dufo G. BelskiRetired bureaucrat/desktop supportCommented:
Or to copy all .dxf files that exist at the time,

copy j:\hal\synth\hsga\*.dxf c:\my documents\drawings
0
 
Pete LongTechnical ConsultantCommented:
depends on the path to your my dcocuments!!!!!!!

The path to the My Documents folder is stored in the following registry key:
Hive: HKEY_CURRENT_USER
Key: Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
Name: Personal
Type: REG_SZ
Value: fully qualified path to storage location

so your command woud be

copy j:\hal\synth\hsga\sheet?.dxf <path from the key above>

remember if theres spaces in the path toy need to put quotes around it i,e.

"c:\documents and settings\username\folder"
0
 
Pete LongTechnical ConsultantCommented:
ThanQ
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now