Solved

Only PS2 keyboard works before boot; after boot, only USB keyboard works

Posted on 2004-09-01
6
516 Views
Last Modified: 2013-12-09
OK, it is difficult to describe how I got to this problem. This is one of a pair of home built servers running W2K SP4 in English but located in Paris, France. The system drive is mirrored, and there is an entry in the Boot.ini file so that I can boot off either disk. The second system is exactly identical and has no problem.

On the first server, Windows was installed with an English-layout PS2 keyboard but then it was replaced with a French-layout USB keyboard. There was no problem until one day the server had to be rebooted and from there on, the following problem appeared (or became visible, anyway; perhaps it was always there). In the boot process, Windows asks, as usual when it finds several entries in the boot file, which OS needs to be booted, with a countdown of 30 seconds for the user to select one of the two. Usually, after the thirty seconds, if the user doesn't do anything the first OS is booted.

The problem is that

(a) neither the PS/2 keyboard nor USB keyboard (which are now coexisting) allows the user to select which OS to boot; in other words neither allows the user to use the arrow keys, enter key or space bar to select even the currently highlighted OS.

(b) after the countdown is finished, and only then, the system allows the user to press <enter> on the PS/2 keyboard. It hangs until the user does so. The USB keyboard still is completely dead.

(c) after the boot is complete, the control-alt-delete for the login box only works on the USB keyboard, which works great from then on. On the other hand, the PS2 keyboard is dead, even for the enter key.

(d) for a bonus, see if you can answer this. While logging into the login box, the USB keyboard, which if you recall uses a french layout, is programmed to act as a US keyboard, as the PS/2 was originally installed. The french layout only appears after the user (administrator) logs in. I have seen this before and I think it is "normal" behavoir for Windows 2000, I was just wondering if anyone know how to fix this.





0
Comment
Question by:valleeo
6 Comments
 
LVL 13

Expert Comment

by:wlennon
ID: 11954172
Hello valleeo, not too familure with multi lauguage keyboards, you can try removing the .ini file from the bat file, and let windows use plug and play to reconize the keyboards, but I have found that using KVM switches to run ONE keybaord on two systems sucessfully (see link below, there are serveal options, two USB, two PS/2).  On page three there is even one that is Rack Mounted.  Note* you do not have to use the Monitor support on any of these for them to work.

http://www.tigerdirect.com/applications/category/category_slc.asp?CatId=202

Thanks,

wlennon
0
 
LVL 31

Expert Comment

by:rid
ID: 11956370
The system that doesn't have a problem, does it, too, have 2 keyboards?
Why can't you just use the PS/2 KB?
/RID
0
 
LVL 6

Accepted Solution

by:
salvagbf earned 150 total points
ID: 11957251
There should be a setting in the BIOS of the machine that's labled something like "Legacy USB" and that (usually) needs to be enabled for USB devices to work before Windows boots up all the way.  

As for the ps/2 not working once you hit windows, it's probably just because windows is taking the USB one as default and disabling the ps/2 port.  Try not plugging in the USB one at all, the ps/2 will probably then work once you're in Windows.  If that still doesn't work, with both kbd's in, go to device manager and right click "computer" at the top and click "Scan for Hardware Changes" to make sure it's detecting the ps/2 kbd.

-Bernie
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 
LVL 2

Assisted Solution

by:icedrop-dcse
icedrop-dcse earned 100 total points
ID: 11957460
your having conflicts regarding your keyboards. the french language system launches only when windows starts. so during boot-up the computer is conflicting between the two since your pc supports both usb and ps2 keyboards even out of the OS.

as with the enter key.. this is just a theory. as the os loads with ntldr. it reads off from the ps2 because that is the first in the list with the bios. and as windows loads up it then disables the ps2 port since its last configuration was to use the usb keyboard.

the problem regarding the layout of the keyboard outside of any user accounts can only be fixed if youre using the french version of the OS. if youre using english based OS,  then the "regional" settings would only kick in after loading the preferences of a user. thats the way i know to correct it. i think there is also a patch to convert your system to another language settings.

why not just use 1 keyboard at a time?
0
 

Author Comment

by:valleeo
ID: 11961786
wlennon, thanks for your comment, but there is not .ini file except for the boot.ini file, that has no reference to the keyboards. also, a KVM switch is irrelevant for this problem.

Rid:  I would like to get rid of the PS2 keyboard, but if I remove it then I can't hit the enter key to get the system to boot.   To answer your question, the second system does not have two keyboards.

Salvagbf:  The bios idea is a good one. I will reboot the system tomorrow, and I will check then.  I do remember that if  I remove the USB keyboard, the PS/2 keyboard still does not work, leaving me with no keyboard access at all. I did do the "scan for hardware changes" but that did not help.

Icedrop-dcse:  Thanks for the insight. I will check the bios settings when I reboot (see above). To answer your question, yes, I'd like to have one keyboard. Re the french/english problem, I have installed english-language systems with french keyboards before, and it does work, but only if you specify the french layout during system installation. I have neverfound a way to change this, even in regional settings, which works as your describe. The problem is that once you install it as english layout, if you then install a french keyboard, the layout is always english until you log in. When you log in, you have to log in as "Qd,inistrqtor" and not "Administrator"!

Thanks to everyone,
Olivier

0
 

Author Comment

by:valleeo
ID: 11987776
I brought down the machine and checked the bios settings. In fact there was a bios setting for USB support, and that fixed the problem. I'm splitting the points between Salvagbf and Icedrop-dcse. Many thanks.
PS. Still don't know how to change the keyboard layout before login.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now