?
Solved

Windows 2000 "Black Hole" Folder

Posted on 2004-09-01
5
Medium Priority
?
465 Views
Last Modified: 2010-04-03
Background:

Windows 2000 machine running Imail Server under NTFS.
Norton Antivirus scanned inside mail "Spool" folder, I guess corrupting files inside.
Folder was successfully moved and renamed to take care of problem with Imail.
Left with "oldspool" folder on desktop.

Problem:

This folder cannot be deleted. I don't believe this to be a permission problem. I am unable to run some scans as they will scan this folder indefinately.

What I've tried:

Under 2000 GUI - Dropping in recycle bin.
Using a file shredding program.
Killing explorer.exe and deleting from a command prompt.
Moving to a temporary second HDD.

From repair console: Using "del" command on folder.
Running "chkdsk".
Using del *.* inside the folder.

Odd things I've noted:

If I right click on the file and click properties, size and size on disk grow infinitely.
Double-clicking the folder will open the folder and it will show 0 files and 0 folders but with an hourglass cursor if I hover over the window.
If I drop a file in the folder it is not displayed. However if I drop another file in the folder with the same name, I will get an overwrite error.
I never get an error when trying to delete the folder, just a never ending deleting notice.

This is crazy. Any ideas? I'll try anything at this point. I also tried using a marker the same color as the desktop and coloring the monitor over the folder. This appeared to work, but I still have problems.
0
Comment
Question by:hharding
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 57

Accepted Solution

by:
Pete Long earned 1000 total points
ID: 11953696
Can’t Delete a File

You need permissions to delete a file are you a member of the Administrators group?
(you need a minimum of {modify} to delete.
**********
1.      Try to take ownership of the file. Right click the file > Select the security Tab
Select properties > Select Advanced > Select Owner
Find the User or group you wish to give ownership to and select > Click apply
Now try and delete the file
http://support.microsoft.com/default.aspx?scid=kb;en-us;268019
**********
2      Is it telling you the filename is too long? Then Delete the file in DOS mode
Start >Run >cmd {enter}
Navigate to the folder the file is in, i.e. if its in c:\folder\anotherfolder\file, type "cd c:\folder\anotherfolder" {enter} The command prompt should change to let you know you are in
the correct directory. Type "dir /x" {enter}
The offending file will be listed like (filena~1.xxx)
Take note of the name and type "del filena~1.xxx" {enter}
**********
3.      Is the file flagged as ‘System’? Start > Run > type CMD >Click OK
Navigate to the folder in which the file resides (i.e. cd c:\folder\folder\ {enter})
Type attrib -r -s -a -h filename.extension {enter}
Del filename.extension {enter}
**********
4.      Is the file in use? If either the OS or another program is using the file you cannot
delete it You can with ZAP Included with the Microsoft SMS 2.0 Resource Guide and the
Microsoft BackOffice Resource Kit 4.5. or you can download it here
http://helpdesk.kixtart.org/KixUtilsTasks.asp
WARNING make sure you know what your deleting first!
**********
5.      If your hard drive is formatted with FAT32 you can boot with a boot disk and Delete
the file from DOS. (del filename.extension) If your hard drive is formatted with NTFS you
can boot with a boot disk and, if you lucky enough to have a copy of NTFSPro from http://www.sysinternals.com/ntw2k/freeware/ntfsdospro.shtml you can boot to DOS mount the
NTFS volumes and delete it from there.
**********

**Other Options**
Use this on the file/folder in question
http://www.jrtwine.com/Products/DelFXPFiles/

Try using TAKEOWN from the resource kit to force ownership and delete the file
http://www.dynawell.com/support/ResKit/win2k.asp

Try using "KillBox" on the file
http://www.broadbandmedic.com/download/VbStuff/TheKillBox.zip

"Access Denied" When You Delete Folders from a Mounted Drive
http://support.microsoft.com/default.aspx?scid=kb;en-us;243514
0
 
LVL 6

Expert Comment

by:icemanwol
ID: 11957488
I have had this problem happen before on my windows XP box were a file or folder just cannot be deleted no matter what you do,  The solution, i find, is either A: put that harddrive in anouther 2000 system or B: use a bootable cd-rom called BARTPE which boots a minimum Windows XP system, it builds of a currect xp/2000 cd-rom so if you have one, download and build it (when i say build, i do not mean compile, i mean it builds a iso that you can burn to a cd and boot off of)
http://www.nu2.nu/pebuilder/
Hope this helps.
0
 
LVL 6

Expert Comment

by:icemanwol
ID: 11957497
Ohh, also, before deleteing the folder, run CHKDSK C: /F in either the other windows 2k host system or the bartPE CD
0
 

Author Comment

by:hharding
ID: 11957529
OK, I got this figured out.

I got this enlightenment using Killbox, so I'll award PeteLong the points.

The files in here are all 13 characters long. They are numbered in order as aaaaaaaaaaaaa, aaaaaaaaaaaab, aaaaaaaaaaaac...ect. with numbers coming after letters, aaaaaaaaaaaaz, aaaaaaaaaaaa0, aaaaaaaaaaaa1...etc

The highest numbered file I was able to see was named "D08xxxxxxxxxx" or somewhere around there.

I don't care to convert a 36 base numbering system to decimal, but there has to be millions of files in this folder.

I suppose it was hanging trying to display or delete all these in one fell swoop.

I set up a batch file that divides this up and deletes them in smaller groups based on the convenient numbering system.

I'm sure this will run for days, but in the end I think it should take of the problem.

Thanks for the help.

Hugh
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 11957715
ThanQ
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lets start to have a small explanation what is VAAI(vStorage API for Array Integration ) and what are the benefits using it. VAAI is an API framework in VMware that enable some Storage tasks. It first presented in ESXi 4.1, but only after 5.x sup…
Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question