Solved

Dlink DI-624 Wireless Router and Wireless ISP configuration problems

Posted on 2004-09-01
3
1,168 Views
Last Modified: 2011-10-03
Hello,

I need help configuring a wireless router to allow ICS and file sharing on a small two to three PC network.

We use a wireless ISP provider called E-net. The iSP sends the internet signal to a reciever located on the outside of the office building. The signal is then transferred from the reciever to a host PC via coaxle cable to an internal card on the host PC. The internal card connects to the coax cable with a BNC type of connection. We are able to get internet connectivity on the host PC.

The problem comes into play when we try to setup a D-Link DI-624 wireless router so that we can get internet access to a second PC through the wireless capability of the router. Basically, nothing seems to work that will allow the second PC to gain internet access or file sharing/network access. I have tried several different things and am unsure of where to go from here.

I have tried the following:
I have reset the router
I have verified that the host machine will connect to the internet through the router(see below)
I have disabled DCHP on the router to try and turn it into a switch(see below)
I have upgraded the firmware on the router

The internal ISP provided card requires me to run the connection the router to the host PC from the ethernet card(host PC) to the router. I have tried to connect to the WLAN port on the router but that results in the host PC losing internet connectivity. I have only been able to keep internet connectivity by running from the host PC ethernet card to LAN Port 1 on the router so I am unsure whether I am accessing the internet through the router or through the internal ISP card. So I know I can connect to the internet through the host PC but the hardware connections that I am forced to use have me confused on where the connection is coming from. I tried IP config and it looks like all of the active network connections (there are two, 1 for the wireless internet and 1 for the Local LAN/D-Link Router) are active. I tried to PING the IP addresses associated with both connections and the reply was positive.

It seems very strange to me that I have to connect to the router from the host PC ethernet card to one of the LAN Ports. I am used to the cable/DSL internet environment where an ethernet cable is used to connect/piggy back from the router to the host PC ethernet card. It does not make sense to do it any other way. But this ISP setup is different.

Trying to use the router as a switch did not work either.

I have repeatedly received an error when trying to enable ICS on the host PC. The error states that a confilct has occured due to duplicate IP addresses (the router IP address is the one mentioned. 192.168.0.1) IP config tells me that this IP address is not being used any where except for the default gateway.

Both of the PC's are using WinXP Home with SP1 installed. I have a great signal from the router and I have tested the router in a different environment and it works just fine. I need to get this resolved ASAP so I am assigning 500 points to this issue. I have spent at least 10 hours talking to D-Link and E-net (ISP) and they can not help.

A quick response will be appreciated
0
Comment
Question by:tkieffer
  • 2
3 Comments
 
LVL 11

Accepted Solution

by:
infotrader earned 500 total points
Comment Utility
You should focus on E-net.  Any ISP that does not result in delivering Internet access to the end user(s) via Ethernet cable is a joke.

The problem is that you cannot get any router for their proprietary connectors.  So ICS seems to be the only way to go, unless you want to spend more money and buy yourself an ISA server.  I think E-Net SHOULD have some solutions because c'mon, what kind of ISP is it if it needs to run a proprietary cable to every machine?  I think they just want more money, that's all.

Let's assume the 1st machine (I shall call it machine_A) is now connected to the Internet.  You should connect machine_A to the D_Link's LAN (NOT WAN) port, and use that as a wireless switch.  Change the D-Link IP to anything except 192.168.0.1 because realistically, you don't need an IP for D-Link except for administrative purposes... it's NOT being used as a gateway... machine_A is now the gateway because you turned on ICS.

- Info
0
 

Author Comment

by:tkieffer
Comment Utility
Thanks for the advice. I changed the router IP to 192.168.0.10 and turned on ICS. I still could not connect to the internet. I then turned off ICS and bridged the network connections(through Windows) located on machine_A. I could actually connect to the internet at this point. I am not sure right now if I disabled DHCP on the router (I am not able to look at these machines right now).  Anyway, I could also connect to the internet from my laptop. The other setting that I changed was the default gateway on machine_B to match up with 192.168.0.10. I am unsure of why these changes allowed the connection to take place but the combination looked like it solved the problem.

However, I was asked to reboot machine_B after running the network setup wizard on machine_B and the connection was lost afterwards. I was able to get the connection back(a little unsure on what brought it back) but when I rebooted, it was gone again.

It seems like the network will not work hand in hand with the internet connection. I am unsure at this point how to resolve the issue because I have tried so many things that my mind is little foggy. Any ideas?
0
 

Author Comment

by:tkieffer
Comment Utility
Things are working just fine now with one exception. The wireless network is sometimes when I reboot Machine_B. The work around is to disable the wireless connection from this computer and then re-enable it. Everything works fine from then on. The problem is intermittant and the work around is easy to manage. Here's what I think fixed the problem.

1. Disable DHCP on the router.
2. CHange the router IP to something other than 192.168.0.1.
3. Enable ICS from the host machine.
4 Run the network setup wizard from both machines.
5. Disable the D-link software on both machines and let XP manage the network cards.

Thanks for your help.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now