• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 314
  • Last Modified:

USB flash memory to RedHat 8.0

I added the above to a USB port.  I did not see a drive letter or something a ppers as it dows on windows operating systems.  Are there additional steps need ed to install this?

Regards,

0
khyberman
Asked:
khyberman
1 Solution
 
knollbertCommented:
check your /dev/ it will probably show as /dev/sda
unless you already have scsi items

create line for it in fstab
noauto

create directory to mount into

mount /mnt/directtomountinto
0
 
knollbertCommented:
Check out
http://www.extremetech.com/article2/0,3973,1256701,00.asp
Yeah it for RH 9.0 but it should still work
0
 
GnsCommented:
Do dmesg and look for the fake SCSI interface for "usb mass storage". Unless you have some other scsi it'll become /dev/sda... These things rarely use any partitioning scheme, so you usually mount the /dev/sda device directly... something like
mount /dev/sda /mnt/flash
Now, the flash directory will not be there, and you need it as a mountpoint, so do
mkdir /mnt/flash
before trying to mount it the first time. Also note that we don't specify any filesystem type or mount options, but rather try with the defaults (autodetect fs type and mount r/w)... You might need help with that too:-).

Very important:
before removing the flash, remember to _always_ unmount it. You do that with
umount /dev/sda

... Now, don't take /dev/sda for granted, check the dmesg output first (after inserting it).

-- Glenn
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
xDamoxCommented:
first do:

modprobe usb-storage

then do mount /dev/sda /mnt/flash
0
 
GnsCommented:
RH8 don't have hotplug installed xDamox? Perhaps a good thing if so:).

-- Glenn
0
 
ITcrowCommented:

Linux commands in sequence for the first time.
Later on, use only mount command

> modprobe usb-storage
> mkdir /mnt/usb
> mount /dev/sda /mnt/usb
> ls /mnt/usb

This should work and your USB data should be visible in /mnt/usb.

If it doesn't, then launch hardware browser:
> hwbrowser &

This will show you what device your storage is on. /dev/sda, /dev/hde. etc.
Remember /dev/hda is your primary HDD.

You will require your root password with mount and hwbrowser.
0
 
khybermanAuthor Commented:
Thanks all.  It works now.
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now