Solved

PIX client VPN setup

Posted on 2004-09-02
11
248 Views
Last Modified: 2013-11-16
Hi ,
i am looking to connect a VPN client through my new PIX 501 and its been a while since i did this thing but here is the config
i'm using client 4.03 which seems fine
currently i can connect to the address pool 192.168.73.1 absolutely fine

ony problem is i cannot access anything on the 192.168.72.0 network

cant see whats wrong but guess its an access-lsit thing or something

any help is appreciated

heres the config

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password sjMKnkqrAFoDv9qV encrypted
passwd ppfrsHiAri.o1MPD encrypted
hostname foundpix1
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 102 permit ip 192.168.72.0 255.255.255.0 192.168.73.0 255.255.255.0
pager lines 24
logging on
logging console debugging
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside 80.169.155.6 255.255.255.248
ip address inside 192.168.72.250 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VpnPool1 192.168.73.1-192.168.73.254
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 1 80.169.155.4 netmask 255.255.255.248
nat (inside) 0 access-list 102
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 80.169.155.1 1
route inside 193.196.133.0 255.255.255.0 192.168.72.111 1
route inside 194.129.160.0 255.255.255.0 192.168.72.111 1
route inside 194.129.161.0 255.255.255.0 192.168.72.111 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup foundation address-pool VpnPool1
vpngroup foundation dns-server 192.168.72.1
vpngroup foundation default-domain FELONDON
vpngroup foundation split-tunnel 102
vpngroup foundation idle-time 1800
vpngroup foundation password ********
telnet 192.168.72.0 255.255.255.0 inside
telnet timeout 50
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
terminal width 80
Cryptochecksum:591ced32654b155b35f94e57e8ad3b84
: end
foundpix1(config)#




also just to add a bit more info.

when i am connect i get an ip address but no default gateway on the virtual IP address and also when i do an ARP look-up i can see the 192.168.72.x network .... not sure that helps but to me looks like a routing issue
 
 
0
Comment
Question by:redmayne
11 Comments
 
LVL 11

Expert Comment

by:billwharton
ID: 11963699
Your configuraiton seems correct. Did you try pinging a live host on the x.x.72.0 network?
0
 

Author Comment

by:redmayne
ID: 11963727
yes i did i can't get anything
not sure whats up there as i thought it was right too

like i said when i try to ping from an external source (which is admittedly behind a firewall) there is no response and i can't get any other services such as DNS etc from it so i;m not sure whats blocking it.  I thought this would have worked.  
0
 

Author Comment

by:redmayne
ID: 11964023
should i be able to ping the IP address handed out by the Firewall on the client?
i can't even do that!

0
 
LVL 36

Expert Comment

by:grblades
ID: 11964688
Hi redmayne,
Yes you should be able to ping the IP address assigned to you (I can).

Have you tried reinstalling the client and making sure you don't have any personal firewall installed?
Sometimes deinstalling, rebooting, reinstalling current service pack, rebooting, reinstalling client fixes problems like this.

Is it the 4.0.3(F) client that you have?
0
 

Author Comment

by:redmayne
ID: 11964701
yes that is the client
i think i will try that a bit later on at home as was using another ofice's machine where i don't want to mess too much

thanks for the tip i'll see hiow it goes in a few hours
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:redmayne
ID: 11971146
nope still didn't work - can't see it being a client fault now
had the same problem but no personal firewall or other VPN client software in the way

0
 

Author Comment

by:redmayne
ID: 11971162
here are some other thigns such as sh ver etc in case that helps but all looks good to me

foundpix1# sh ver

Cisco PIX Firewall Version 6.3(3)
Cisco PIX Device Manager Version 3.0(1)

Compiled on Wed 13-Aug-03 13:55 by morlee

foundpix1 up 1 day 0 hours

Hardware:   PIX-501, 16 MB RAM, CPU Am5x86 133 MHz
Flash E28F640J3 @ 0x3000000, 8MB
BIOS Flash E28F640J3 @ 0xfffd8000, 128KB

0: ethernet0: address is 0011.bb3d.c3a5, irq 9
1: ethernet1: address is 0011.bb3d.c3a6, irq 10
Licensed Features:
Failover:                    Disabled
VPN-DES:                     Enabled
VPN-3DES-AES:                Enabled
Maximum Physical Interfaces: 2
Maximum Interfaces:          2
Cut-through Proxy:           Enabled
Guards:                      Enabled
URL-filtering:               Enabled
Inside Hosts:                Unlimited
Throughput:                  Unlimited
IKE peers:                   10

This PIX has a Restricted (R) license.

Serial Number: 808323128 (0x302e0838)
Running Activation Key: 0xb363ace9 0x6d2159e0 0x82c2c32e 0x2ac53f17
Configuration last modified by enable_15 at 03:06:42.416 UTC Fri Sep 3 2004
foundpix1#


foundpix1# sh vpngroup
vpngroup foundation address-pool VpnPool1
vpngroup foundation dns-server 192.168.72.1
vpngroup foundation split-tunnel 102
vpngroup foundation idle-time 1800
vpngroup foundation password ********
foundpix1#


config is same as above - ta.

Andy
0
 
LVL 1

Expert Comment

by:tevens
ID: 11990215
Try adding the following...

isakmp nat-traversal

Then reconnect.


--Tim
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 12092738
Are you still working on this? Do you need more information?
0
 

Author Comment

by:redmayne
ID: 12131160
hello sorry for the delay
i managed to fix it by usin g a portion o9f the same subnet the PC's are connected to
its obviously some routing issue but i reckon as i have found in the past it will be more to do with tnhe box itself than the config

thanks for your help as it was most useful
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 13703135
How's it going? Have you found a solution? Do you need more information?
Can you close this question?

http://www.experts-exchange.com/help.jsp#hs5

Thanks for attending to this long-forgotten question.

<-8}
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Physical Network Design 11 87
Cisco ACS re-imaging with CIMC 2 45
Command "logging persistent size .... " 6 25
Cisco iWAN 8 46
When I upgraded my ASA 8.2 to 8.3, I realized that my nonat statement was failing!   The log showed the following error:     %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows It was caused by the config upgrade, because t…
Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now