ClassNotFound when going through demo

I'm going through the WaterWorks example provided with Notes, trying to learn how to do development. One of the forms in the example has a toolbar at the to with two action buttons, and an area at the bottom with a rich-text field.

Both these areas render correctly in the Notes client (5.0.8), but when I try to display them in Internet Explorer, I'm getting ClassNotFound exceptions for the toolbar with the buttons and for the area with the rich-text field. (The other fields and static text on the form display correctly.) The error suggests I'm missing the lotus.notes.apps.editorapplet.EditorApplet.class file.

Where can I get this file, and where should it be on my system? If I'm missing this, what else am I likely to be missing?

Thanks.
VandanaManneAsked:
Who is Participating?
 
madheeswarConnect With a Mentor Commented:
if you are using iNotes or Mail template, then open the mail file like this:

http://yoursevername/mail/yourmaildb.nsf

this open the mail database. And when trying to access this site, it will prompt a warning messge. Accepct it.

(Since you are facing this problem, it may not prompt. But u can try. What I assume is, you did not downloaded warning msg when browsing your db. And the path(C:\Notes\Data\domino\java ) is nothing related to this issue.

I am sure it is problem with IE.

Upgrade to IE6 Sp2, and try it. And also if it is not succeeded, then degrade to 5.5.  This may work.

0
 
madheeswarCommented:
may be the applet is not loading properly.

I did not saw the example before, so unable to comment.
if you tell what it should do, then I can figure out what causes the problem.
0
 
VandanaManneAuthor Commented:
I created the action bar to display buttons at the top of the form-- SAVE& CLOSE and CANCEL and checked the option in Action Bar properties box to display them using Java applet at Web access. They are being displayed and working correctly in the notes client. Same is happening with the rich text field which I created on this form and checked the option in the field properties box to display it using Java applet at web access. This is the setting that tells Domino to use the rich text applet when rendering this field on the Web.
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
madheeswarCommented:
Folow below solutions:
1) Try to open it from another system.
2) Are you opening it from Server or Localhost?
3) If you put the java applet within a table cell you must manually specify the width and height of the applet. Normally width and height are set to 100% but this doesn't seem to work within a table. Modify the HTMLAttributes for the RTF field to include "width=xxx height=yyy" where xxx and yyy are the width and height values (see the Body field in the Main Topic form of the discussion template for an example). Note that the width should be at least 500 for all of the UI elements to display.

4) try it in Netscape or IE5.5
5) http://www-10.lotus.com/ldd/46dom.nsf/55c38d716d632d9b8525689b005ba1c0/87489c17db3ebcf68525684d006156be?OpenDocument

Thanks
0
 
VandanaManneAuthor Commented:
it is working on the other system but not on mine. I am opening it from local. It is not within in the table but on the form-- all buttons and rich text field. I am using IE5.5.
I guess I am lacking editor and action bar java applets which is giving me error exception.

0
 
madheeswarCommented:
u need to remove JVM from your machine. And then try.

And from the menu of IE, Tools-InternetOptions->Security-CustomLevelbutton-> Enable Scripting->Scriptuung of java Applets.


or Migrate to IE6
0
 
madheeswarCommented:
it is problem with your IE. Since it is working from other PC's, you can draw a conclusion it is working. So, try to solve IE and you will get the result.
0
 
VandanaManneAuthor Commented:
I have migrated to IE6 and have setting of scripting of java applets enabled but still having same problem. What is this JVM stuff which I need to remove? Can you tell me in detail so that I can look into it too. May be this will help.
0
 
madheeswarCommented:
Java Virtual machine will be installed in your PC. Removing that program helped to display applets. This hapened to me on Win2000 OS. So, I thought of telling you.

if you are using XP, I can't be of much help. Still I am searching to solve the same issue on Xp for one of my user.

When open any notes databases which uses Applets extensively like your mail file, it prompts to download Notes applet. U need to accept (click on Yes) and it will load. try to open your mail file and accept the warning message.

Remove entire cache, Temp Internet files, etc.,

Since it is working in other PC's, you should be having XP or you did not trusted the warning message to download applet.

Hope it helps.
0
 
VandanaManneAuthor Commented:
I have win2000 OS and taking out JVM didn't helped. It didn't even opened the form and asked that there is no JVM and gave me option to download on demand.

I don't remember getting prompt to download Notes applet anytime. Is this is the warning which comes up only first time when you open notes databases. How can I open mail file so that it will give me warning which I can accept .....?

I checked that in my C:\Notes\Data\domino\java , I have editor and actionbar .cab and .jar files  which are used by browsers. Domino creates the appropriate parts of the APPLET tag for these files.

Thanks for looking at this problem but it is still hanging over here.
 
ANy other clue?
0
All Courses

From novice to tech pro — start learning today.