Solved

ArcServe 2000 v7 active job will not stop

Posted on 2004-09-03
11
4,118 Views
Last Modified: 2009-05-29
Hello, I have an arcserve2000 v7 where the active job will not allow me to stop it even after rebooting the server and turning the services to disabled.  Any thoughts?
0
Comment
Question by:RDAdams
  • 6
  • 4
11 Comments
 
LVL 15

Accepted Solution

by:
Yan_west earned 400 total points
ID: 11976509
Yes, 1- stop all the engines.
2- go to the job directory in the arcserve directory
3- Delete the job
4- restart the engines
5- Recreate the job.

Update your arcserve to the most recent service pack.. it has been greatly improved.. what build are you using?
0
 
LVL 15

Expert Comment

by:Yan_west
ID: 11976517
btw, the job directory is called 00000001.qsd..
0
 
LVL 15

Expert Comment

by:Yan_west
ID: 11976527
if you want to be sure not to mess up, copy the job in another directory before deleting it..
0
 
LVL 17

Author Comment

by:RDAdams
ID: 11976582
Hi Yan west.  The system is not allowing me to stop the job.....   I have the services disabled and the server was rebooted.  The file asrunjob.exe is stuck and will not allow me to stop the process even after a reboot.  I am trying a kill process or trying to right now.

We are likely going to remove ARCSERVE altogether and go with Backup EXEC.
0
 
LVL 15

Expert Comment

by:Yan_west
ID: 11976647
you disabled all the 3 arcserve services (tape, engine, database), and the asrunjob.exe is still running after a reboot? that's imposible... ??
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 17

Author Comment

by:RDAdams
ID: 11976704
No it isn't as this has been an issue for some time with many reboots.  Are network engineer tried for over a month and gave up and gave it to me to fix.

I wish this wasn't the case.  
0
 
LVL 15

Expert Comment

by:Yan_west
ID: 11976716
did you use the Kill utility to kill the process?

http://www.sysinternals.com/ntw2k/freeware/pskill.shtml
0
 
LVL 17

Author Comment

by:RDAdams
ID: 11977054
tried the kill.exe utility from the windows 2000 resource kit.  It didn't allow me to kill the process by PID but did allow it by the name of the asrunjob.exe.  The server is still not running great so we will try rebooting this evening.  Since it is a production server I need to wait till the users are off it.  

I am going to leave the services disabled to see if this will make a big difference on the server.  

Once I verify it back up I can reinitialize the services and restart the system again.

Then I will try to recreate a job in arcserve for a test tonight.

That is if all goes according to Hoyle!
0
 
LVL 15

Expert Comment

by:Yan_west
ID: 11977060
:) get back to me tomorrow!
0
 
LVL 22

Assisted Solution

by:dovidmichel
dovidmichel earned 100 total points
ID: 11983078
Perchance was this an agent job?

Sometimes it is a hung agent that is keeping the job active. So if this is an agent job database or client agent then try restarting the agent.

Another thing that can cause a job to stay active is if the Tape Engine is waiting on something. The Tape Engine can be stopped by the Service Manager and then the job stopped if that is the case.

You can go the other route mentioned above. Here are a few things on it.
If you have other jobs you do not want to loose select them, then modify and save as.
The job or queue directory is as mentioned is ARCserve\0000001.qsd.
The jobs in there are numbered and so by comparing them with the job number in the ARCserve Manager Job Status window you can identify which job it is you want to delete.
You can set the Job Engine Startup type to Disabled and restart the server.
Then keeping the Job Engine stopped and the Manager closed delete the queue directory.
Once the Job Engine is started and the Manager brought back up the queue directory will be automatically recreated.  

The update recommendation is a very good one and should be followed. Go to http://esupport.ca.com and you will have to register in order to download. Right there on the first page is a drop down product list, select BrightStor ARCserve backup. That will take you to the page where you can select ARCserve 2000.
0
 
LVL 17

Author Comment

by:RDAdams
ID: 12237957
I was able to kill the job once I booted in safe mode.  Deleted all created files and the 0000001.qsd directory.  Started from scratch to get the jobs to work.  

I was running the latest patches and updates for both OS and Arcserve.  We are going to switch to another product in the near future.  Just getting the PO's in place now.

Thanks for all the suggestions.
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Hi, I've made you some graphics for a better understanding how RAID works. First of all, there are two ways a raid can be generated: - By hardware - By software What does that mean? This means: If you have a hardware RAID controller, there…
Problem description :  Some external hard disks / USB flash drives do not show actual space as mentioned in the factory settings. This is a common problem when you use an 8 GB USB drive to make it bootable to install a firmware/ driver on a serv…
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now