Excahnge RPC comunication Error

Hi.
I've two exchange servers. The first one has a Windows NT 4 SP6a with Exchange 5.5 and the Second one has a Windows 2003 Server Std. with Exchange 2003, this exchange was added to the 5.5 Organization using the procedure described in one Q.
Now after installed it, we migrated a few mailboxes usin Move Maibox option from AD. The problem that we have is that these users (on the Exchange 2k3) are experimenting a delay reciving mail.
We found the followings erros:
Event id: 9318
Source: MSExchangeMTA
Type: Warning
Category: Interface
Descripion: An RPC communications error occurred. Unable to bind over RPC. Locality Table (LTAB) index: 32, NT/MTA error code: 1722. Comms error      1722,      Bind error      1722,       Remote Server Name NAVCFEX01 [MAIN BASE 1 500 %10] (14)

Event id: 289
Source: MSExchangeMTA
Type: Warning
Category: X400Service
Descripion:A connection to /O=NAVISUR S.A./OU=Company/CN=CONFIGURATION/CN=SERVERS/CN=SRVEX01/CN=MICROSOFT MTA could not be opened. [MTA XFER-IN 16 26] (12).

Refering the first case we check this:
net view \\SRVEX01    OK
net view \\192.168.0.2 OK
net use \\SRVEX01\ipc$  OK

I would like to know if somebody can help us.

Regards

CRistian
celiberticAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
BNettles73Connect With a Mentor Commented:
Yeah, DNS is the culprit in most cases ... Q266312 points to that ... congrats, glad you got it fixed! =)
0
 
BNettles73Commented:

The MTA uses remote procedure call (RPC), a synchronous socket protocol for intrasite and site connections. The methodology that provides the bind and bind back changes in the post-Exchange Server 5.5 Service Pack 3 (SP3) build 2651.75; the Exchange Server 5.5 SP3 build of the MTA is 2650.24. In particular, build 2651.75 or later of the MTA requires fully qualified domain name (FQDN) resolution for normal operation, which is accomplished with Domain Name System (DNS) or HOSTS files.

Each Exchange Server computer must have a valid host (A) record in either a DNS or a HOSTS file with the FQDN of each Exchange Server to which the Exchange Server computer connects added to the %SystemRoot%\System32\Drivers\Etc folder. Exchange Server 5.5 Service Pack 4 (SP4) and Microsoft Exchange 2000 Server require that the TCP/IP protocol be installed on the server.

I think we resolved this issue between E5.5 and 2K3 by adding the 5.5 servers to AD DNS and setting the domain suffix search orders on the all servers (5.5 and 2K3) ... you need to make sure the MTA's are restarted afterwards ... you may need to reboot the 5.5 servers if you haven't in a while .. I have an article on this issue somewhere ... am looking for it now ...

Also, make sure your bindings are set correctly - put the NIC that the MTA talks over first ... if you have multiple NICs ...
0
 
BNettles73Commented:
Other articles I found on the Event 289 ...

http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_20343623.html?query=event+289+MTA&clearTAFilter=true

FYI - you need to make sure the service account has Send As / Receive As in the domain ... seems like I remember something weird like that at the domain level ... probably worth checking ... http://support.microsoft.com/?id=259221
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell┬« is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
BNettles73Commented:
I meant at the Org level in Exchange 2003, not domain ... kind of late in the day for me lol ...
0
 
BNettles73Commented:
These might help ....

http://support.microsoft.com/default.aspx?scid=kb;EN-US;279537
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q266312
http://support.microsoft.com/default.aspx?scid=kb;EN-US;303156

Summary - make sure all servers are in DNS, Bindings are set right if necessary, reregister DNS servers if necessary, service account has appropriate permissions, suffix search order is set properly if you have multiple domains, flush DNS on your E2K3 boxes  ... try restarting the MTA's on the 5.5 servers, if that doesn't work reboot ...

Hope that is enough information for you!
0
 
celiberticAuthor Commented:
I┬┤ll check all this thinks.
Regards.
0
 
celiberticAuthor Commented:
Well the point was de DNS configuration.
After this was reconfigured, the issue was solved.
Obiusly all your recomendation were checked.

Thank you very much

Cristian
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.