Citrix - VFP6 Published Application

This question began here: http://www.experts-exchange.com/Databases/FoxPro/Q_21118616.html#11977233

I am reposting it here because I feel this is a more appropriate topic area.

We have a VFP6 application that we use locally.  Recently we added a Terminal Server with Citrix Metaframe XP to our network.  I would now like to provide access to the FoxPro application through Citrix.  I created an application set and a published application for the FoxPro application.  I would like to run this in seamless window mode.  My problem is that when I run the published application, the TS desktop is loaded and I receive the following message:

"ICA Seamless Host Agent Dialog box: You have started Windows Explorer in your ICA seamless session. This will obscure your local Explorer desktop. To re-enable this ICA seamless connection, please log off and restart the seamless remote application."

Why is the desktop being loaded?  Is this due to FoxPro, or do I have my published application incorrectly configured?

I have very little knowledge of FoxPro or Citrix.  Any help would be greatly appreciated.

Thanks in advance for you help
tgerman10Asked:
Who is Participating?
 
jbombellConnect With a Mentor Commented:
Check this first:  

http://support.citrix.com/kb/entry.jspa?externalID=CTX644401

Let me know if anything in the doc works for you.  While you do that, I will burn up some more brain cells thinking about what else can cause this to happen.

Good Luck!
0
 
jbombellCommented:
Sounds like either you didn't set the path correctly or you accidentally published the desktop instead of the app.  What is the full path and executable you set for your published application? [ ex: c:\program files\{directory}\{app.exe} ]

0
 
tgerman10Author Commented:
jbombell,

The path for my published app is F:\VP10\VPW.exe.  I have the desktop publised also, but currently no users have permissions to run it.
0
 
tgerman10Author Commented:
jbombell,

Everything seems to be working fine now.  I can't explain why...  I read through the document you provided and checked all of the settings it discussed.  I didn't change anything (that I know of), but after I completed all of the steps in the article my published apps started working correctly.

Thanks for your help!
0
All Courses

From novice to tech pro — start learning today.