Solved

Crystal Reports 8.0 keeps asking for password... very annoying.. HELP!

Posted on 2004-09-03
17
1,418 Views
Last Modified: 2008-01-09
Hi folks..

This is my first post here, so please bear with me.

Right now, we recevied some new computers so I had to install ADP Payroll software on their computers first. Within that, it installs ORACLE 8i. After that, I instaleld Crystal Reports 8.0 and had trouble connecting to the ODBC connected to it because it was running XP.. so installed this patch.. and the new p2sodbc.dll file.. a discussion of it can be found here...

http://support.businessobjects.com/library/kbase/articles/c2007581.asp

Now everytime we refresh CR reports, it asks for the password and prompts for it. It is very annoying after the fifth time.. it's frustrating!

Here is a clue...I had to remake a new SYSTEM DSN under PEPS1 instead of the original PEPS because somehow PEPS settings never get saved...

Thanks in advance!
0
Comment
Question by:kitkit201
  • 8
  • 6
  • 3
17 Comments
 
LVL 10

Expert Comment

by:ebolek
ID: 11978349
Try to create your report with integrated security. Then user's windows login info will be passed to the report. While creating the report ther eis a checkbox secure login or close to that. Check that box. That will force your reprot o use integrated security other than sql authentication. If you have to use sql authentication and dont want to receive that dialog box, you have to write a small application and set the username and password in runtime.

Do whatever makes you happy:) That is the only two path you can go

Regards
Emre
0
 
LVL 42

Expert Comment

by:frodoman
ID: 11979781
When are you being prompted for the password - is this while using Crystal developer or when users are viewing reports from an application or when viewing compiled report, etc.?  Please let me know as that will narrow the range of possibilities.  Also, which Oracle driver are you using?

frodoman
0
 

Author Comment

by:kitkit201
ID: 11980400
Frodoman-

The prompt is when users are in CR 8.0. As they refresh attributes from the database, they are repeatedlly prompted for the service name, username and password.  The password field is blank.

I believe we are using Oracle 8i as the driver.. it is automatically installed with ADP payroll software.
0
Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

 
LVL 10

Expert Comment

by:ebolek
ID: 11981574
as i told you before why dont you use integrated security.

Regards
Emre
0
 

Author Comment

by:kitkit201
ID: 11983154
How do I go about doing that specifically? Can you give me a clue on how to do that ..

Thanks!
0
 
LVL 10

Expert Comment

by:ebolek
ID: 11983181
sure when you set your datrasource

the dialog box comes up right. Over ther eit asks you to neter username and password. There must be check box saying that secure logon, or integrated security,
Something in those lines. Check that box. Then you will see that user name and password text boxes are disabled because crystal will use your windows logon username and password for the report. If th user have access then they will get acess to the report.

Regards
Emre
0
 
LVL 42

Expert Comment

by:frodoman
ID: 11987068
So with Crystal open, is it prompting only when they refresh the report or when they make changes to a report (such as adding fields, etc.)?  

Oracle 8i is the database - there are several database drivers that you can use to connect to it.  Most likely either Oracle's native driver or the Microsoft ODBC?  When you remade your system DSN you would have selected the driver to use as the first step to creating the DSN.  If it's Microsoft or Oracle then it doesn't matter but I've seen other people have problems with other drivers & crystal.  Add to that the fact that CR8 has some know bugs when used with Win XP and it could just be a minor incompatibility problem.

Emre - There is no integrated security with Oracle 8i.  There's no way around sending authentication parameters - you either have user's enter it manually or you pass it with code.

frodoman
0
 

Author Comment

by:kitkit201
ID: 11998148
Frodoman-

That is exactly  my problem. Whenever I refresh or change values and try to access the oracle database, it prompts me with entering the password... every single time. It's annoying to say the least ... any help would be appreciated...

I am using the Oracle ODBC drivers 8i in System DSN for it...

I have increased the point value to 150.. i need help on this ASAP!
0
 
LVL 42

Accepted Solution

by:
frodoman earned 150 total points
ID: 11998848
You can try this 8i fix that Crystal (Biz Objects) released for the native driver:
http://support.businessobjects.com/communityCS/FilesAndUpdates/cr8_746.zip.asp

Or for the ODBC driver:
http://support.businessobjects.com/communityCS/FilesAndUpdates/cror815.zip.asp

I suspect that it's a driver-related problem and you still haven't indicated which driver you're using.  Odds are it's one of these though so hopefully these updates will help you.

frodoman
0
 

Author Comment

by:kitkit201
ID: 11998910
Frodoman-

I'm going to try out both of your links you gave me tomorrow because of the overlapsing busy holiday workday today.  Thanks and I'll get back to you.

Kit
0
 

Author Comment

by:kitkit201
ID: 12010723
Ah okay-

I still haven't tried those .dll drivers yet, but the prompt window that shows up says...

"Oracle8 ODBC Driver Connect"
The servicename and username are filled in, but the password isn't.

the driver version is 8.1.7.0.0

0
 
LVL 42

Expert Comment

by:frodoman
ID: 12010749
That would be the second of the two links I posted that you'll want to give a try.
0
 

Author Comment

by:kitkit201
ID: 12011522
I installed the second .dll files, but how can I make it so that it selects 8.1.5 driver, versus the 8.1.7 driver..  can't seem to find it under "System DSN"

Thank you for your help so far frodoman.. I really appreciate it!
0
 

Author Comment

by:kitkit201
ID: 12011670
Here is another weird thing...

Under Oracle 8i->Net8 COnfiguration Assistant, when I went in and try to delete an old service name, MARTIN12121, it seems like it cannot be deleted. Pressing "next" repeatedly does nothing ....  if I repeat the same procedure under MARTIN, it prompts for confirmation...

The same goes for the testing option... it seems like it left some kind of trace, and after I ran the webfix, it can't seem to erase it's old service name or something...??

When I went into regedit... I searched for MARTIN and MARTIN1 ..

*some background on why it was named: (the two service names I named because it couldn't find MARTIN initially, so I did the webfix from my first post above. So the name was "taken" or something so I had to rename the Data Source name Martin1. And so that is how I keep getting that constant prompt for logon thing is..*

So, I found MARTIN and MARTIN1,... it was under MYCOMPUTER\HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI , but when I clicked on MARTIN, I got a popup window that said.. "Error Opening Key".. (X) Cannot open MARTIN: Error while opening key... I can right-click it and try to delete it, but it gives me another prompt that says I cannot delete it either........ AHH! This must be the problem....
0
 
LVL 42

Expert Comment

by:frodoman
ID: 12017409
Have you tried booting into safe mode and then deleting it?  Sounds like either something is corrupted or you have a service or application that is grabbing a connection.  Hopefully deleting in safe mode will a) let you delete it and b) identify the process causing the problem because it'll probably throw up an error when you reboot normally and the odbc connection no longer exists.

frodoman
0
 

Author Comment

by:kitkit201
ID: 12032082
I couldn't delete it in safe mode, but i found out that i had to give myself ownership under regedit.. permissions.. advance... ownertab.... but i still awarded the points to frodoman..

Thanks much frodoman! :)
0
 
LVL 42

Expert Comment

by:frodoman
ID: 12032121
Glad to help - frodoman
0

Featured Post

Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question